S-10 Forum banner

s15

  1. V8 Discussion
    Hi guys! I tried using the search option, but I couldn't find anything with pictures or detailed help. I have a 1988 S15 that I put a Vortec 350 in. I'm having trouble putting the radiator in with the fan. I read on here that people like using the corvette Rad More Information for APDI/PRO...
  2. S10 / S15
    Any speeds above 60kmph the truck vibrates once i let go of the gas pedal, the vibration also goes away when i put it into neutral at speeds above 60kmph. I also hear a clunking noise, the faster i press down on the accelerator the louder the clunk noise gets, could this be the ujoint?
  3. Heating and Air Conditioning
    I recently bought a 1st gen 1994 s15 Jimmy. The people who owned it before me told me that the fan wont work for the heater unless you hit the top of the dash hard with your hand. Im wondering what the cause of this could be. I tried searching the forums and around online for what the issue...
  4. S10 / S15
    Hey guys, got a signal light problem, the truck signals left normal and when I signal right it does not signal at all but when I push the 4ways all the lights work, what could be causing this? Thanks in advance
  5. Member Projects
    Hi guys, I've posted in a few different spots in this forum, but I figured I should start my own thread with my build progress & to document everything. So, here we go. I acquired a free 1988 S15 from my neighbor who had it stored on his property after it died on him driving on the freeway...
  6. Electrical / Lighting
    Just picked up a 2001 S15 (4.3/auto/2wd) that'd been sandwiched front and back in a wreck, but only cosmetic damage. I drilled out the ignition lock and replaced it with an AutoZone Dorman one, so that's new. I hooked up my battery charger to goose the battery and see if it'd crank. Everything...
  7. S10 / S15
    Hi first post here, hopefully there isn't a thread already on this (or something similar) i tried using the search bar. I got gifted from my neighbor a 1988 S15. He said it wasn't running, and the thought a head gasket went bad. I pulled the head, and there is a hole in one of the pistons. I got...
Top