S-10 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-5 of 5 Results
  1. 262ci Forum (4.3)
    Hello S10 Community. I'm new here, and have perused many, many forums and threads, looking for an answer to my question, but didn't find any. So, here goes... I have a 1992 Chevy S10 Blazer with the 4.3 V6 . When I first start it up from a cold start, it high-idles for about 1 minute until it...
  2. 262ci Forum (4.3)
    Thinking about boosting my 4.3 02 S10. I've been reading a lot about people who boosted theirs but all the threads are 10+ years old. Is there anything new on the market for super/turbo charging the 4.3. If so what is the best for making good power while keeping it dailyable
  3. S10 / Sonoma
    I'm rebuilding the 4.3 that is in my 03 S10 and I would like to get more power out of it. I need help on finding the right parts for my build. There is also a chance that I will put a turbo on it after I rebuild it. Any help will be great help. Thanks
  4. S10 / S15
    I have this 1998 s10 with the check engine light so I hooked up the obd2 scanner and it reads half way before error. its 4.3 vortec 2wd. Replace PCM and it has power at 3 ports. Unplugged all engine sensors one at a time to see if it was a short but still hasn't worked. Checked air bag and seat...
  5. 2.2L - 2nd gen 4-banging
    2000 2.2 s10, 270k miles So Ive been trying for along time fixing a p0171 code, (rough idle, rarely dies at a stop, slow accelleration and towards the end staryed bogging down on hills) replacing parts, new intake gasket, cleaning TB etc, till finally a coworker hooked up his fancy snapon code...
1-5 of 5 Results
Top