S-10 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-11 of 11 Results
  1. 60v6 Forum (2.8/3.4)
    So I just got this s10 Tahoe edition truck ,Dude told me the starters going out no biggie right?. I just pushed started it. shortly after wards Got it in the drive way. Replaced the starter, She cranks but won’t start!…So I hopped on the forums. Then replaced the ICM and Coil. Still nothing...
  2. 2.2L - 2nd gen 4-banging
    Hey guys my 97 s10 2.2 L will crank but not start. A family friend hooked his computer up to it over the summer and I believe it had low fuel pressure. I have replaced the fuel pump and fuel filter. I think I’ve heard the fuel pump engage before but not all the time, idk if it does if it’s...
  3. 2.2L - 2nd gen 4-banging
    Hey guys I’ve got a 97 s10 2.2L manual drive and I’m trying to figure out what’s going on. I had someone come over and checked the fuel pressure with their computer and it was a little low. I’ve changed the fuel pump and fuel filter. I have spark. The truck does run if you spray starting fluid...
  4. 262ci Forum (4.3)
    Looking for ideas on what might be wrong. 2001 S10 ZR2 165,xxxMiles. Intake manifold gaskets blew a while back, was in process of changing them when, literally putting manifold back into top end and was arrested. Long story, it sat that way for 2 weeks. I pulled it apart recleaned everything...
  5. 262ci Forum (4.3)
    Hey I think I might be in the wrong Area so I apologize first.... If there is a way to move me to the correct place please do so. I have a 1998 Chevy S-10 4.3X and for the past month I noticed it's sometimes really hard to start... (for example - sometimes fires right up, other times it will...
  6. S10 / Sonoma
    My 01 Sonoma was running great no issue. I drove about 5 miles to my house. As I pulled in the truck just shut off. As if I had turned the key. Now it will crank but won't start. I replaced fuel pump and filter. Still nothing . I can put starting fluid straight through the throttle body and it...
  7. 262ci Forum (4.3)
    I'm at a loss here...97 gmc jimmy 4.3l 4x4. Died while driving. Truck will crank but not start, however it will start on starting fluid (dies once the starting fluid is consumed). New fuel pump (tested 62psi, and holds it), new fuel filter, new spider/injectors. Everything points to a fuel...
  8. 262ci Forum (4.3)
    wasn’t sure what thread this should go in but i have a 1999 s10 4.3 and it struggles to start, i’ll have to turn it over for like 5-10 seconds then tap the gas pedal a bit for it to start i don’t think it’s the starter since sometimes it does start right up. i also have replaced the fuel filter...
  9. Articles - Engine, Core
    Hello everyone I have a 2003 Chevy s10 4.3 & recently I been having a problem where when the truck sits for 4 hours or so the truck doesn’t start unless I press the gas straight to the floor (fuel injected vehicle). After that it runs at high rpm and almost sounds like I have a cam (which I...
  10. 262ci Forum (4.3)
    Anyone have experience with a "plug and play" ECM replacement? If so, do you have any vendor recommendations? Or perhaps any alternative routes to ECM programming? The vehicle: '94, 4.3L, V6, 206k miles The challenge: Crank, but no start. Prior to that - random stalling, intermittent...
  11. S10 / S15
    With this forum and a few YouTube videos I was able to fix my 1990 S15! So I decided to join and say a thank you! Conditions: (1) hard start generally (2) rough idle after sitting for a couple days (3) recently replaced two speakers, while doing this I ran down the battery (4) found a melted...
1-11 of 11 Results
Top