S-10 Forum banner

crank no start

  1. 262ci Forum (4.3)
    I'm at a loss here...97 gmc jimmy 4.3l 4x4. Died while driving. Truck will crank but not start, however it will start on starting fluid (dies once the starting fluid is consumed). New fuel pump (tested 62psi, and holds it), new fuel filter, new spider/injectors. Everything points to a fuel...
  2. 262ci Forum (4.3)
    wasn’t sure what thread this should go in but i have a 1999 s10 4.3 and it struggles to start, i’ll have to turn it over for like 5-10 seconds then tap the gas pedal a bit for it to start i don’t think it’s the starter since sometimes it does start right up. i also have replaced the fuel filter...
  3. Articles - Engine, Core
    Hello everyone I have a 2003 Chevy s10 4.3 & recently I been having a problem where when the truck sits for 4 hours or so the truck doesn’t start unless I press the gas straight to the floor (fuel injected vehicle). After that it runs at high rpm and almost sounds like I have a cam (which I...
  4. 262ci Forum (4.3)
    Anyone have experience with a "plug and play" ECM replacement? If so, do you have any vendor recommendations? Or perhaps any alternative routes to ECM programming? The vehicle: '94, 4.3L, V6, 206k miles The challenge: Crank, but no start. Prior to that - random stalling, intermittent...
  5. S10 / S15
    With this forum and a few YouTube videos I was able to fix my 1990 S15! So I decided to join and say a thank you! Conditions: (1) hard start generally (2) rough idle after sitting for a couple days (3) recently replaced two speakers, while doing this I ran down the battery (4) found a melted...
Top