S-10 Forum banner
brakes
1-12 of 12 Results
  1. Wheels, Tires & Brakes
    Hey everyone! Need some insight on a brake issue. Did the front brake blazer upgrade on my 2000 S10 pickup and added an LSMFG disk brakes kit on my 8.8 in the rear. Been trying to get my brakes bled for the past few weeks and have not been successful. We tried the following: 1. Conventional...
  2. Xtreme / ZQ8
    99 s10 xtreme 4.3l 2wd ext cab Just installed “little shops” GM Late Style S10 & Midsize Rear Disc Brakes and i cant get my brake pedal to feel right. 0 air in the lines. Ive read all sorts of things about “proportioning valves” and “abs systems” Very confused. Anyone else have the kit? What...
  3. S10 / S15
    I have recently got a 1984 s10 base model and I’m having problems with the brake pedal not returning. It returns fully and compresses the brake light switch occasionally but other times has to be held up to avoid draining the battery. I don’t have any springs on my brake pedal assembly and have...
  4. S10 / S15
    Hello everyone! Got a 1994 Extended Cab S10 2.2 5 Speed. Recently did new brakes, rotors, and wheel bearings on the front end because the pads were worn out and I had a warped rotor. It went well and I had no trouble until I decided to check what temperature the wheels were after a run to make...
  5. S10 / S15
    Hey everyone! I drive a 94 s10 "LS" trim, extended cab, 2.2L RWD with 5 Speed Manual. It has various minor issues that I've been working on but it's a solid truck. One of those issues is ABS. Now, there's no codes or anything being thrown about ABS (it only throws codes for EGR and Lean Exhaust...
  6. Wheels, Tires & Brakes
    Thanks in advance for any advice. Short version: When the engine heats up, both front brakes apply and continue to drag until the engine temperature comes down. NOTE: Updated 11/9/2020 - After some additional testing, this is not a 'heat' problem. The brakes apply intermittently but release...
  7. Xtreme / ZQ8
    These brakes are shafting me and it's driving me crazy! Got my 2004 Blazer Xtreme with the knowledge of the brakes beginning to stick, no big deal, it's brakes Changed all calipers, hoses (except carrier hose) pads, rotors seemed okay so left them for now. Trying to bleed the system and...
  8. Electrical / Lighting
    I just finished replacing both wheel hub assemblies on my 2002 S10 because of bad wheel bearings. Now that everything is back together, the key won't turn, even to running position. It turns just a little bit, enough to show green-lit gear display and odometer. No power to windows or radio. The...
  9. Wheels, Tires & Brakes
    1985 2.8 v6. durango rwd. Started her up.. release ebrake.. warning light stayed on. Didn't think much of it until I put it in reverse and had no brakes and no ebrake. I am guessing that the something busted in the ebrake assembly and that I have a leak in a brake hose. does anyone have a...
  10. Wheels, Tires & Brakes
    Ok guys I'll try to keep this short. I have a 2003 S10 ZR5. I installed new front rotors and pads, during which I had removed the calipers to clean them up a bit. I let the disconnected front brake lines bleed out. After reinstalling the calipers and bleeding the lines the pedal was extremely...
  11. Wheels, Tires & Brakes
    Hey everyone, I have an 01 Sonoma 2.2L and over the past few months the back wheels have been locking when I first start for the first 3 or so brake applications. It has been getting progressively worse and now it happens really bad after everytime I drive the truck. I just replaced the wheel...
  12. S10 / S15
    Hey all, I have a 2002 S10 4.3L V6 2wd. The truck is clicking when I brake, turn left and go over speed bumps. The clicking is only coming from the front left hand side of the vehicle though. Sometimes it clicks once and sometimes it'll click 3-4 times. It sounds like metal on metal but I'm not...
1-12 of 12 Results
Top