S-10 Forum banner

4.3

  1. What the heck is this plug under the battery for?!?! Please help!

    S10 / Sonoma
    Just about done rebuilding my 4L60E for my 2000 4.3L S10. To get this transmission ready to put back in I am cleaning all of my grounds. I removed the battery and bracket it sits on to get at the grounds and I found a plug just lying on the chassis not plugged into anything. I cannot figure out...
  2. New here......4.3l wake up

    262ci Forum (4.3)
    Hello everyone I'm new to the forum and sorry if I'm not posting in the right spot but I just picked up a 2003 s10 step side, with zq8 option 122000kms(76000miles) I'm looking to wake up the 4.3 any suggestions????
  3. Help!!!!! 4.3 Hard starting

    262ci Forum (4.3)
    Hello my truck has recently started hard starting every time I go to start it. The exception to this is when I get gas right after I get gas will start fast no problem like before but before I really even get down to 3/4 tank it will do the same thing as before. It also has a rougher idle than...
  4. Need some ideas for vehicle diagnosis.

    262ci Forum (4.3)
    I have a 91 s10 blazer with the 4.3. Occasionally it had white smoke out of the exhaust, but it was mainly noticeable in park or when stopped at a red light. The coolant levels are consistent and haven't needed to be topped off. It has a slight misfire during idle in park, but runs rough in...
  5. Cam

    262ci Forum (4.3)
    So I want a cam that’s going to increase hp and torque that’s reliable and I don’t have to do any machining or valve train work to. Any suggestions on cam options or what specs I can get away with? I have a 2000 zr2 4.3
  6. Help! Broken coolant line on intake

    S10 / S15
    Ok, so I bought a 93 s10 with a 4.3. While messing around changing plug wires and checking some other stuff I managed to bump the coolant line that goes to the back of the intake beside the distributor. Any good ideas on how to get this out and after/if I get it out, can I just plug it off? I...
  7. Engine Help and Future Planning Help

    S10 / S15
    So I've got my 95' S10 still running good. About to replace the front discs and rear shoes. I previously stated I would do a rebuild, but I've decided against it. I want to go for a crate motor. From what I've seen, it's cheaper and has what I want to do with my truck. My major issue is that I...
  8. Messing with starter

    262ci Forum (4.3)
    May be simple may not be. I bought a 97 s10 4.3l 5 speed about a year ago it’s super sketchy but runs, has what looks like a kill switch under the dash and everything else. Every now and then it seemed like the starter would skip so i popped it off and it was only held by one of the two bolts...
  9. 91 4.3l oil consumption, burning oil, constant smoke

    262ci Forum (4.3)
    I have a 91 Chevy C1500 with a 4.3l out of a 93 astro van that burns oil badly, it smokes upon start up and I just noticed tonight that it was smoking when I was driving. I've got oil all over the underside of the engine, the trans and almost everything in between. Just did an oil change and put...
  10. 97 s10 4.3 won't start

    262ci Forum (4.3)
    Was backfiring and would not stay running , had it towed home and it sat for roughly 6 months now will not start at all. Any suggestions would be greatly appreciated, I hope it's nothing too serious
  11. 4.3 vortec parts

    4.3 vortec parts

    What is a fair price for bulk? Block has seized crankshaft but everything else is good.
  12. surging at shift, bunch of codes. '97zr2

    262ci Forum (4.3)
    Thanks for this great site. i think i've read most of the posts dealing with engine surging, but mine has trouble codes that are different. '97 zr2, 4.3, 250k miles. has been surging badly at shift points when 1600-1800rpm. idles fine. codes are listed below. thanks for a review suggestions...
  13. Electric fan on 4.3 vortec

    S10 / Sonoma
    I recently had to replace my fan, both shroud pieces, and radiator. they were on about a week and a half and the fan tore the shroud up again. no its not my motor mounts. i cant afford to keep replacing these parts so id like to move to an electric fan system. its a no brainer at this point...
  14. Issues with cooling system

    262ci Forum (4.3)
    Alright, I have a 02 Sonoma 4.3 Vortec automatic, extended cab with 240,000 miles. Currently I'm having a few odd issues and I'm having trouble figuring out if they are connected in some way. Here's my laundry list of problems with it. And attempted solutions -When my engine temperature hits...
  15. PatsBlueXtreme

    PatsBlueXtreme

    I looked for a good while to find this one. When I first saw it I was sold on it. Even more so when I drove it. The blue is so dark that it looks black at night. In the day it reflects the blue of the sky and looks even better. Of course it was only 4 1/2 hours from my house to go look at the...
  16. 91 s10 2wd 4.3 standard cab pickup with th400 swap driveshaft (HELP)

    Transmission & Rearend
    Hey guys im new to the forum. I have a 2wd 91 s10 4.3 that i put a th400 in. Im having a problem figuring out the driveshaft. I cant afford to have one made. By any chance has anyone here done this swap in the same truck? If so do you know how long the driveshaft was? Are there any cheaper...
  17. Posi doesnt kick in very well

    Transmission & Rearend
    Howdy, on my 96, rwd, 4.3 posi doesn't kick in most of the time, it will usually kick in but has to be very high rev range and I get the usual embarrassing 1 wheel peel. I don't really know what to do about the rear end, install new clutches? what are your recommended rebuilt kits if that's the...
  18. P0303 cylinder 3 misfire after engine swap

    262ci Forum (4.3)
    I have a 2000 s10 zr2 blazer with the 4.3L Vortec Only code is P0303 Due to low pressure issues and backfiring I picked up the engine and transmission out of a 80k mile 2000 gmc jimmy and my father and I swapped both in. We replaced all spark plugs and plug wires, new cap and rotor, complete...
Top