S-10 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-5 of 5 Results
  1. Transmission & Rearend
    Hey there, I've got a 2001 s10 (4.3L V6) and it's throwing me the p1870 code and I cannot currently drive it. I got the code a couple weeks back, cleared it, and it did alright for a couple weeks. However, when I was on my way to work last week I had to come home. It was slipping harder than it...
  2. S10 / Sonoma
    I recently bought an 01’ crew cab LS with a lift, I believe 2” plus 32” tires so a overall lift of 3” or so… I’m looking to get new shocks because I’m 99.9% sure the previous owner kept the stock shocks on it; they look original and they ride like absolute crap. What would you guys and gals...
  3. 2.2L - 2nd gen 4-banging
    2001 ext cab 2.2L, 5 speed. After changing the oil I noticed this hose not connected to anything and not sure what it's connected too. Any help would be appreciated!!
  4. 262ci Forum (4.3)
    General Description and Symptoms This all started when the EGR valve wiring got messed up (by a rodent? Found a mouse nest in the air box), disconnecting the position sensor, and would fully open and close rapidly, resulting in extremely jerky acceleration. I've since installed a blocker plate...
  5. S10 / S15
    I have motor trans and radiator and some what a of a drive shaft all I'm missing is rear end and motor accessories like headers an what not .. my ? Is will I have to switch the peddle assembly and knock the fire wall in
1-5 of 5 Results
Top