S-10 Forum banner
2000
1-6 of 6 Results
  1. Electrical / Lighting
    Hey all, I cannot for the life of me find a OEM replacement under-hood wiring harness for my 2000 S10 4.3L 2WD with a 4l60e auto trans. The auto electrical shop I took my truck to quoted me 4k to replace the harness and $1600 to repair the old one to "like factory". I can't justify that as I...
  2. S10 / Sonoma
    Bought this truck a couple months ago and I've been having some problems. When I went to get it inspected I was waiting for the guy and I started leaking fuel from the Vent Valve that apart of the EVAC system. Luckily it was outside of the mechanic so I had them "fix" it which they didn't do and...
  3. Exhaust
    While in the process of replacing a broken exhaust manifold, we encountered this pipe that we cannot identify but think we are going to have to replace too, as it seems the old manifold's bolts are too rusted. It is connected to the manifold tubes and runs farther back into the truck. Anyone...
  4. S10 / Sonoma
    Hi, I'm looking at buying a 2000 Sonoma, single cab, short bed, 4.3 vortec + 5spd at 140,000 miles. I've already searched the site for all the warnings. What are some things to look for and ask? I already know to check frame for bends underneath, rust, and checking the fluids but other than...
  5. Electrical / Lighting
    I recently installed a new stereo in a 2000 s10 for a client, it had no radio installed when they bought it but it was obvious the previous owner had an aftermarket stereo,amp, and sub installed previously. All of the aftermarket stuff is disconnected but the wires are still present. After I...
  6. 262ci Forum (4.3)
    I have a 2000 Chevy s10 that won’t start without starting fluid. We’ve changed the fuel pump Distributor cap Starter Spark plugs Fuel pump and filter And the fuses to the fuel pump and such Yes the engine is getting gas we checked but it’s just not starting up without fluid At first it...
1-6 of 6 Results
Top