S-10 Forum banner

Reaction score
14

Profile posts Latest activity Discussions Media Albums About

  • XonAir ·
    Yo Dave!,

    What's happening man? So I'm trying to do mass deletion, can you delete all threads started by me? " They offend me" lol
    timster ·
    Hi, my member name is timster, but that would show up in this message. Anyhow, I would like to post but other than my intro post I am blocked from posting. I getting messages saying:

    "timster, you do not have permission to access this page. This could be due to one of several reasons:
    Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
    If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation."

    I entered my activation code, so not sure why I could make the intro post and not any further posts.
    bradtech519 ·
    Hello, I have signed up and unable to post in threads even as replies. I posted in new member forum a month ago & it states my account is activated. I also started using an avatar. Would like to participate & post some questions about my 1993 S10 or talk to others about their First Gen S10s. I've been doing a lot of troubleshooting & everything keeps coming back to this forum. Would like to be able to participate and get input/give input.

    Thanks!
    mferrari ·
    Just joined. Was trying to make a post in the Project sections for my 4wd, Sonoma, 55 chevy project I am working on. Was going to start a build thread to share and get input from guys that know s10s a lot better than I do. Anyway to get permission to post?
    toolman62 ·
    hows it goin bud, I have a post in the body dropping it form called "project dwn tym" but would like it moved to the project form. is that something you can handle for me or how would I go about doing that.
    DangerRanger ·
    Requesting account activation. I've tried to post and reply to other member thread (Like that awesome bagged s10 build) but keeps telling me i have no permission to do so
    Steve-Z ·
    The Admin told me I could post, but when I go into the "LSX Discussion" and attempt to start a new Thread, the system says I do not have permission to start a new thread. What do I need to do to be able to start a new thread? I want to ask the forum members questions about my plan for putting and LS engine in my 2003 S-10 truck. Thanks
    joem67 ·
    i see you know about s10's & motors.. I'm getting p0300 code since I bought my 2001 xtreme last year.did full tuneup,plugs,wires,cap,rotor,updated spider injectors,egr valve,2- 02 senors,fuel filter.. took to midas & they checked the cat's & temp was 380*.. seems a bit low to me ,,,said their fine. can't figure it out. it also has a little miss at idle.when i did plugs did compression test & got 170 lbs. on all cylinders.can you help me.. [email protected] or give a ring.732-425-6485 thanx..gas milage was 9.3 now it's 13.3 it sucks.. planning on selling truck..can't afford gas for it.. gorgeous truck though..just turned 100,000 miles
    Dead End Kustumz ·
    Would like to change my user name and am not sure what I need to do to change it if u could help that would be great trying to change DEAD END KUSTUMZ to DEAD END KUSTOMZ
    s10slave ·
    Hey sorry to bother ya but i have a question or two about doing a bd on my 96 s10 4.3 5 spd reg cab. Im looking to lay rocker ive got the mmw uppers im doing shocks but kinda confused about what to do with the steering when bd'ing
    jesseltaylor41 ·
    im new to bagging blazers an i have an 02 xtreme that i want to bag like you did on the white blazer without doing a c notch like it. What would be the best way to do this and what air ride kit should i use thanks.
  • Loading…
  • Loading…
  • Loading…
  • Loading…
  • Loading…
Top