HELP!!!! 2.8L TBI rough idle and other issues - S-10 Forum
 
LinkBack Thread Tools
post #1 of 1 Old 04-25-2019, 10:04 PM Thread Starter
Registered User
 
92BlueLightning's Avatar
 
Join Date: Feb 2019
Age: 30
Posts: 14

User is: 92BlueLightning is offline
HELP!!!! 2.8L TBI rough idle and other issues

Hey guys I need some help figuring this out. I have a 1992 GMC Sonoma with the 2.8L V6 with the throttle body and manual transmission. So I have have replaced the plugs (I also just check the plugs again a couple days ago to see it there is any damage to them and found oil on cylinders 1/2/5/6), wires, distributor cap/rotor, TPS, and IAC thinking it will stop the rough idle and the weak takeoff. When I start it up it idles as if there is a misfire and when it warms up it has a huge amount of power loss. Also when I take it up to interstate speeds (anything greater then 60) and shift into 5th gear it immediately starts to lose power and speed. The truck has 261k on it and still fires up with very little issue. Sometimes when I start it, it just keeps turning over until I put the accelerator to the floor, then it will start. I have done everything I can think of to fix the issue and have had no luck with it and am wondering if it's the electrical or something else. If anyone has a clue to what it is, I would greatly appreciate the help.

92BlueLightning is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome