4.3l tbi - S-10 Forum
 
LinkBack Thread Tools
post #1 of 2 Old 10-13-2014, 11:27 AM Thread Starter
Registered User
 
Join Date: May 2007
Age: 36
Posts: 37

User is: bandz7 is offline
4.3l tbi

Hey everybody. I'm in an incredibly slow process of a 3.4L swap in my 86 5 speed jimmy. Saturday at the junkyard I found a nice 4.3 TBI located on an s10 and I decided to grab it since I didn't see any astro vans around. It was from an 88 or 89. I can't remember, but it has the same connectors as my 86 so no splicing wires. so this is where I'm confused. It has 4 vacuum ports. I was under the impression it would only have three and that I would have to drill on in. Did I get lucky or are all the older 88 and 89 tbis have this?

bandz7 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-15-2014, 01:51 PM
Awww..you ain't got shit!
 
jimmykicker's Avatar
 
Join Date: Nov 2005
Location: McCalla, Alabama
Age: 48
Posts: 3,242

User is: jimmykicker is offline
Re: 4.3l tbi

I think some of that is bs man...I pulled mine off a late 90s Astro and it was supposed to have 3. It had 2...I wouldn't question it...Since it came off an S-10 you should be plug and play...



1984 xcab s-10 3.4L GM crate engine 91 S10 TBI swap w bored intake, Edelbrock headers. 2" Rough Country Lift. Custom exhaust, shift kit, e-fan.


EFI swap https://www.s10forum.com/forum/f106/...e-help-513616/

My build thread (3.4L)https://www.s10forum.com/forum/f106/...stions-427168/
Quote:
Originally Posted by Racer_X View Post
I had to cut my nut in half .
jimmykicker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome