2.8L vibrations - S-10 Forum
 
LinkBack Thread Tools
post #1 of 2 Old 07-31-2015, 11:57 AM Thread Starter
Registered User
 
Join Date: Jul 2013
Age: 23
Posts: 47

User is: woodmaster69 is offline
2.8L vibrations

So I drive a 92 s10 with a 2.8. And just recently it has started vibrating at around 1300-3500 rpm. It even does it I'm neutral so it isn't the driveshaft. It even sounds different. Any ideas of what it could be? The engine seems to be lopey at idle. Very uneven. Could it be bad spark plugs?

woodmaster69 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-31-2015, 12:27 PM
Registered User
 
S10tahoe28's Avatar
 
Join Date: Mar 2015
Age: 25
Posts: 127

User is: S10tahoe28 is offline
Re: 2.8L vibrations

Could be misfiring. Check all plugs, wires, cap and rotor first. I know mine had a broken spark plug wire and wouldn't even move over 1500 rpm. Wait until it's dark and see if you see any arcing as well. It's not hard to miss


Sent from AutoGuide.com Free App
S10tahoe28 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome