Need help!!! 2.2 3rd Gen. - S-10 Forum
 
LinkBack Thread Tools
post #1 of 11 Old 04-08-2019, 12:36 PM Thread Starter
Registered Users
 
Heathen240's Avatar
 
Join Date: Nov 2018
Posts: 7

User is: Heathen240 is offline
Need help!!! 2.2 3rd Gen.

So here the gig. I have a 2003 2.2 3rd gen 5 speed s10. Single cab short bed I bought maybe 4 months ago. This truck has been amazing to me up until about 2 weeks ago. I noticed when i was driving just cruising along I noticed it would jump/buck/kick under very light throttle. Now when I accelerate it goes away like nothing ever happened. So not being to worried about it I dumped some injector cleaner in it thinking it was just some dirty gas or injectors... Nope. Nothing. It still kicked and bucked under light throttle. So far IV changed. Spark plugs, wires, air filter, fuel filter, tps sensor, cleaned throttle plate, checked for vacuum leaks, checked the trottle cable for any ware or slack,... Theres probly something else iv replaced or tested but I just can not figure out the problem. Other then that the truck runs like a top. Its not fast I havent noticed a loss in power. I mean its a 110hp 4 banger. Any help will be very appreciative. And something else. No service or money light. Ran a diagnostic and its clear of codes.

Heathen240 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 04-08-2019, 05:32 PM
Chopper! Sic balls!
 
Mostizzle's Avatar
 
Join Date: Aug 2009
Location: Walkin' the tracks
Posts: 39,226

User is: Mostizzle is offline
Re: Need help!!! 2.2 3rd Gen.

Hard to say without the truck in front of me. It could still be tired or dirty injectors. Technically there is no "3rd gen" though fyi.
Mostizzle is offline  
post #3 of 11 Old 04-08-2019, 06:24 PM
always something new
 
S10dude's Avatar
 
Join Date: May 2006
Location: Sacramento,Ca.
Age: 66
Posts: 54,515

User is: S10dude is online now
Re: Need help!!! 2.2 3rd Gen.

i would have to guess 'spark plugs".....make sure you use ac delco when you replace them

All truck pics
http://s93.photobucket.com/user/sdim...?sort=3&page=1.........


Marc .........."01" ExCab 2.2 - 5sp ......On Air......
.......... 2014 Harley Street Glide Special ......on Air
S10dude is online now  
 
post #4 of 11 Old 04-08-2019, 06:50 PM
Chopper! Sic balls!
 
Mostizzle's Avatar
 
Join Date: Aug 2009
Location: Walkin' the tracks
Posts: 39,226

User is: Mostizzle is offline
Re: Need help!!! 2.2 3rd Gen.

Good point. My truck seems to run like butt with any other brand of plug.
Mostizzle is offline  
post #5 of 11 Old 04-09-2019, 08:08 AM Thread Starter
Registered Users
 
Heathen240's Avatar
 
Join Date: Nov 2018
Posts: 7

User is: Heathen240 is offline
Quote:
Originally Posted by Mostizzle View Post
Hard to say without the truck in front of me. It could still be tired or dirty injectors. Technically there is no "3rd gen" though fyi.
Quote:
Originally Posted by S10dude View Post
i would have to guess 'spark plugs".....make sure you use ac delco when you replace them
Quote:
Originally Posted by Mostizzle View Post
Good point. My truck seems to run like butt with any other brand of plug.


Yeah I dont know I think they sold me NGK plugs. Didnt even think of that. Another thing I forgot to mention is yesterday it brought up a code P0410 secondary air injection pump. People told me that it wouldnt cause the problems im having and others say it does matter. I checked the pump yesterday it comes on for about 30 seconds after a cold start then kicks off. I checked fuses and connections. Everything seemed to check out fine. Am i looking over something?
Heathen240 is offline  
post #6 of 11 Old 04-09-2019, 09:57 AM Thread Starter
Registered Users
 
Heathen240's Avatar
 
Join Date: Nov 2018
Posts: 7

User is: Heathen240 is offline
Update. After doing hours of research I was told to change the one way check valve thats conected to the exhaust header. Does that sound like a good solution to anyone?
Heathen240 is offline  
post #7 of 11 Old 04-10-2019, 08:39 AM
8/31/1897 - 4/29/2004
 
BravadaX's Avatar
 
Join Date: Jun 2010
Location: Destin,Florida
Posts: 9,026

User is: BravadaX is offline
Re: Need help!!! 2.2 3rd Gen.

Not really. Those fail on everything GM put them on,and never seen a drivability issue related to their failure.

If I was diagnosing the truck Iíd check the obvious like stated earlier...wrong plugs,bad wires...Iím terrible at guessing unless itís in front of me,lol. At work Iíd drive around on the data screen of my modis,and see which cylinders are dropping as well as the O2 sensor readings. The 2.2 is a speed density vehicle,and doesnít throw lean codes as easily as air density vehicles like the 4.3 trucks..Iíve seen failing fuel pumps on these trucks do everything from no power,misfires,to lean codes in severe cases...Iíve seen the coils shot through the bottom,and ground out on the module,seen the terminals on the coils corrode where the plug wire attaches...best bet if the obvious is expended is to take it to a shop instead of throwing parts at it...

Quote:
Originally Posted by mostizzle View Post
I turned mine into an Oldsmobile, bitches love Oldsmobiles.
BravadaX is offline  
post #8 of 11 Old 04-11-2019, 07:53 PM
Registered User
 
F117EWO's Avatar
 
Join Date: Dec 2008
Age: 61
Posts: 216

User is: F117EWO is offline
Re: Need help!!! 2.2 3rd Gen.

The air pump only runs during open loop operation, typically right after start-up. It shouldn't cause any problems after that. Are you getting any codes other than P410?

Jake

2002 S-10 2.2 ltr 5 speed, reg cab, step-side
1992 S-10 2.8 ltr V-6, 5 speed, extended cab
2012 Acura TL, auto (bone stock)
2006 Harley-Davidson Springer Softail
2010 Chevy Suburban 6.6 Duramax diesel
1996 GMC Suburban 6.5 turbo diesel
F117EWO is offline  
post #9 of 11 Old 04-16-2019, 07:29 AM
Registered User
 
jayyk31's Avatar
 
Join Date: Sep 2013
Location: Long Island NY
Age: 38
Posts: 2,027

User is: jayyk31 is offline
Re: Need help!!! 2.2 3rd Gen.

WTF is a 3rd gen???

-NEW DAILY. '86 Blazer 54k miles!!!
https://www.s10forum.com/forum/f20/my-new-gem-815417/

'92 EXTENDED Cab 408 LSx t56 Magnum!!!
Build thread-
https://www.s10forum.com/forum/f213/l...56-n-a-665850/

-2000 RCSB 2.2 5 speed.... SOLD!!!
jayyk31 is offline  
post #10 of 11 Old 04-16-2019, 10:13 AM
8/31/1897 - 4/29/2004
 
BravadaX's Avatar
 
Join Date: Jun 2010
Location: Destin,Florida
Posts: 9,026

User is: BravadaX is offline
Re: Need help!!! 2.2 3rd Gen.

A second gen version 2.0?

I can kinda see it tho. if you dismantle a 95-97,and then start taking apart 98-03 models it kinda is a 3rd gen in comparison. theyíre way different once you get past the body panels,suspension&brakes.

Quote:
Originally Posted by mostizzle View Post
I turned mine into an Oldsmobile, bitches love Oldsmobiles.
BravadaX is offline  
post #11 of 11 Old 05-08-2019, 11:18 AM
Registered User
 
Join Date: Sep 2013
Age: 28
Posts: 183

User is: ghostrider1776 is offline
Re: Need help!!! 2.2 3rd Gen.

Have you checked the idle air control valve? You can test this by disconnecting it with the engine running. When the sensor is disconnected, the truck should begin a "fast" idle.

Other than that, I would check the o2 sensors.

2000 S10 Base
"Humpty Dumpty"
ghostrider1776 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
S10 V8 noob here - Which is "easier" 1st gen or 2nd gen SBC swap? Stilgar308 V8 Discussion 9 01-13-2019 08:23 PM
1st Gen vs 2nd Gen Blazer fuel tank question npohl545 LSx Discussion 0 10-17-2018 10:16 AM
2.2 2nd gen voltage meter issues Mullins Electrical / Lighting 2 06-30-2018 10:24 AM
Extended cab LED 3rd Brake light (MY DIY) Mpool32 Electrical / Lighting 4 08-25-2017 03:19 PM
Some LS info .... long post!!!! Wkeracing LSx Discussion 3 08-10-2016 05:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome