Evap monitor won't complete it's diagnostics - S-10 Forum
 
LinkBack Thread Tools
post #1 of 10 Old 06-08-2019, 09:48 PM Thread Starter
Registered User
 
rimawc's Avatar
 
Join Date: May 2019
Location: Berkeley, Ca
Posts: 37

User is: rimawc is offline
Evap monitor won't complete it's diagnostics

Hello everyone,

I have a 2001 s10 with a 2.2L. After the DTCs were erased it's taking forever for the EVAP monitor to finish its diagnostics. I've put over 200 miles on the truck since it's been continuously running diagnostics. Does anyone know why it would do this?


William C. Rima[SIGPIC][/SIGPIC]
rimawc is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 06-10-2019, 03:13 PM Thread Starter
Registered User
 
rimawc's Avatar
 
Join Date: May 2019
Location: Berkeley, Ca
Posts: 37

User is: rimawc is offline
Re: Evap monitor won't complete it's diagnostics

I just found out that I caused the EVAP monitor to initialize a system test with my scan tool. Does anyone have a Factory Service Manual that says how to stop the EVAP system test? It's for a 2001 Chevrolet S10 extended cab 2.2L.

William C. Rima[SIGPIC][/SIGPIC]
rimawc is offline  
post #3 of 10 Old 06-11-2019, 08:05 AM
New Member
 
Racer-X's Avatar
 
Join Date: Aug 2017
Location: North Georgia, USA
Age: 55
Posts: 1,014

User is: Racer-X is online now
Re: Evap monitor won't complete it's diagnostics

The evap monitor is one of the tougher ones to get to complete for some folks. I don't have the factory service info in front of me right now, so this is more general from experience with several vehicle manufacturers and many vehicles.
  • You have to have around 1/2 tank of gas for the Evap monitor to run. A full tank (more than 3/4) will disable it because of the likelihood of sucking fuel into the system if the purge valve is opened. Less than 1/4 tank can affect the accuracy of the sensors and the test. So you have to have 1/2 tank +/- 1/4 tank for it to run.
  • The vehicle usually has to be parked with the engine off for a significant time (8 hours is pretty common). On some vehicles, you can override/force the test to run with an advanced enough scan tool, but the lack of a "cold soak" can affect test accuracy and results.
  • You can't have any active or pending evap DTCs. The test will not run (for readiness monitoring) if there is a fault in the system. Check your pending codes. If there's a pending evap code, that's what is stopping the test. Fix the pending DTC first.
  • Usually, the evap system is operational when cruising on the highway at light throttle between 45 and 65 mph. Generally, the readiness test needs at least 10 minutes of steady operation in those conditions to count for a "drive cycle." You might need 2 to 3 "drive cycles" that include that 10 minutes of steady highway speed (sometimes after a "cold soak") to complete the readiness testing.


The best thing to do is, first drive of the day, head for the nearest interstate/limited access highway (with light traffic), drive at least 10 miles on there. Exit, shut the engine down. Start it up again and return on the same limited access highway. It might take 2 to 3 days for that to clear it, but that will eventually clear the Evap readiness test.

Every machine is a smoke machine if you operate it wrong enough.
Racer-X is online now  
 
post #4 of 10 Old 06-11-2019, 02:05 PM Thread Starter
Registered User
 
rimawc's Avatar
 
Join Date: May 2019
Location: Berkeley, Ca
Posts: 37

User is: rimawc is offline
Re: Evap monitor won't complete it's diagnostics

Well, I've had over 1/2 a tank of fuel since the DTCs were reset, and I filled the tank after I got back from my 200 mile trip. I don't have any DTCs or pending DTCs, so I think it should complete the test when I reach 1/2 a tank of fuel. I just need to let it sit overnight and take it out on the highway for at least 10 miles, shut off the engine, then return the way I came. I think the level of fuel has prevented the test from finishing. Thanks Racer-X.

William C. Rima[SIGPIC][/SIGPIC]
rimawc is offline  
post #5 of 10 Old 06-20-2019, 03:38 PM Thread Starter
Registered User
 
rimawc's Avatar
 
Join Date: May 2019
Location: Berkeley, Ca
Posts: 37

User is: rimawc is offline
Re: Evap monitor won't complete it's diagnostics

That seemed to solve the problem. The EVAP monitor finished its readiness test and its diagnostics.

William C. Rima[SIGPIC][/SIGPIC]
rimawc is offline  
post #6 of 10 Old 06-20-2019, 06:01 PM
New Member
 
Join Date: May 2017
Location: central Fla
Posts: 1,830

User is: dime-dozen is offline
Re: Evap monitor won't complete it's diagnostics

just curious ,did you leave the scanner connected this entire time?
dime-dozen is offline  
post #7 of 10 Old 06-21-2019, 02:16 PM Thread Starter
Registered User
 
rimawc's Avatar
 
Join Date: May 2019
Location: Berkeley, Ca
Posts: 37

User is: rimawc is offline
Re: Evap monitor won't complete it's diagnostics

No, the scan tool was disconnected the whole time. I just used the scan tool to initiate the system test.

William C. Rima[SIGPIC][/SIGPIC]
rimawc is offline  
post #8 of 10 Old 06-22-2019, 10:02 AM
Post Whore
 
chevymec's Avatar
 
Join Date: Feb 2010
Location: Eastern NC
Age: 39
Posts: 1,166

User is: chevymec is offline
Re: Evap monitor won't complete it's diagnostics

Using a Tech 2 , it has a service bay test. That has a stationary test, then you drive the truck, then a shut down time. Ran the test in maybe 30 minutes but the truck had to be cold to start with if I remember correctly. Glad it finally went through for you.

1997 SS---Built and Blown... almost

My build thread... https://www.s10forum.com/forum/f30/pr...ecs-ss-513887/
chevymec is offline  
post #9 of 10 Old 06-22-2019, 10:57 AM
New Member
 
Join Date: May 2017
Location: central Fla
Posts: 1,830

User is: dime-dozen is offline
Re: Evap monitor won't complete it's diagnostics

when my truck was pretty new(I bought new as an 01) I think it had 18K on it.
Started getting evap codes. Dealer told me gas cap wasnt being tightened down.
I knew it was and problem persisted. Rep said gas cap was bad,walked over to the parts counter and paid for a new cap out of my own pocket,just to shut them up. 2 days later it came back. I told them to keep the truck until it was fixed,no loaner etc.2 wks go by and it still wasnt fixed,I called Corporate and got them involved.I almost lemon lawed it,but stuck it out.
They finally found a crack in the line,behind the engine. I asked why they didnt do a smoke test to find that within 10 minutes and Service Manager looked at me like I had a third eye."we arent a big dealer and cant afford that thousand dollar tool",I said I had one at home,small shop vac,coffee can with charcoal brickettes and smoke bombs. I got an even weirder look then.Havent had an evap problem since.
dime-dozen is offline  
post #10 of 10 Old 06-22-2019, 12:34 PM
Post Whore
 
chevymec's Avatar
 
Join Date: Feb 2010
Location: Eastern NC
Age: 39
Posts: 1,166

User is: chevymec is offline
Re: Evap monitor won't complete it's diagnostics

I worked at a dealership. They sent those kent-moore tools to you and you didn't have a choice. You paid for them.

Sent from my SM-G930V using Tapatalk

1997 SS---Built and Blown... almost

My build thread... https://www.s10forum.com/forum/f30/pr...ecs-ss-513887/
chevymec is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome