Reverse lights don't work - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Reverse lights don't work

Go Back   S-10 Forum > General Tech > Electrical / Lighting
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 03-10-2008, 12:06 AM   #1
HATEKILLDESTROY
 
THRICE's Avatar
 
Age: 33
Join Date: Aug 2002
Posts: 4,655
Location: Colorado Springs, CO
User is: OffLine
Reverse lights don't work

Well, I bought my s10 back in October from my friend who works at a dealership. The dealership bought the truck for me at an auto auction. Well, when I received the truck, the reverse lights didn't work. I changed the bulbs, but still no go. I don't have a manual to the truck, so I was wondering if you guys know which fuse I could check, if in fact that was the issue. Thanks in advance.
Old 03-10-2008, 01:08 AM   #2
5 speed 4 door blazer
 
NYCBLAZER's Avatar

 
Join Date: Jan 2007
Posts: 1,189
Location: BROOKLYN, NEW YORK
User is: OffLine
Re: Reverse lights don't work

i'm having the same problem and i also have a 5 speed
gonna check the reverse switch tomorrow on the driver side of the tranny, i hope it just that.
Old 03-10-2008, 03:43 AM   #3
What?
 
cwd240z's Avatar
 
Join Date: Mar 2004
Posts: 1,759
Location: TX
User is: OffLine
Re: Reverse lights don't work

The switch on the tranny went out in my 98 5 speed one time.
Old 03-10-2008, 03:45 AM   #4
UN-BANNED B!TCHES!!!!!
 
NotaDime's Avatar
 
Join Date: Jan 2007
Posts: 6,950
Location: Verizon's iPhone4
User is: OffLine
Re: Reverse lights don't work

reverse light switch
Old 03-10-2008, 09:25 AM   #5
HATEKILLDESTROY
 
THRICE's Avatar
 
Age: 33
Join Date: Aug 2002
Posts: 4,655
Location: Colorado Springs, CO
User is: OffLine
Re: Reverse lights don't work

Mine is an auto. Anyone have a pic of what the switch looks like? LOL
Old 03-10-2008, 08:33 PM   #6
forum idiot
 
orangesonoma's Avatar
 
Age: 36
Join Date: Oct 2002
Posts: 49,674
Location: Indian Trail, NC
User is: OffLine
Re: Reverse lights don't work

yeah its a big thinigy on the driver side of the trans with wires on it...that could be bad
Old 03-10-2008, 09:58 PM   #7
HATEKILLDESTROY
 
THRICE's Avatar
 
Age: 33
Join Date: Aug 2002
Posts: 4,655
Location: Colorado Springs, CO
User is: OffLine
Re: Reverse lights don't work

Quote: Originally Posted by orangesonoma
yeah its a big thinigy on the driver side of the trans with wires on it...that could be bad
Thanks, I'll check it out.
Old 03-10-2008, 10:03 PM   #8
forum idiot
 
orangesonoma's Avatar
 
Age: 36
Join Date: Oct 2002
Posts: 49,674
Location: Indian Trail, NC
User is: OffLine
Re: Reverse lights don't work

it looks like this

Old 03-10-2008, 10:04 PM   #9
forum idiot
 
orangesonoma's Avatar
 
Age: 36
Join Date: Oct 2002
Posts: 49,674
Location: Indian Trail, NC
User is: OffLine
Re: Reverse lights don't work

this is where it is


i think

Last edited by orangesonoma; 03-10-2008 at 10:05 PM.
Old 03-10-2008, 10:16 PM   #10
HATEKILLDESTROY
 
THRICE's Avatar
 
Age: 33
Join Date: Aug 2002
Posts: 4,655
Location: Colorado Springs, CO
User is: OffLine
Re: Reverse lights don't work

Awesome. Thanks Brian. I'm getting tired of assholes honking at me for not having reverse lights.

I had no reverse lights on my Blazer and never was honked at. Now with the s10, I get honked at at least twice a day. Shit's getting old.

Thanks again.
Old 03-10-2008, 10:17 PM   #11
forum idiot
 
orangesonoma's Avatar
 
Age: 36
Join Date: Oct 2002
Posts: 49,674
Location: Indian Trail, NC
User is: OffLine
Re: Reverse lights don't work

i hope you give them the finger..
Old 03-10-2008, 10:50 PM   #12
HATEKILLDESTROY
 
THRICE's Avatar
 
Age: 33
Join Date: Aug 2002
Posts: 4,655
Location: Colorado Springs, CO
User is: OffLine
Re: Reverse lights don't work

Every time. Even the blue hairs.
Old 06-14-2008, 08:39 AM   #13
Registered User
 
Age: 32
Join Date: May 2008
Posts: 7
Location:
User is: OffLine
Re: Reverse lights don't work

Quote: Originally Posted by orangesonoma
it looks like this

What part number is this?
Old 06-14-2008, 12:06 PM   #14
Registered User
 
Join Date: Jan 2006
Posts: 58
Location: 14075
User is: OffLine
Re: Reverse lights don't work

is this for an auto, is it the same switch for a 5 speed
Old 06-14-2008, 12:10 PM   #15
V going 4 door!
 
98layinframe's Avatar
 
Age: 33
Join Date: Feb 2003
Posts: 14,863
Location: Pittsburgh Pa
User is: OffLine
Re: Reverse lights don't work

nope the 5 speeds are totally different.. but in a good way. Ours is a simple little switch that looks kina like a big spark plug with a connector on the end of it. There really easy to swap out. ALL ya need is a 1/2" drive 7/8" deep well socket.
Old 06-14-2008, 03:02 PM   #16
Registered User
 
Join Date: Jan 2006
Posts: 58
Location: 14075
User is: OffLine
Re: Reverse lights don't work

is the switch on the passenger side and buried into the tranny, it looks like that might be it but i'm not sure, also if i unplug the two wires and jump them that should buy pass the switch and tell me if the switch is bad correct thanks for your help
Old 06-14-2008, 03:15 PM   #17
V going 4 door!
 
98layinframe's Avatar
 
Age: 33
Join Date: Feb 2003
Posts: 14,863
Location: Pittsburgh Pa
User is: OffLine
Re: Reverse lights don't work

yep, passenger side and yes just jumper/short the plug out. just make sure you dont forget to then put the truck in reverse with the key on.
Old 06-14-2008, 05:38 PM   #18
Registered User
 
Join Date: Jan 2006
Posts: 58
Location: 14075
User is: OffLine
Re: Reverse lights don't work

great that confirmed that the switch is bad, thanks for your help
Old 06-25-2008, 03:18 PM   #19
Registered User
 
Age: 32
Join Date: May 2008
Posts: 7
Location:
User is: OffLine
Re: Reverse lights don't work

whats the part number for the one with the 5 speed? I have a 98 5 speed and need a part number please!
Old 06-25-2008, 10:51 PM   #20
Hater
 
Join Date: Feb 2003
Posts: 23
Location: Perryville, MO
User is: OffLine
Re: Reverse lights don't work

For a 98 5 speed the borg warner part number is S9150. Any decent parts store should be able to cross reference that number to whatever brand they carry.
Old 10-03-2013, 09:54 AM   #21
Registered User
 
Age: 66
Join Date: Sep 2013
Posts: 24
Location:
User is: OffLine
Re: Reverse lights don't work

my backup lights work IF I remove the backup light switch and Jump the two wires in the plug.... Bought a NEW switch at Advance Auto... replaced switch.. STILL DO NOT WORK except when Jumped..

Any additional ideas.. except i have TWO bad switches.... can happen.
Old 10-03-2013, 10:29 PM   #22
CCTV EXPERT....
 
madmader's Avatar
 
Age: 39
Join Date: Jan 2012
Posts: 263
Location:
User is: OffLine
Re: Reverse lights don't work

on the passenger side of the tranny, there is a 2 wire switch... I don't remember the wire colors, but I think one of them is orange. You can get the switch from any parts store for 15 bucks, and it will fix the problem. I used to have a youtube video posted on how to fix this, but I killed my youtube account a year ago...
Old 10-06-2013, 10:59 PM   #23
Registered User
 
Age: 66
Join Date: Sep 2013
Posts: 24
Location:
User is: OffLine
Re: Reverse lights don't work

On this truck, the switch is on the drivers side.. the new one costs about $10 at advance auto... My new (and old) switch worked just fine.. not in the transmission.... SO:

MY neighbor has a lathe.... He chucked my new switch up in his lathe and milled 30 thousandths of an inch off the face of the nut portion of the switch. IT WORKS NOW.. thats about 1.3/32 of an inch further that it screws into the transmission....................... PROBLEM SOLVED..
Old 10-06-2013, 11:12 PM   #24
Registered User
 
Age: 50
Join Date: Jan 2012
Posts: 1,034
Location: Way down in Louisiana.
User is: OffLine
Re: Reverse lights don't work

Mine didn't work for the longest, then I was trying to get the switch (never could determine what size wrench) but in the process created a short, which made me hang it up for the day, but when I crawled out from under, they were now working.

I think they are back to intermittent now.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:08 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.