ECM fuse keeps blowing?? - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

ECM fuse keeps blowing??

Go Back   S-10 Forum > General Tech > Electrical / Lighting
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 04-16-2008, 08:19 AM   #1
Registered User
 
cUt_sh*t-uP's Avatar
 
Age: 25
Join Date: Jun 2007
Posts: 268
Location: CHERRYHELL,NC
User is: OffLine
ECM fuse keeps blowing??

i got a 99s-10 2.25spd, searched and didnt find much of anything. the fuse keeps blowing and im not sure why, i'll put a new fuse in go down the road about 30ft and truck cuts off, each time i put in a new fuse it blows!! im not sure what the problem is or what the ecm is, so i dont where to start lookin for problems?? has anyone else had this problem?? any info is helpful, thanks.
Old 04-16-2008, 09:19 AM   #2
Yes, those are my feet
 
Web-Foot Freak's Avatar
 
Age: 41
Join Date: Oct 2004
Posts: 622
Location: Marion, AR... again...
User is: OffLine
Re: ECM fuse keeps blowing??

If this is the ECM2 fuse, I've had the same problem... I never did manage to fix it either... The only difference is I have the 2.8, but the schematic seems the same...

I do know that from the fuse there are 2 B+ wires right to the ECM
There is a B+ wire to the oil pressure sending unit, and then to the ECM
The final B+ wire goes to the Fuel Pump

I blew 3 fuses, then physically checked every wire to the fuel pump and the sending unit and found no chaffing. I plugged everything back in, one link at a time and never blew another fuse... this was about 1.5 mos ago...
Old 04-16-2008, 10:58 AM   #3
Registered User
 
cUt_sh*t-uP's Avatar
 
Age: 25
Join Date: Jun 2007
Posts: 268
Location: CHERRYHELL,NC
User is: OffLine
Re: ECM fuse keeps blowing??

i do know that when it blows the fuel pump DOES NOT work until the fuse is replaced.......should i check all wires down to the fuel pump???

also i had to change both fuel pump plugs on the tank, before the plug that runs the pump was shorting out and i would wiggle it a little and it would come back on (could that have been why the fuse was blowing?) thanks!
Old 04-16-2008, 05:47 PM   #4
Registered User
 
cUt_sh*t-uP's Avatar
 
Age: 25
Join Date: Jun 2007
Posts: 268
Location: CHERRYHELL,NC
User is: OffLine
Re: ECM fuse keeps blowing??

can anyone provide more info, please??
Old 04-17-2008, 05:40 AM   #5
Registered User
 
trixedout1's Avatar
 
Join Date: Feb 2006
Posts: 203
Location:
User is: OffLine
Re: ECM fuse keeps blowing??

had the same problem wit my 89 blazer 4.3l .don't bother wit the the fuel pump or the ecm .you got a short some were .i started to rip apart my dash ,drop the gas tank ,check all relays etc.all that was working fine. but what i found out it was just my knock sensor plug wasn't plug in and started to ground out between trans and firewall .and it ran fine after but now got a short on my courtesy lights working on that now .well everything thats connected to the ecm2 fuse is fuel pump relay,fuel pump ,oil pressure sensor and couple other stuff but forget the rest ,got the wiring diagram at work .get back to you thursday .but just check all plugs in engine bay and do a visable check on all wire under dash . keep me updated
Old 04-17-2008, 08:46 AM   #6
Registered User
 
cUt_sh*t-uP's Avatar
 
Age: 25
Join Date: Jun 2007
Posts: 268
Location: CHERRYHELL,NC
User is: OffLine
Re: ECM fuse keeps blowing??

i checked the wires back to fuel pump and i see no problems and all my plugs are good. they have been checked twice, but i havent tryed a new fuse since i replaced the plug that was shorting out, im gonna take it out sat and drive around and see if it blows again!!! i'll let ya know how that goes!!
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:19 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.