98 s10 rear chassis harness to taillight harness questions..... - S-10 Forum
 
LinkBack Thread Tools
post #1 of 12 Old 01-16-2012, 03:58 AM Thread Starter
Registered User
 
Join Date: Jan 2012
Location: 425 washington
Age: 30
Posts: 80

User is: baggedNstuffed is offline
98 s10 rear chassis harness to taillight harness questions.....

Cann you guys help me match up the wires.

I have 7 wires on the chassis wiring harness at the rear on the drivers frame rail .
and i have a 5 wire connecter for the tail light harness.


heres the chassis harness - 7 wires
light green - connected to taillight harness light green
dark green - connected to taillight harness dark green
yellow - connected to taillight harness yellow
brown - connected to taillight harness brown
brown with white stripe. - connected to taillight harness brown w white
Black - connected to chassis ground (frame rail)
Light blue - Not connected




and heres the taillight harness 5 wire connector, and a ground splice pack (green thing.)
light green - connected to chassis harness light green
dark green - connected to chassis harness dark green
yellow - connected to chassis harness yellow
brown - connected to chassis harness brown
brown with white stripe. - connected to chassis harness brown w white
splice back - 4 black wires coming in 1 black wire running to chassis ground (frame rail)

Anyone know what the light blue chassis wire is???

Aanyone know if i have my grounds/ and wiring all correct??

Thanks !!!!! and look at the wires not the rust

baggedNstuffed is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 01-22-2012, 12:00 PM
Registered User
 
Join Date: Jan 2012
Posts: 7

User is: Orange Peel is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Have you figured out what the light blue wire is for?
I have been having troubles with my tail lights and I have found the same wire not connect and don't see a place for it either.

Thanks!!
Orange Peel is offline  
post #3 of 12 Old 01-22-2012, 12:09 PM
Been around the block
 
CatDaddy52's Avatar
 
Join Date: Nov 2008
Location: Rochester Hizzle, MI
Posts: 2,062

User is: CatDaddy52 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Lt Blue is for "Trailer Wiring Provision" comes from the 10A trailer CMCSL fuse.
CatDaddy52 is offline  
post #4 of 12 Old 01-23-2012, 05:35 PM Thread Starter
Registered User
 
Join Date: Jan 2012
Location: 425 washington
Age: 30
Posts: 80

User is: baggedNstuffed is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

ok sounds good.

Does the chassis harness black (ground) connect to the frame rail?

or does it tie into the taillight harness (green ground splice pack)
baggedNstuffed is offline  
post #5 of 12 Old 01-23-2012, 07:16 PM
Registered User
 
Join Date: Jan 2012
Location: Way down in Louisiana.
Age: 52
Posts: 1,035

User is: Ed98 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

My guess is the black wire is for a trailer wiring provision; is already attached to the chassis on the other end.

All the grounds from the bulbs go to a splice pack which itself is grounded.

So this wire would be so you can have something grounded to hook your trailer to.

Labor Rates: $35/Hr. If you watch: $45. If you help: $55 If you tried to fix it yourself first: $95
Ed98 is offline  
post #6 of 12 Old 01-24-2012, 10:29 AM
Been around the block
 
CatDaddy52's Avatar
 
Join Date: Nov 2008
Location: Rochester Hizzle, MI
Posts: 2,062

User is: CatDaddy52 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Black wire in chassis harness should be grounded to frame as well as the wire from the ground block. In my case, the chassis harness ground was for the fuel pump (among other items). In general, ALL black wires are grounds.
CatDaddy52 is offline  
post #7 of 12 Old 12-13-2012, 09:04 PM
Registered User
 
Join Date: Oct 2010
Age: 28
Posts: 6

User is: Cherry32773 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Hey in the above picture of the "taillight harness 5 wire connector, and a ground splice pack (green thing.)"I need the metal pieces that go on the wires that go into the connector (not sure what to Actually call them), does anyone know where i can get them? Oreillys, Autozone, and Advance all say that they don't exist. -.-
Cherry32773 is offline  
post #8 of 12 Old 12-15-2012, 10:51 PM
Registered User
 
Join Date: Jan 2012
Location: Way down in Louisiana.
Age: 52
Posts: 1,035

User is: Ed98 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Terminals? The metal inside the white plastic? I think you have to improvise.

Really you can probably buy the white connector with six or eight inches of wire on it from the dealer. And make standard splices to connect it to your harness.

Labor Rates: $35/Hr. If you watch: $45. If you help: $55 If you tried to fix it yourself first: $95
Ed98 is offline  
post #9 of 12 Old 02-14-2013, 06:08 PM
Mr Cheech
 
Sleeper S10's Avatar
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 2,385

User is: Sleeper S10 is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Sorry to high jack this post.

I have a question on the green harness section in the above pic with 4 wires and another ground off to the side?
What's that for?

Nothing is plugged into it on my '99 S10. Have one on each side of the rear frame.

Reason I'm asking is because I broke that ground wire on the driver side removing the harness to clean and paint my frame.

Now trying to pinpoint why my new fuel pump won't turn on?
Would the broken ground relate to that?

The harness for the fuel pump is in tact and grounded.

Thanks for any help!

LS2 402 STROKER SWAP:
http://www.s10forum.com/forum/f213/s...x-swap-430296/

S10 Sonoma Envoy Swap - NEW & 99% COMPLETE!
Best offer!
http://www.kijiji.ca/v-view-details....teLocale=en_CA

Hellwig Rear Sway Bar - New Other
Best offer!
http://www.kijiji.ca/v-view-details....dId=1124629793
Sleeper S10 is offline  
post #10 of 12 Old 03-11-2013, 11:32 PM Thread Starter
Registered User
 
Join Date: Jan 2012
Location: 425 washington
Age: 30
Posts: 80

User is: baggedNstuffed is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

ya i replaaced my fuel pump for $250 and then realized my wiring was wrong near the taill lights, fixed the harness near the tail light connector and the fuel pump works good.

i cut off the ground connector with the 5 ground wires and hooked them all right to the frame.
baggedNstuffed is offline  
post #11 of 12 Old 04-18-2013, 10:21 AM
Need to DO WORK son
 
Innis's Avatar
 
Join Date: Mar 2006
Location: London, Ontario
Age: 30
Posts: 8,571

User is: Innis is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Quote:
Originally Posted by Sleeper S10 View Post
Sorry to high jack this post.

I have a question on the green harness section in the above pic with 4 wires and another ground off to the side?
What's that for?

Nothing is plugged into it on my '99 S10. Have one on each side of the rear frame.

Reason I'm asking is because I broke that ground wire on the driver side removing the harness to clean and paint my frame.

Now trying to pinpoint why my new fuel pump won't turn on?
Would the broken ground relate to that?

The harness for the fuel pump is in tact and grounded.

Thanks for any help!
Those 2 connectors your talking about, they are common grounds, need to have them grounded for sure



2001 S10 Bagged - Just need to DO WORK!
Innis is offline  
post #12 of 12 Old 04-20-2013, 11:41 PM
SSRT-S10
 
my_nightmare's Avatar
 
Join Date: Nov 2009
Location: Georgia
Posts: 1,131

User is: my_nightmare is offline
Re: 98 s10 rear chassis harness to taillight harness questions.....

Driver side frame connection (from frame out to the bolt): One STAR washer. Then one lug w/ black wire going toward front of truck is pump main ground. Then Another Star Washer. Then A small Black wire that leads into the green grounding block (the rear lights main ground). Another Star Washer. Then the 13mm bolt.

Passenger side Frame rear: (from frame out to the bolt) One star washer. One lug with small black wire that goes into the green passenger side grouding block. Another star washer. Then the 13mm bolt.

I just got through replacing the pump in my truck tonight(1hr 38mins ago) so I kind of got it all memorized at the moment....lol.

Hope this helps.

P.S. It would be good advise to relocate the fuel pump ground closer to the pump. What I did was cut the lug off, attached a gold plated lug. Then got some new star washers and drilled a new hole for the new bolt and locknut to hold it all together.
Then I coated the connection(bolt and all around it) with a weatherproof sealer that won't flake or rub off.(similar to winshield urethane) It should last forever I think...
my_nightmare is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome