1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2) - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Go Back   S-10 Forum > General Tech > Electrical / Lighting
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 01-15-2012, 10:31 PM   #1
Registered User
 
Age: 29
Join Date: Jan 2012
Posts: 11
Location:
User is: OffLine
Exclamation 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Part 1 is in another subform because I didn't realize we had this one. Here is what was done.

1st. Stock Radio/CD Player didn't work, at this point Speedometer WAS working, so I went and got a replacement CD player from the junkyard.
2nd. Installed said radio which included hooking up Green Wire on big white connector. This caused I *think* my speedometer to stop working.
3rd. Checked the VSS (Velocity Speed Sensor) both clips where broken so I used zip ties to hold the wire to the sensor, also I unplugged the green wire on the white connector from the radio, still no speedometer
4th. Reset the computer in the car by disconnecting the ground and letting the car reset (I think that is now its done) did nothing
5th. Installed the stock broken CD player back into the car WITH the green wire connected . . . that did not fix it
6th. Reset car, unplugged green wire from radio that did not work
7th. Took cluster out of the car, checked the pins on the console, some looked low so I gently bent some of them up and put the cluster back in, everything works BUT the speedometer and odometer

What I'm thinking is the problem is the following:

1st. I've burnt up the speedometer with the other radio
2nd. The VSS doesn't work anymore
3rd. Because of a LOT of research it could be my ignition key on the column that might be causing all my problems.

ANY more advice would be HIGHLY appreciated! Going to the junkyard tomorrow to get a spare cluster, ignition switch AND VSS in hopes one of those thing will fix my S10 truck.

Again any other suggestions would be highly appreciated!

Thanks
Old 01-16-2012, 09:36 AM   #2
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,801
Location: Houston, TX
User is: OffLine
Re: 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Check the fuses. And verify that you connected the two vss wires as they make a path to the radio and the radio's connector keeps the two wires together.
Old 01-22-2012, 10:55 AM   #3
Registered User
 
Age: 29
Join Date: Jan 2012
Posts: 11
Location:
User is: OffLine
Re: 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Ok,

Here is what I have done and tried.

1st. I put the original radio back in the truck and that did not fix it.
2nd. I got two VSS units and two Clusters out of the junkyard (both from 2.2l S10) and none of those work.
3rd. I took you diagrams and did a wire trace from the VSS to the ECU and the ECU to the cluster with a multi-meter and there are no breaks in the wire, I have continuity on the signal wire.
4th. I've checked all the fuses in the panel next to the door.
5th. I checked all my VSS units with a multi-meter and they all appear to be working correctly.

Like I said I checked the fuses that are next to my door, however that is the only fuses panel I know about on the truck, is there another one anywhere on the truck?

Also if the radio I'm using had some kind of security on it would it screw up my cluster? I really want to get this fixed, its really annoying me to have to depend on a GPS for speed.

Thanks
Disjaukifa
Old 09-04-2012, 11:38 PM   #4
Registered User
 
Age: 29
Join Date: Jan 2012
Posts: 11
Location:
User is: OffLine
Re: 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Bump! I still haven't gotten the speedometer working so I now have to get it working since I moved to another state. Please if anyone can help me with this that would be great.
Old 09-14-2012, 10:15 PM   #5
Registered User
 
Age: 25
Join Date: Sep 2012
Posts: 3
Location:
User is: OffLine
Re: 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

yeah bro got the same problem..as far as the fuses go there are two fuse boxs. the other fuse box your asking about is under the hood. its located driver side. its a black box with what looks like a circular knob you have to unscrew. its a larger fuse box that holds more fuses than the one locaated on the side of the driver dash..

I have a 98 sonoma that i changed the cd player..once i did that cluster with the digital gear and mileage quit working, also lights on cluster such act up and the fuel gauge quit working. checked all fuses everything is good, i canted figure out what the problem is if anyone knows anything give me a reply back
Old 07-01-2013, 12:35 PM   #6
Registered User
 
Age: 29
Join Date: Jan 2012
Posts: 11
Location:
User is: OffLine
Re: 1997 S10 2.2l Manual 2wd Speedometer not working! , advice needed please (Part 2)

Just an FYI, I did end up getting rid of the truck, but I had tried replacing the following:

New VSS
New ECU
Used Speedo
Used Stock Stereo

I never got it working before I sold the truck . . .
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:28 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.