[Project] Clean Start - Page 3 - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

[Project] Clean Start

Go Back   S-10 Forum > Member Forums > Member Projects
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 02-20-2012, 01:23 AM   #101
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Page 3 bitches
Old 02-20-2012, 01:27 AM   #102
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

yea our limit is 110.
Old 02-20-2012, 01:31 AM   #103
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Actually, Its 65 MPH, but close enough.
Old 02-20-2012, 08:57 AM   #104
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
I've hit the governor in my s10 at 95 mph. And most 94s had 85 mph speedos. Ss's and a few other v6 trucks had 100 mph clusters. And yes, it has a tach. Pics later. It's from an auto though.
Old 02-20-2012, 09:45 AM   #105
Registered User
 
badmofo529's Avatar
 
Age: 22
Join Date: Nov 2010
Posts: 2,685
Location: Flint, MI
User is: OffLine
Re: [Project] Clean Start

i hit mine at 97. never again. its fine getting up to speed but its sketchy as soon as you let off the gas and start slowing down lol
Old 02-20-2012, 09:59 AM   #106
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

how long did it take to reach the governor with a 2.2? :P
Old 02-20-2012, 10:34 AM   #107
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

Actually it didn't take that long really. I've hit it 3 times now, the first time scared the shit out of me though, because everything just went quiet all of a sudden and I was like WTF! I used GPS to verify my speed by the way.

I hit it once in Texas on a rural road (speed limit 70) and the other two times were in Michigan on I-75 in a rural area (speed limit 70).

Old 02-20-2012, 01:57 PM   #108
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

DO WANT DO WANT. and careful on 75 there is a section where the boys will nab you for going 2 over, been there done that.
Old 02-20-2012, 02:01 PM   #109
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
This is the only 100 mph 94 cluster I've had. I believe you had to have the CPI to get it. But I could be wrong. I've owned like 8 94 tach clusters now.
Old 02-20-2012, 03:25 PM   #110
This is doo doo baby!
 
wildman ss's Avatar
 
Age: 24
Join Date: Apr 2006
Posts: 10,353
Location: Lawrenceville, GA
User is: OffLine
Re: [Project] Clean Start

mmmmmm I want that cluster
Old 02-20-2012, 04:54 PM   #111
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Brent, get a 94 first.
Old 02-20-2012, 08:20 PM   #112
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by deathphoenix99
This is the only 100 mph 94 cluster I've had. I believe you had to have the CPI to get it. But I could be wrong. I've owned like 8 94 tach clusters now.

BLah blah blah how much dammnit?
Old 02-20-2012, 08:45 PM   #113
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

I'm am planning on making a verry small run of TenthDigit R decals, those interested I want to know what colors you would like. Below are some that i have tossed together. The last one is white, let me know it if is too hard to see. cost/ decal is around 5$, it may be cheaper depending on how many i can get, size is about 6"x1.25".




Old 02-21-2012, 12:18 AM   #114
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Sean, I was thinking about getting some made too, just let me talk to the company first
Old 02-21-2012, 01:42 AM   #115
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

how come mine isn't special
Old 02-21-2012, 08:03 AM   #116
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

It's not a 94. And it's special in a way, it's got you working on it.


Sean, not sure, I haven't actually decided to sell this cluster yet. LOL
Old 02-21-2012, 01:23 PM   #117
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

but it's a 95 so it's not tenth digit R
Old 02-21-2012, 05:09 PM   #118
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Sucks to be you...
Old 02-21-2012, 05:19 PM   #119
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

94's are pretty amazing.
Old 02-21-2012, 05:53 PM   #120
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

Oh well at least it's a Z
Old 02-21-2012, 07:29 PM   #121
.
 
mostizzle's Avatar
 
Join Date: Aug 2009
Posts: 27,772
Location: 1800 Crenshaw
User is: OffLine
Re: [Project] Clean Start

Raggity.
Old 02-22-2012, 02:14 PM   #122
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

Hey Sean, how's the honeybadger coming?
Old 02-22-2012, 02:33 PM   #123
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by deathphoenix99
Hey Sean, how's the honeybadger coming?
slowly, i need to buy a grinder and some flap wheels, weld in the upper supports, winch base plate, and some other fine niggles.
Old 02-22-2012, 02:33 PM   #124
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

sounds like a plan.
Old 02-26-2012, 05:59 PM   #125
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

SO I have to order new Bushings before the shackles can be done, any one have a suggestion for place to get some polly's.

edit there are the rear leaf and frame bushing
Old 02-26-2012, 06:15 PM   #126
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

I replaced mine with rubber, whatever Autozone had in stock. They are hard to find unless you're looking online.
Old 02-26-2012, 06:40 PM   #127
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by deathphoenix99
I replaced mine with rubber, whatever Autozone had in stock. They are hard to find unless you're looking online.
on-line is fine, I wont be able to work on it again until next weekend, im going to have to burn the bolts heads off slide the shackles off, then burn out the old bushings. Going to have to buy a new ratchet to replace the one I broke today (craftsman here I come) and get a couple C clamps.
Old 02-26-2012, 09:24 PM   #128
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

I used a ball joint press on mine.
Old 02-27-2012, 02:31 PM   #129
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

So I was digging in some old folders, and came across something I had scribbled up when I first got the truck. I'm unsure if this will be a project or not, but here it is any way.
Old 02-27-2012, 03:44 PM   #130
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

Do it!
Old 02-27-2012, 10:53 PM   #131
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by deathphoenix99
Do it!
the problem is weight, if i use 1" .125 wall square tube it will be heavy as ****. I don't really want to tag on much more weight that I already have.

If i could use 1" conduit it would weigh about half of the square tubing, but wouldn't be able to support much weight.
Old 02-27-2012, 11:12 PM   #132
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

If you make it correctly, it should be easy to support 100-200 lbs.
Old 03-03-2012, 06:35 PM   #133
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Got my runnning light/ turn signals in today.


played with a few mounting options and this tunrs out the be about the only good one.. figures, if they were 2" shorter I could place them in the bumper.

any way what do you say, yey or ney
Running only


running left turn right


with headlights


and with all lights
Old 03-04-2012, 04:12 PM   #134
Molon Labe
 
Stewzer55's Avatar

 
Age: 24
Join Date: Aug 2010
Posts: 7,697
Location: Ohio
User is: OffLine
Re: [Project] Clean Start

Yay, brilliant mounting location!
Old 03-04-2012, 04:53 PM   #135
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Old 03-04-2012, 06:36 PM   #136
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

Looking good man.
Old 03-04-2012, 06:46 PM   #137
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

Now show it some love and give it a wax. wax on... wax off...
Old 03-04-2012, 07:32 PM   #138
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by roademon
Now show it some love and give it a wax. wax on... wax off...
it wont get wax untill this summer probably. i still have to fix the paint on the hood and roof.
Old 03-04-2012, 08:37 PM   #139
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

aw poor noma
Old 03-07-2012, 01:37 AM   #140
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

found out my cruise control works tonight, so that is nice, just have to get my AC going before my trip next month.
Old 03-07-2012, 01:40 AM   #141
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Re: [Project] Clean Start

trip? what trip?
Old 03-07-2012, 03:06 AM   #142
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

no idea
Old 03-07-2012, 02:36 PM   #143
Slowly but eventually
 
98lowerednewproje's Avatar
 
Age: 27
Join Date: Feb 2007
Posts: 2,795
Location: AR
User is: OffLine
Re: [Project] Clean Start

See, I told you that the ABS shouldn't affect it!
Old 03-07-2012, 08:12 PM   #144
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

and why wasn't cruise working? I finally got mine fixed on the noma, needed a cable adjuster, I think it works better than before with proper cable adjustment.
Old 03-07-2012, 09:48 PM   #145
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

Quote: Originally Posted by roademon
and why wasn't cruise working? I finally got mine fixed on the noma, needed a cable adjuster, I think it works better than before with proper cable adjustment.
I have never tried to use it in 5th gear, the Resume accel portion doesnt work but i can get over that. just to get my AC in order.
Old 03-07-2012, 10:05 PM   #146
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

what seems to be your ac issue?
Old 03-07-2012, 10:20 PM   #147
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

It just isn't cycling on, I'm going to check the connectors and see if it is getting power this weekend. before it was way over pressurized so i let some pressure off, and its still a no go. hopefully its just a bad connection.
Old 03-07-2012, 11:08 PM   #148
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 9,874
Location: Elizabeth Colorado
User is: OffLine
Re: [Project] Clean Start

On a different areay of random shit I am working on, just went out ond got some info off my receiver hitch 400# toung 4000# trailer 600# WD toung 6000# wd trailer. made me LOL but at least I don't have to buy a new hitch.

This is why I was researching, Planning a weekend jaunt this summer, and since we have it and it hasnt been used in about 5 years, why not

21ft 3700# roughly empty.



my yard looks liek shit
Old 03-08-2012, 09:28 AM   #149
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 53,844
Location: Houston, TX
User is: OffLine
Sounds like fun man.
Old 03-08-2012, 08:11 PM   #150
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: [Project] Clean Start

That's going behind the noma? what is the tow rating on our trucks anyways? Been wondering if I could pull our horse trailer.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:50 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.