DON'T use Russell quick connect fittings!!!! - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

DON'T use Russell quick connect fittings!!!!

Go Back   S-10 Forum > Engine and Drivetrain Tech > LSx Discussion
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 06-01-2011, 05:19 PM   #1
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
DON'T use Russell quick connect fittings!!!!

Just had another pop off on me while driving . This time it was the return line at the filter. I must've been spewing gas cause it ran out quick!!!!I obviously didn't realize it until I puttered to a stop. Looked around and a trail of fuel behind me for a ways.... So yeah not to happy right now
Old 06-01-2011, 05:24 PM   #2
Registered User
 
Age: 38
Join Date: Nov 2004
Posts: 265
Location: Phoenix, AZ
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Yeah, when messing with fuel, I don't want anything that disconnects easily.

Glad to hear nothing bad happened other than an empty tank of gas.
Old 06-01-2011, 05:33 PM   #3
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

They have a new design because so many people had been having issues with them popping off... I obviously would have never purchased them had I known this. I'm definitely not the only one though...And of course I have 5 of these fittings in my fuel system setup to top it all off..
Old 06-01-2011, 05:34 PM   #4
LSX Jimmy
 
moon509's Avatar

 
Age: 37
Join Date: Jan 2002
Posts: 4,028
Location: Bellingham, WA
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

yea, good to know, I was putting my order together at summitracing for the fittings
Old 06-01-2011, 06:27 PM   #5
Registered User
 
Age: 35
Join Date: Jan 2010
Posts: 509
Location: Scott, Arkansas
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I used the Dorman OEM fittings for all but the one that meets the rail and I used a JEGS brand quick connect at that point after reading a lot of trouble from the Russell fittings. It doesn't look the same as the Russell so I'm not sure who makes the fitting but it went on very snug and had a very positive lock when it went on.
Old 06-01-2011, 07:59 PM   #6
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Well I popped it back on just like the one at the fuel rail the other day and tried hard as hell to pull it off with no success...What gives?!?!?! It took forever to get the pump sucking fuel again...Tapped the bottom of the tank and got it running..I dunno if that's what did it but it cranked afterwards...I will be speaking with Russell/Edelbrock tomorrow about the issue and see what can be done about it..This is absurd IMO that so many others have had this issue...I'm usually easy going but I'm a lil upset about this issue since I don't think it's a user error and more of a manufacturer error...
Old 06-01-2011, 08:08 PM   #7
5 speed 4 door blazer
 
NYCBLAZER's Avatar

 
Join Date: Jan 2007
Posts: 1,189
Location: BROOKLYN, NEW YORK
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

And the way gas prices are right now, I would hate to be spilling it also..
Good thing nothing bad happened, and you and your truck are ok.
Old 06-01-2011, 08:18 PM   #8
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Yeah the other day when the one at the fuel rail popped off and spewed fuel all over a fully warmed up hot engine/headers/etc I'm lucky it didn't catch fire...I don't have a fire extinguisher in the truck so it would've burnt to the ground..Thank God it didn't though...Cause at 55~58PSI A LOT of fuel can spew out in a few seconds!!!
Old 06-01-2011, 08:42 PM   #9
Yes, they're all mine
 
pwtr02ss's Avatar
 
Age: 27
Join Date: Nov 2002
Posts: 2,729
Location: Tennessee
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

i used them on my swap. hope like hell i have the new design. I have just started my truck a few times for a few seconds, haven't finished it yet but i hope this doesn't happen to me. like you said they feel tight so it'll be interesting to hear what they have to say. @ $13-$15 bucks each they should be perfect cause like you i have 6. mine are the -6 braided fittings if that makes a difference
Old 06-01-2011, 08:56 PM   #10
518MOTORSPORTS
 
kybrad's Avatar
 
Age: 24
Join Date: Sep 2009
Posts: 392
Location: Elizabethtown, Ky
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

These are the fitting I used on my first swap, drove it 6000 miles and one never failed....but on the bad side I now have a total of 4 of these fitting where I only had two on the last truck. We also used 3 or these on a vette filter setup on the Silverado and it has 2 Walbro 255 and has not blown a hose yet.
Not to point fingers but I have noticed it is easy to put one of these on and not make the white tabs "lock" in place. I always push them on as hard as possible and then push the tabs to make sure they lock and then pull on the fitting as hard as I can to make sure it doesn't come off. Hope these dont become a problem tho, makes me a little worried.
Old 06-01-2011, 09:02 PM   #11
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

You would know if you had the new design check this out:

http://www.jegs.com/InstallationInst...799-641300.pdf

http://www.ls1tech.com/forums/conver...-fittings.html



I know I pushed them on all the way upon intial installation. I remember trying to pull them back off and then pushing them back to back sure my pulling didn't unseat them..
Old 06-01-2011, 09:51 PM   #12
518MOTORSPORTS
 
kybrad's Avatar
 
Age: 24
Join Date: Sep 2009
Posts: 392
Location: Elizabethtown, Ky
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by Petro
You would know if you had the new design check this out:

http://www.jegs.com/InstallationInst...799-641300.pdf

http://www.ls1tech.com/forums/conver...-fittings.html



I know I pushed them on all the way upon intial installation. I remember trying to pull them back off and then pushing them back to back sure my pulling didn't unseat them..

It does seem like they do have a problem. Them coming out with a new one makes me worry about my fittings. It would really make me mad if my truck burnt over a $15 fitting after me having to build a second truck because the last one was destroyed by someone else. We are all wondering what they will say to you when u call. I'm sure if they replace yours then they have stepped on a very slippery slope because we will all want them replaced. But on that same note replacing a few thousand fitting is cheaper then paying for 10 trucks that burn.
Old 06-01-2011, 10:01 PM   #13
Registered User
 
Iroc-10's Avatar
 
Age: 43
Join Date: Oct 2004
Posts: 2,484
Location: A-Town, Ill side
User is: Online
Re: DON'T use Russell quick connect fittings!!!!

I still don't have my fuel stuff, but I won't be using them. Thanks
Old 06-01-2011, 10:02 PM   #14
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I agree...They obviously realized something was wrong by them just changing the design...Some people may never have a issue but others have obviously had problems...
Old 06-01-2011, 10:05 PM   #15
Registered User
 
Barry's Avatar
 
Join Date: Jul 2009
Posts: 537
Location: Greenfield, IN.
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by Petro
You would know if you had the new design check this out:

http://www.ls1tech.com/forums/conver...-fittings.html



I know I pushed them on all the way upon intial installation. I remember trying to pull them back off and then pushing them back to back sure my pulling didn't unseat them..

thanks for this link Petro. I have the return and feed on the tank only thankfully. Im going to use his tube trick to lock it in for the time being. I always thought these things looked kinda chincy...
Old 06-01-2011, 10:13 PM   #16
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

The OP in the tech thread apparently had no luck with getting Edelbrock to admit fault. I may get nowhere fast by calling them but will still call none the less. Maybe they'll man up the the fault and replace them. We shall see
Old 06-02-2011, 10:16 AM   #17
It's a 4. something
 
scriptedmind's Avatar
 
Age: 28
Join Date: Apr 2007
Posts: 2,551
Location: Ward, AR
User is: Online
Re: DON'T use Russell quick connect fittings!!!!

lol FML I have 4 of these on my truck. It seems like every single part that I bought for my truck has now turned into parts that no one wants or buys.

Mien haven't come off yet but I know they were almost impossible to get on all the way.
Old 06-02-2011, 11:48 AM   #18
The Animal
 
V893S10's Avatar
 
Age: 24
Join Date: Apr 2009
Posts: 508
Location: Felton DE.
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I have not had an issue yet, but im gonna do the hose trick to be safe. Thanks for letting us know.
Old 06-02-2011, 10:40 PM   #19
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I didn't get a chance to call them today..Busy at work and when I got home I was prepping the truck for my tuning session tomorrow!!! Hopefully nothing pops of then....
Old 06-03-2011, 08:43 AM   #20
Registered User
 
Join Date: May 2008
Posts: 89
Location:
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

The plastic lock clips are the same as Gm has been using for many years. One trick is when you plug the connector over the clip you dont just slide it all the way on and forget about it. You have to pull outwards on the ears of the clip and slide the fitting back until the locks on the clip seat inside of the fitting.

In the other thread on tech, he tells how to make a saftey catch for the fittings.
Old 06-03-2011, 12:46 PM   #21
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Glad I found this before picking up my fittings. So have we figured out what brand fittings to use? The russel revisioned ones look good though.
Old 06-03-2011, 01:13 PM   #22
Registered User
 
Join Date: Jan 2010
Posts: 236
Location:
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Danng I hope this doesn't apply to my jegs brand quick connects I have like six of these hooked up!
Old 06-03-2011, 01:30 PM   #23
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Im pretty sure the new versions have a better retention system and wouldn't be worried about it with them. I'm nervous about the old style though because after the one at the fuel rail popped off I triple checked the rest of them and still had the other pop off....
Old 06-03-2011, 03:50 PM   #24
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Are the new russel ones under the same p/n? Im making a big list for Summit next weekend when they have their 10% off your order sale.
Old 06-03-2011, 06:10 PM   #25
Registered User
 
Iroc-10's Avatar
 
Age: 43
Join Date: Oct 2004
Posts: 2,484
Location: A-Town, Ill side
User is: Online
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by Petro
I didn't get a chance to call them today..Busy at work and when I got home I was prepping the truck for my tuning session tomorrow!!! Hopefully nothing pops of then....

Glad to hear that. I have not been on here much lately, but it sounds like that job interview went well a while back. Thanks again for the heads up on these.
Old 06-03-2011, 09:42 PM   #26
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Again no time to call them today...Work and then the short tuning session this afternoon...

The job interview did go well...Got a job as Nuclear Security...
Old 06-09-2011, 07:52 PM   #27
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

So does russel have the new design in the 3/8 and 5/16 sizes? All Ive found are -8an and 1/4 ones.
Old 06-09-2011, 08:27 PM   #28
Registered User
 
darkracer#212's Avatar
 
Age: 33
Join Date: Mar 2010
Posts: 82
Location:
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

good to know thanks
Old 06-09-2011, 08:32 PM   #29
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I put an order in on 3 644000 fittings -8an male to 3/8 push on. Summit has them back ordered until the end of the month but Pur Performance didnt list it as so plus they were much cheaper there, so I hope that they are in stock. Ill just have to run a -8an hose.
Old 06-09-2011, 08:36 PM   #30
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Russel doesnt have any 5/16 redesigned fittings listed so Ill just do that vinyl hose insert safety method.
Old 06-09-2011, 08:50 PM   #31
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I dunno if that -8an will affect anything or not...I thought they did have it 3/8 in -6an and not 5/16 -6an....hmmm...Russell had told me that it was most likely a user error and to give them a call if it continues to happen...I will be keeping a very close eye on everything...
Old 06-10-2011, 12:14 PM   #32
Registered User
 
sprayed99's Avatar
 
Join Date: Feb 2007
Posts: 380
Location:
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

This is odd they must have made a change in the machining process. I used several of these fittings in 08 and 09 and none of them have failed. By several I mean at least 40-50 fittings
Old 06-17-2011, 12:55 PM   #33
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Well Pur Performance cancelled my order since the fittings arent in stock. Are these new fittings even out yet? Both Summit and Jegs have the fittings listed as expected ship dates during the end of the month. And the black fittings arent shipping until July. I thought they were out already??
Old 06-17-2011, 01:53 PM   #34
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I thought they were out already also...The guys over on Tech talk like they're already using them...
Old 06-17-2011, 05:06 PM   #35
Bowtie Til I Die
 
s10studduts01s's Avatar
 
Age: 25
Join Date: Jan 2010
Posts: 2,305
Location: Easley, SC
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Man I tried getting mine on and off the fuel rail last night. It wasn't easy by any means so Idk what the deal is. The rest of the fittings I buy are going to be the dorman ones from Advance though just to keep from having as big of a chance with issues
Old 06-17-2011, 05:16 PM   #36
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

That one guy in the thread over on tech said it seems to be something that occurs over time with road/engine/etc vibrations making them come off...Because after I had that first one pop off I checked them all and could not for the life of me get them to pop off...then a few days later that other one popped off...
Old 06-18-2011, 08:54 PM   #37
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Checked russels online store and even they dont have these fittings listed? Need to make a decision on fittings this week, Maybe Jegs brand??
Old 06-29-2011, 07:01 AM   #38
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Looks like the new screw on style fittings will be out July 16th. So far just in blue but Black will be offered at a later date.
Check out the thread for p/n's on -6an 3/8 and 5/16

http://www.ls1tech.com/forums/conver...sconnects.html
Old 07-20-2011, 02:15 AM   #39
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Straight from Russells facebook page

"#644110
(Blue -6 AN Male to 5/16" SAE Quick-Disconnect Female with threaded retaining cap)
#644113
(Black -6 AN Male to 5/16" SAE Quick-Disconnect Female with threaded retaining cap)
#644120
(Blue -6 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)
#644123
(Black -6 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)
#644130
(Blue -8 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)"

Should make it easier for people to look up the new fittings.
Old 07-20-2011, 02:21 AM   #40
Registered User
 
sprayed99's Avatar
 
Join Date: Feb 2007
Posts: 380
Location:
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by tiresmokinV8
Straight from Russells facebook page

"#644110
(Blue -6 AN Male to 5/16" SAE Quick-Disconnect Female with threaded retaining cap)
#644113
(Black -6 AN Male to 5/16" SAE Quick-Disconnect Female with threaded retaining cap)
#644120
(Blue -6 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)
#644123
(Black -6 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)
#644130
(Blue -8 AN Male to 3/8" SAE Quick-Disconnect Female with threaded retaining cap)"

Should make it easier for people to look up the new fittings.

too bad summit racing keeps kicking the dates back..

Anyone need a 644120

Blue 3/8 to -6an I have an extra one.. Yes I got my hands on it and through the nose for it. brand new in the package

Anyone need it?
Old 07-20-2011, 06:23 AM   #41
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

I just bought 3 3/8's and 2 5/16 all black yesterday at performanceparts dot com. Already got the confirmation email that theyve shipped out. I noticed that Summit keeps pushing them back for some reason. Its easier for me to get them there since I live down the street from them. People on tech have recived theirs from Summit already though, I know the first couple that bought the revised blue ones recieved them on July 8th through Summit. Figured Id swap out the old clip style before my truck even fires, better safe then sorry.
Got 5 old style fittings for sale never seen fuel.
Old 07-20-2011, 08:10 AM   #42
LSX Jimmy
 
moon509's Avatar

 
Age: 37
Join Date: Jan 2002
Posts: 4,028
Location: Bellingham, WA
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by tiresmokinV8
I just bought 3 3/8's and 2 5/16 all black yesterday at performanceparts dot com. Already got the confirmation email that theyve shipped out. I noticed that Summit keeps pushing them back for some reason. Its easier for me to get them there since I live down the street from them. People on tech have recived theirs from Summit already though, I know the first couple that bought the revised blue ones recieved them on July 8th through Summit. Figured Id swap out the old clip style before my truck even fires, better safe then sorry.
Got 5 old style fittings for sale never seen fuel.
I ordered about 8 of the black ones from performanceparts.com last night. I also picked up a wixx 33737 for under 25 at

http://cgi.ebay.com/ebaymotors/ws/eB...OC%3AUS%3A1123
Old 07-26-2011, 10:10 PM   #43
Registered User
 
Age: 29
Join Date: May 2009
Posts: 267
Location: Council Bluffs,IA Omaha,NE
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

The russel connector are junk I thought it was just bad luck for some people and I got my engine to turn over tonight while it was turning over the engine backfire and big flame came up and burnt down driver side of my s10 and took half of cpw harness with it and melted body lights horn etc wiring and more I got a burnt up s10 to deal with its depressing after all money I sunk into getting it lsed now I think ill cut my losses with 94 and source other intake manifold then locate other cpw fans and get another cpw harness or build my own and put the 5.3/t56 in my 89 instead and also the fire heat messed up my droid phone volume button from just heat
Old 07-26-2011, 10:51 PM   #44
Killing Time
 
Petro's Avatar
 
Age: 29
Join Date: Oct 2008
Posts: 5,283
Location: Huntsville , AL
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

So one popped off and caused your truck to catch fire and melted your harness etc??? bummer man
Old 07-27-2011, 12:07 AM   #45
Registered User
 
Fat tony's Avatar
 
Age: 25
Join Date: Jan 2005
Posts: 93
Location: Grayslake, Ilinois
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by nocturnalsixer
The russel connector are junk I thought it was just bad luck for some people and I got my engine to turn over tonight while it was turning over the engine backfire and big flame came up and burnt down driver side of my s10 and took half of cpw harness with it and melted body lights horn etc wiring and more I got a burnt up s10 to deal with its depressing after all money I sunk into getting it lsed now I think ill cut my losses with 94 and source other intake manifold then locate other cpw fans and get another cpw harness or build my own and put the 5.3/t56 in my 89 instead and also the fire heat messed up my droid phone volume button from just heat
Mine have been working fine. Just wondering, did you remove the white clip from the inside of the fitting and install it on the hose end first?
Old 07-27-2011, 01:07 AM   #46
Dreaming of Turbos....
 
tiresmokinV8's Avatar
 
Age: 28
Join Date: Nov 2007
Posts: 3,607
Location: Springfield Twp, Ohio
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by Fat tony
Mine have been working fine. Just wondering, did you remove the white clip from the inside of the fitting and install it on the hose end first?

Is that the correct way?? I think most install it with the white clip inside the fitting as a whole. I know thats how I did it and pushed it one until I heard a click then pulled on it until the white tabs pushed outwards. But switched to the newer style to avoid the fires.
Old 07-27-2011, 01:32 AM   #47
Registered User
 
Age: 29
Join Date: May 2009
Posts: 267
Location: Council Bluffs,IA Omaha,NE
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Yes I installed it as whole and I have to buy new intake manifold and coil packs and other stuff I'm hong to keep the 94 frame and hopefully the 89 body will.swap right over.this time I'm going to just buy fuel rails with 6an fitting right on the rail that way it be safe and im losing sleep on this because I cheaped out on fitting fat tony chuck the fittings u have and get better u dint want same result as me mine clicked tight then it flame up

The $30 ain't worth the sight of truck burning down
Old 07-27-2011, 10:03 AM   #48
It's a 4. something
 
scriptedmind's Avatar
 
Age: 28
Join Date: Apr 2007
Posts: 2,551
Location: Ward, AR
User is: Online
Re: DON'T use Russell quick connect fittings!!!!

I put the white clip on the rail first then installed my fittings and I've never had an issue.
Old 07-27-2011, 10:37 AM   #49
Bowtie Til I Die
 
s10studduts01s's Avatar
 
Age: 25
Join Date: Jan 2010
Posts: 2,305
Location: Easley, SC
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

Quote: Originally Posted by Fat tony
Mine have been working fine. Just wondering, did you remove the white clip from the inside of the fitting and install it on the hose end first?
I think that is where most people mess up...
Old 08-02-2011, 08:56 AM   #50
Registered User
 
slonlow92's Avatar
 
Age: 32
Join Date: Jul 2011
Posts: 87
Location: mid mo
User is: OffLine
Re: DON'T use Russell quick connect fittings!!!!

So what are you guys going to use now? I'm ready to buy and I'm glad I seen this thread....
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:20 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.