smells like rotten eggs 4.3 c.p.i - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

smells like rotten eggs 4.3 c.p.i

Go Back   S-10 Forum > Specific Model Forums > 1st Gen Forums > Blazer / Jimmy / Bravada
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 09-23-2010, 04:07 AM   #1
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Lightbulb smells like rotten eggs 4.3 c.p.i

i have a 87 s10 truck with a 94 cpi 4.3 motor. it has just been rebuilt and after firing the motor up for the first time it fouled all 6 plugs simutaneously. thought maybe timing was off, so made an adjustment through the distributor after setting tdc and insted of the sulfer smell and fouling the next set of plugs, it smells like rotten eggs and fouled them again. any suggestions on what i should check next? please help thx
Attached Thumbnails
smells like rotten eggs 4.3 c.p.i-art-of-noize-2010-feb-21st.jpg  

Last edited by juicedon20s; 09-23-2010 at 04:09 AM.
Old 09-24-2010, 10:25 AM   #2
Registered User
 
blazerfun's Avatar
 
Age: 45
Join Date: Aug 2010
Posts: 123
Location: Western Norway
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Burnt electric components, smells weird.. Maybe you could call it "rotten eggs" .. Gas from overloaded battery or blown battery, bad groundings (very bad), blown ignition module..
Old 09-25-2010, 01:11 AM   #3
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

i put a new tps on and it seemed fine after that but didnt get a chance to run it too long had a small leak in my rad that turned into a fire hydrant bout 5 min after changin tps out. this truck is possessed. everything new on her never had problems before the build but now everything wants to go on it so now everythings new. what you think on the tps? it was runnin closed throttle was .50 volts, wide open was 5.10 volts with the bad one. .54 volts closed and 4.2 volts open throttle. standard voltage is less than 1.25 closed, and no more than 4.5 open.
Old 09-25-2010, 01:13 AM   #4
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

truck weas idling funny before the tps swap and now no idle prob no idea.
Old 09-25-2010, 02:07 AM   #5
Ruff ruff
 
BigTDawg's Avatar
 
Join Date: Jul 2010
Posts: 105
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Coolant is leaking from somewhere possibly. It could be a failed intake manifold gasket or cracked cylinder head, I've seen gasket failures without whitesmoke at first. Normally the sulphar smell is from unleaded gas but fouled plugs is more than gas.
Old 09-25-2010, 03:49 PM   #6
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Thx BIGDAWG I appreciate it man
Old 09-25-2010, 03:49 PM   #7
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

thx BLAZER.
Old 09-25-2010, 04:01 PM   #8
Budget Ballin FTS!
 
BrandonR's Avatar
 
Age: 24
Join Date: May 2010
Posts: 3,651
Location: Cullman,Al
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Are you running a catalitic convertor? Might be stopped up and this will do all the things your describing.
Old 09-25-2010, 04:26 PM   #9
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Quote: Originally Posted by BrandonR
Are you running a catalitic convertor? Might be stopped up and this will do all the things your describing.
I CHANGED OUT THE CAT BECAUSE I WOULD HAVE THE PIPE UP TO THE MANIFOLDS AND IT WOULDNT START, BUT I DROP THE PIPE FROM THE MANIFOLDS, IT WOULD START. SO I FIGURED CLOGGED CAT. I CHANGED IT OUT AND THAT CURED THE SULFER SMELL, AND RAN FINE AS FAR AS SMELL GOES BUT THEN AFTER I SHUT IT DWN AND LEFT IT SIT FOR ABOUT AN HOUR, I STARTED IT UP AGAIN AND HAD THE ROTTEN EGG SMELL, WHICH I WAS TOLD WAS FUEL RELATED. THAT ALSO MAKES SENSE BECAUSE THE FOULING OF THE PLUGS. IM TELLING U MAN THIS TRUCK IS DEFINITELY POSSESSED. LOL. THX FOR THE SUGGESTION THOUGH.
Old 09-25-2010, 04:42 PM   #10
WIP
 
GMC777's Avatar
 
Join Date: Sep 2009
Posts: 529
Location: Heaven
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

It could just be bad gas. ive seen it happen before. if i may ask where are you buying gas?
Old 09-27-2010, 04:23 PM   #11
Registered User
 
Age: 31
Join Date: Feb 2007
Posts: 9
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

circle k is the only gas thats been in it and it was freshly poured into a bone dry tank for the 1st time
Old 09-28-2010, 03:22 PM   #12
Budget Ballin FTS!
 
BrandonR's Avatar
 
Age: 24
Join Date: May 2010
Posts: 3,651
Location: Cullman,Al
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Quote: Originally Posted by juicedon20s
I CHANGED OUT THE CAT BECAUSE I WOULD HAVE THE PIPE UP TO THE MANIFOLDS AND IT WOULDNT START, BUT I DROP THE PIPE FROM THE MANIFOLDS, IT WOULD START. SO I FIGURED CLOGGED CAT. I CHANGED IT OUT AND THAT CURED THE SULFER SMELL, AND RAN FINE AS FAR AS SMELL GOES BUT THEN AFTER I SHUT IT DWN AND LEFT IT SIT FOR ABOUT AN HOUR, I STARTED IT UP AGAIN AND HAD THE ROTTEN EGG SMELL, WHICH I WAS TOLD WAS FUEL RELATED. THAT ALSO MAKES SENSE BECAUSE THE FOULING OF THE PLUGS. IM TELLING U MAN THIS TRUCK IS DEFINITELY POSSESSED. LOL. THX FOR THE SUGGESTION THOUGH.
no problem man, Idk what all could cause all of this again if its already been swapped out. Sounds like you got some fuel problems there
Old 10-05-2010, 01:32 AM   #13
Ruff ruff
 
BigTDawg's Avatar
 
Join Date: Jul 2010
Posts: 105
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Remove a plug from a port that's visable, crank the engine and see if liquid comes out. I don't think gas would foul plugs right after replacement, I could be wrong but that would have to be some nasty gas. You could drain a little gas to get a look at it.
Old 01-26-2012, 02:08 PM   #14
Registered User
 
Age: 28
Join Date: Feb 2007
Posts: 9
Location: 305
User is: OffLine
Unhappy Re: smells like rotten eggs 4.3 c.p.i

Any updates on this issue? I purchased a '94 S15 Jimmy in early December. Truck has 134k on the 4.3. My truck REEKS like old gas after it gets hot. I have put +/- 1,500 miles on it since I bought it. I also did cap n rotor, 6 plugs, plug wires, and put an MSD 6A, but the smell was present before all of that. I noticed on my way home, the smell came in through the a/c.
Old 01-26-2012, 08:55 PM   #15
86, 2.5L, 4spd
 
Blkwdw86's Avatar
 
Age: 43
Join Date: Nov 2009
Posts: 230
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Catalytic converter. Time for a new one.
Old 01-27-2012, 09:10 AM   #16
86, 2.5L, 4spd
 
Blkwdw86's Avatar
 
Age: 43
Join Date: Nov 2009
Posts: 230
Location:
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Sorry, didn't show previous posts before I posted.

While on the way to work this morning following a newer Silverado with burning embers flying up from under his truck (!!!) I got to thinking about your problem more in depth.

About the only thing that will cause a rotten egg smell on these trucks is a blown cat, which is why I answered as such. Cats fail over time, that's a given, it takes some serious abuse throughout it's lifespan and still in spite of that, it's a reliable device.

That's not to say you can't blow one though. The gas smell combined with the rotten egg smell tells me you're blasting unburned fuel into the exhaust system, the number one killer of catalytic converters. Not hard to check, take a decently spirited drive after dark, then poke your head up underneath and look at it, undoubtedly it'll be glowing cherry red. That's NOT normal. It's glowing like that because it's comleting the combustion of raw fuel going into it.

So now we have to figure out why your cylinders aren't burning the fuel. Rich mixture or mechanical defect? Start by changing the O2 sensor, it's the chief controller for mixture. Check your fuel pressure regulator, if it's not holding the pressure down the injector will shoot too much fuel. Go through your ignition system, weak spark will won't fully ignite the fuel. Check timing, too much advance and the combustion is blowing out the exhaust before it's completely burned.

You might have burned up your new cat, check it as well.
Old 01-27-2012, 09:20 AM   #17
Registered User
 
Age: 28
Join Date: Feb 2007
Posts: 9
Location: 305
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

Thank you, I'm going to do the full exhaust and update!
Old 01-28-2012, 09:15 PM   #18
Registered User
 
n2o4myfix's Avatar
 
Age: 38
Join Date: Feb 2011
Posts: 50
Location: central Wisconsin
User is: OffLine
Re: smells like rotten eggs 4.3 c.p.i

I had a 4.3L in my 94 jimmy that had the same problem, stunk and run rough at idle and would foul plugs. I problem was the egr valve had a chunk of carbon stuck in it holding it open, I replaced the egr gasket with one of these with a screen and never had that problem afterwards.



Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:20 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.