Security light comes on while driving, gauges quit working - S-10 Forum
 
LinkBack Thread Tools
post #1 of 7 Old 01-14-2011, 03:44 PM Thread Starter
Registered Users
 
Join Date: Jan 2011
Posts: 4

User is: Butch50 is offline
Security light comes on while driving, gauges quit working

Hello!

I am new to this forum. Did a lot searching on this particular problem but no joy.

1998 S10 2.2L Automatic

Occasionally while driving my gauges go out, or in some cases give innacurate displays. From the bottom up: Gear selection does not show. Oil pressure zeros out. Amps zeros out. Gas gauge zeros out. Speedometer innacurate - slower than actual. RPMs inaccurate - lower than actual. Several of the top warning lights light up, including security light.

The truck still runs fine. If I shut it off, the security light stays lit. The truck still starts and runs.

So far it has not be much of a problem other than trying to guess how fast I am going. But...I am afraid that whatever this problem is, it will get worse with time.

Has anyone got an idea what is malfunctioning - and how to fix it?

Thanks in advance for any and all suggestions.

Butch50 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-15-2011, 02:41 PM
Registered User
 
Join Date: Jan 2010
Posts: 133

User is: bodaciuos is offline
Re: Security light comes on while driving, gauges quit working

i would think its the cluster going bad. u should try pulling it out and resetting it in place. to see if its just have bad contacts to to vehicle.. or try getting it replaced. u dont want a short . could make thing worse good luck..
bodaciuos is offline  
post #3 of 7 Old 01-16-2011, 01:44 AM
UnfiNished PRoJecT
 
Join Date: Sep 2009
Age: 29
Posts: 94

User is: jeffwpayne is offline
Re: Security light comes on while driving, gauges quit working

^^ that or bad ground, maybe alternator is going bad

D.R.A.G.G.I.N-ASS
jeffwpayne is offline  
post #4 of 7 Old 01-17-2011, 09:49 AM
Registered Users
 
Join Date: Jan 2011
Posts: 3

User is: 2.2whiteS10 is offline
Re: Security light comes on while driving, gauges quit working

I am having the same problems. I found this thread but have not had a chance to check for this loose ground. Here is a quote from the thread that gives you the best idea where it is.

Quote:
My truck did the same exact thing. There is a bolt that runs into the bottom of your dash on the left side on the fuse panel side. As your dash slopes down it will be right at the bottom close to the hood release i think. There is a ground wire on that bolt, and it is prolly loose. I think its the main ground for your dash lights n stuff. I just tightened the bolt up and made sure the wire didnt wiggle. Dash lights never went out again. This could b ur problem. Hope that helps.

http://www.s10forum.com/forum/f104/d...licker-238450/
2.2whiteS10 is offline  
post #5 of 7 Old 01-17-2011, 12:04 PM
Registered Users
 
Join Date: Jul 2009
Age: 32
Posts: 8

User is: swigs84 is offline
Re: Security light comes on while driving, gauges quit working

my truck did the same thing ended up being the cluster itself
swigs84 is offline  
post #6 of 7 Old 01-18-2011, 01:32 PM Thread Starter
Registered Users
 
Join Date: Jan 2011
Posts: 4

User is: Butch50 is offline
Re: Security light comes on while driving, gauges quit working

Thanks for the tips!

Checking the ground under the dash will be my first step - since it will be the cheapest.

I will also run a voltage output check while the lights are working properly, and another if they fritz on me again - to see if there is a difference.

If that doesn't work then I will try pulling and replacing the cluster to see if freshening the contacts helps.

If that doesn't work then I will replace the cluster.

By the way - I had a new alternator installed several months ago. It shows a good charge when running. I didn't have the lights problem back when the old alternator was going bad. Not that that means it isn't the alternator this time.

I appreciate the feedback - a lot!
Butch50 is offline  
post #7 of 7 Old 01-20-2011, 02:30 PM
Registered User
 
Typoe99's Avatar
 
Join Date: Aug 2010
Location: Oak Lawn
Age: 25
Posts: 130

User is: Typoe99 is offline
Re: Security light comes on while driving, gauges quit working

im having a similar issue where my security light will come on randomly. the cluster doesnt stop working but lately the security light just randomly comes on and will go away if i turn the truck off and restart it. do you think it could be a grounding issue as well?

1998 S10 Pickup
2.2L 5-Speed Manual
Typoe99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome