P0452 OBDII code. Need help with fix please... - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

P0452 OBDII code. Need help with fix please...

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 07-20-2008, 07:26 PM   #1
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Angry P0452 OBDII code. Need help with fix please...

I have a 2000 GMC Sonoma, V6, 4x4. I'm driving down the highway and all of a sudden I lose power when I am pushing on the gas pedal. Everytime I push on the gas pedal the engine wants to cut out. The engine eventually dies when the truck slows down enough. I restart the engine and it idles no problem. I get back on the highway and as soon as I push the gas pedal at least halfway or more, the engine cuts out again.
This goes on for about 20 or so miles. Eventually the engine dies and now won't fire back up. It'll crank over like a champ, just won't fire up.

Side note: The engine will fire up when starter fluid is sprayed in the throttle body. There's fuel getting to the injection lines, everytime I pushed the check valve on the line, it sprayed fuel out.

I returned the next day with an OBDII meter and two codes popped up.

P0131 - O2 Sensor Circuit Low Voltage (Bank 1 Sensor 1)
P0452 - Evaporative Emission Control System Pressure Sensor Low Input

I've replaced BOTH O2 sensors, in front and in back of catalytic converter. Still no fire from engine. The second code, P0452, I have no idea what the heck to look or check for.

Can anyone help please?
Old 07-20-2008, 08:17 PM   #2
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

I almost forgot...

A few months ago, in April, I replaced the fuel pump, fuel filter, spark plugs, spark plug wires, distributor cap and rotor, and the air filter.

Fuel pump wasn't by choice either, not at $300 a pop, heh. The other one went bad.
Old 07-20-2008, 08:36 PM   #3
Wannabe Dragger
 
ExtCab96S_Dime's Avatar
 
Age: 27
Join Date: Jun 2005
Posts: 1,714
Location: Neenah, Wisconsin
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

First question, did you recently put gas in your truck? If so, make sure the gas cap is tightened down securely.
Old 07-20-2008, 08:41 PM   #4
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

Yep, I put gas in the tank on Friday morning before work and the problems occurred Friday late afternoon.

I've taken the gas cap off and rescrewed it back on a few times, but I don't think this is why the truck won't fire up at all.
Old 07-20-2008, 08:46 PM   #5
Wannabe Dragger
 
ExtCab96S_Dime's Avatar
 
Age: 27
Join Date: Jun 2005
Posts: 1,714
Location: Neenah, Wisconsin
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

No, that's just one thing that might've thrown the code. It could still be a bad gas cap I guess. However, you probably want to check all the vacuum lines. If that's not it, I think something wrong with the sensor.
Old 07-20-2008, 08:47 PM   #6
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

That's my problem though, I have no idea what the sensor looks like or even where to begin to look for it. That's what I need help with.
Old 07-20-2008, 08:51 PM   #7
Wannabe Dragger
 
ExtCab96S_Dime's Avatar
 
Age: 27
Join Date: Jun 2005
Posts: 1,714
Location: Neenah, Wisconsin
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

You're not going to like this. I think it's in the tank, but I'm not 100% on that.
Old 07-20-2008, 09:36 PM   #8
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

Well, IF it's in the tank, that won't be a problem. There's only 8 bolts holding the bed on and it's easy enough to pull the bed and slide it down just enough to uncover the fuel tank.

I need someone to confirm where this sensor really is though. Any help is appreciated, thanks.
Old 07-20-2008, 09:38 PM   #9
Wannabe Dragger
 
ExtCab96S_Dime's Avatar
 
Age: 27
Join Date: Jun 2005
Posts: 1,714
Location: Neenah, Wisconsin
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

Well before you go doing that, I'd make sure on the vacuum lines, if you haven't. Those are a lot easier to check than the 8 bolts you're talking about lol
Old 07-22-2008, 08:37 PM   #10
Registered User
 
KILLBOY POWERHEAD's Avatar

 
Age: 43
Join Date: May 2002
Posts: 1,008
Location: Maryland
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

also you mat to check fuel pressure , as the pump may not be pushing 55 psi or the regulator may be bad , the sensor in question is on top of the tank if you need any more pm or email me

jim
Old 07-22-2008, 08:52 PM   #11
Registered User
 
Age: 37
Join Date: Jul 2008
Posts: 6
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

I checked the fuel pressure. 26 psi on the fuel injection line and 27 psi in place of the fuel filter, which is right after the fuel pump.

Faulty fuel pump. Good thing it's under warranty. I can't believe the fuel pump went out after only 2 months (I know I said I bought it in April, but I was corrected by the parts store, lol, I bought it in May apparently).

Thanks for the help fellas.
Old 10-19-2008, 03:09 AM   #12
Registered User
 
01blzxtreme's Avatar
 
Age: 25
Join Date: Apr 2008
Posts: 576
Location:
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

hmm looks like your were having the exact same problems as me,
my truck is doing that when running, and if i punch on the gas itll only reach 3000 rpms, also did your truck backfire once in a while when trying to accelrate to hard,
Old 10-20-2008, 05:36 PM   #13
body drop in progress
 
97low's Avatar
 
Age: 26
Join Date: Jul 2007
Posts: 299
Location: jacksonville, fl
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

yep i went through the same shit i replaced my fuel pump then 3 months later it went out again.
Old 06-06-2009, 06:38 AM   #14
drag or go home
 
awrone's Avatar
 
Join Date: Aug 2004
Posts: 162
Location: s10 heaven,
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

Quote: Originally Posted by xxxSwoopdawgxxx
I checked the fuel pressure. 26 psi on the fuel injection line and 27 psi in place of the fuel filter, which is right after the fuel pump.

Faulty fuel pump. Good thing it's under warranty. I can't believe the fuel pump went out after only 2 months (I know I said I bought it in April, but I was corrected by the parts store, lol, I bought it in May apparently).

Thanks for the help fellas.
I know this is few months later, but did a new fuel pump fix it?

I had the EXACT same symptoms shorty after running out of gas once. Same P0452 code too. Also, my truck has been having trouble with starting in the morning. However, I ask if a new pump fixed it because mine is currently reading 50-55psi which is closer to normal so Im not sure if its the pump. But I have yet to test the pressure when it stalls out. I guess I will have to carry around a pressure gauge.
Old 07-07-2009, 11:58 PM   #15
Registered User
 
twisted2door's Avatar
 
Age: 31
Join Date: Feb 2007
Posts: 25
Location: pikeville, nc
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

I too am having a similar problem on an 01 blazer. Not to butt in on your post. I replaced the fuel pump, with an aftermarket(seeing now people are saying its a bad idea ). I get the engine code saying ''fuel tank pressure sensor low input''. I have changed this sensor and still no better. It turns over no problem, if you keep trying to crank it it will eventually crank. Once warmed up there is no problem cranking it that day. Put a fuel pressure gauge on it tonight, it is reading 45psi at the check valve. This is with the key switch on, once the pump stops running the pressure slowly drops to around 25. i can get it to crank to get a running reading.
Old 07-18-2009, 03:35 PM   #16
90 f**kin 7 s f**kin 10
 
vespasoul's Avatar
 
Join Date: Mar 2005
Posts: 96
Location: las vegas, nv
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

maybe this will help
there is a minimum of 3 O2 sensors, typicaly there is 4.
one on each exhaust manifold, in addition to one before cat, and one after cat.
the P0131 code refers to the one on exhaust manifold on drivers side.
Old 12-24-2009, 10:27 AM   #17
Boogie
 
misteviouse's Avatar
 
Age: 28
Join Date: Jan 2006
Posts: 1,220
Location: Orange County CA
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

i have` a 98 s10 with a deviouse gas tank... ,my truck is getting the same p0452 code.... but it runs perfectly fine no sputtering or anything... randomly it will turn over and like sputter to start up... but when it does that if i shut it off it after and then start it again it fires right up....

what tool do i check the pressure in the tank with?
Old 07-12-2010, 02:09 AM   #18
2001 ZR2 S!O
 
ZR2 S10 MAN's Avatar
 
Age: 24
Join Date: Jul 2010
Posts: 11
Location: OLY, WA
User is: OffLine
Question Re: P0452 OBDII code. Need help with fix please...

I have a 2001 4,3 S10 Pickup. I need to replace the fuel tank pressure sensor. Engine Light came on with the code P0452: Evaporative Emissions System Pressure Sensor/Switch Low Input.

The first instinct is gas cap. Well i just got a new one and it didn't fix problem. I know its not gas cap because when i have around a quarter of gas left my gas gauge freaks out and starts bouncing around empty. Then the engine light comes on after ive been running it around a quarter of gas. And then it reads the same code....P0452. So it has to be the sensor, people say check wires and bblah bla but my gauge would be off all the time if it was wiring. And my gas gauge wouldn't just freak out when im running low on gas and the check engine light would come on more often. I try to keep the tank full and when i do the problem never occurs. But I also know the EVAP is connected to the overall performance of the throttle body so I would like to get this fixed and maybe improve gas mileage.

So i want to know how to change the Fuel tank pressure sensor. I was wondering if you have to take the fuel pump out. Is the sensor attached to the fuel pump? They say you have to drop gas tank to reach the sensor, well i have Zr2 suspension and i can reach this electrical harness on top of the tank with my hand and im not sure if that's the sensor. It would be nice if the sensor was separate from the fuel pump, if so i think i might be able to change it without dropping the tank.

If anyone has detailed step by step instructions on how to replace this sensor, it would be highly appreciated. If you would like to email me an answer or a url or pictures on how to, my email is and1_player547@yahoo.com
Old 02-04-2012, 09:24 AM   #19
Registered User
 
Age: 28
Join Date: Feb 2012
Posts: 1
Location: Indianapolis
User is: OffLine
Re: P0452 OBDII code. Need help with fix please...

I am currently having this problem. I replaced the fuel pump back in October. It started having the issues on Jan 31st. Code P0452. I replaced the MAF sensor, air filter, TPS, fuel fill tube hose that leaked when I filled it up, replaced vacuum lines, fuel filter & eventually the EVAP sensor on the fuel tank. Replacing the EVAP sensor made the check engine light go out but still had the same problem. I had checked fuel pressure w/ the auto zone loaner & with key on had 45 psi & once started it dropped to about 12 psi. The pump I replaced in the fall I had ordered off ebay since it was much cheaper. This was probably why.
Plus all the front end repair work I did, new bumper, grill, headlights and all. It had been wrecked over the summer. So I have dumped a lot of money into this truck.
I will try a new fuel pump & let you know what happens.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:10 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.