Fuel Gauge not workin..97' sonoma - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Fuel Gauge not workin..97' sonoma

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 09-24-2010, 02:03 AM   #1
Registered User
 
BLas10's Avatar
 
Age: 23
Join Date: Jun 2009
Posts: 11
Location: miSsion TX
User is: OffLine
Fuel Gauge not workin..97' sonoma

the fuel gauge dont work... and it say low fuel too..
i already replaced the comple fuel pump but its still tha same..
anybody knows what the problems might be/??
Old 09-24-2010, 03:35 AM   #2
It's a Blue thing...
 
♠ ▀lυε ♠'s Avatar
 
Age: 28
Join Date: May 2003
Posts: 12,410
Location: ♠5★3★0♠
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

The gauges or the wire going to them.
Old 09-24-2010, 07:12 PM   #3
Registered User
 
BLas10's Avatar
 
Age: 23
Join Date: Jun 2009
Posts: 11
Location: miSsion TX
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

well idk why it doesnt show how much gas it has and it says low fuel
if i already put a new fuel pump in it...
Old 09-25-2010, 12:54 PM   #4
Registered User
 
Join Date: Jan 2010
Posts: 133
Location:
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

i have the same problem on 2001/ 2002 model ls 4.3.. im working on the wiring. guages r goods and i have 4.5 volt coming from sending unit.. im working on the wiring to the gauges. been on this for two days know.. if any one know where to pin point problem .. that would be great..
Old 09-26-2010, 06:16 PM   #5
Registered User
 
BLas10's Avatar
 
Age: 23
Join Date: Jun 2009
Posts: 11
Location: miSsion TX
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

Quote: Originally Posted by bodaciuos
i have the same problem on 2001/ 2002 model ls 4.3.. im working on the wiring. guages r goods and i have 4.5 volt coming from sending unit.. im working on the wiring to the gauges. been on this for two days know.. if any one know where to pin point problem .. that would be great..
did you find the problem already?? lol
Old 09-27-2010, 12:07 AM   #6
Registered User
 
Energizer023's Avatar
 
Age: 22
Join Date: Oct 2009
Posts: 184
Location: Ga
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

Im not familar with the 2nd gen, but is there a fuse for the fuel level that could be blown.
Old 11-18-2010, 09:42 AM   #7
Registered User
 
Join Date: Jan 2010
Posts: 133
Location:
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

sorry ,know i never found the problem... i think im going to send it to a dealer or to a electro mechanic.. to se if they could figure it out .. im stumped..
Old 11-18-2010, 09:45 AM   #8
Electrical Mod
 
deathphoenix99's Avatar

 
Age: 24
Join Date: Oct 2007
Posts: 51,740
Location: Houston, TX
User is: OffLine
Re: Fuel Gauge not workin..97' sonoma

On the 97, it's common that the fuel buffer goes bad. Look at the wiring diagrams in my sig, if it's sitting on empty, that means theres a short to ground somewhere. It could be a faulty gas gauge, but I believe it's a wire that's shorted out somewhere.

YOu can test this, remove the cluster, and find the pin for fuel gauge, check the resistance, should be 0-90 ohms, closer to 0 is empty while 90 is full.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:54 PM.

Powered by vBulletin┬« Copyright ┬ę2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.