98 Sonoma will crank, but not start - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

98 Sonoma will crank, but not start

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 03-01-2011, 03:07 PM   #1
Registered User
 
Age: 38
Join Date: Jun 2004
Posts: 19
Location:
User is: OffLine
98 Sonoma will crank, but not start

Bought a 98 Sonoma Highrider for my girlfriend to drive in winter. The guy had wrecked the truck & damaged the passenger side control arms. The bed is shot, & needs bottom of third door replaced, but that's the least of my problems now. The truck sat for about 2 months. So we went over to check it out last weekend would not start just crank over, but you could tell from time to time it was trying to start. Changed plugs & after alot more cranking the truck fired up & ran great. No smoke, or noises from the motor at all. This weekend went over & installed new tires & changed upper pass side control arm & a new outer ball joint & truck will not start at all. We checked for engine codes their is none. Checked the fuel pump & was carrying 60lbs at the rail, swapped the coil, still will not start. They said it started fine 2-3 times in the week it sat there, but will not start now. Have talked to a few mechanics & am getting alot of things. First everyone tells me to change the coolant temp switch, they say it controls the temp for the injectors, so i bought a new one & will try this weekend if weather permitting. Also my brother in law took the ignition switch from his 98 parts blazer & also crank sensor, hope to try all this weekend. Their is no problems with the dash, but my 97 Jimmy had tranny problems because the ignition switch was going bad. The boy who owned it had tranny problems & sent it off & had it rebuilt, so i am kinda leaning towards the ignition switch. Any useful info appreciated. Thanks
Old 03-02-2011, 08:37 AM   #2
Registered User
 
Age: 38
Join Date: Jun 2004
Posts: 19
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

No one has any advice?
Old 03-04-2011, 09:36 PM   #3
Registered User
 
Age: 26
Join Date: Mar 2011
Posts: 10
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

How many miles? A mileage milestone would help a bit. If it started the other day, and now suddenly is not again, my guess would be the CPS (crank position sensor)
Same thing happened to my dad's 99 S10, only without the sitting time. Started taking longer to start one day, gradually got worse over the next few days. We replaced plugs, wires, cap, coil, etc. It started and ran fine for like 3 days. Then on the 4th morning, would not start at all. Turned out it was the CPS.
Old 03-04-2011, 09:42 PM   #4
Registered User
 
2.2X-10's Avatar
 
Age: 38
Join Date: Feb 2005
Posts: 2,047
Location: Columbia
User is: OffLine
Re: 98 Sonoma will crank, but not start

is there gas in it now?, what about the grounds from engine to frame or from wire harness to back of frame
Old 03-06-2011, 11:08 AM   #5
Registered User
 
Age: 38
Join Date: Jun 2004
Posts: 19
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

Mileage just shy of 185k, yes it has half of a tank & is getting fuel & spark. Got the truck home friday by driving it, would not start sat. Replaced cap & button no help, the old one was the original. I do have a spare crank sensor, can try it later this week. Got my WRX in the garage waiting a new Perrin Turbo Inlet. Went ahead & got a new ignition switch try it later this week also weather permitting. One question i have is how do you tell if this thing has passlock. It has no power options, but does have a security light in dash panel. Whatever it is has to be simple, the truck runs to good when it does start. Keep coming with the advice & i will keep you posted. Thanks
Old 03-10-2011, 01:02 PM   #6
Registered User
 
Age: 38
Join Date: Jun 2004
Posts: 19
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

Just to let you all know i must have gotten something wet when i purple powered the motor, starts & runs fine now. Just been tuning it up new coolant temp sensor,plugs, wires, cap, button fuel filter & pcv valve. All were original except the fuel filter, but it was getting plugged up. Thanks
Old 03-10-2011, 01:13 PM   #7
Registered User
 
Age: 23
Join Date: Mar 2011
Posts: 5
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

Quote: Originally Posted by schrok
Bought a 98 Sonoma Highrider for my girlfriend to drive in winter. The guy had wrecked the truck & damaged the passenger side control arm bushings. The bed is shot, & needs bottom of third door replaced, but that's the least of my problems now. The truck sat for about 2 months. So we went over to check it out last weekend would not start just crank over, but you could tell from time to time it was trying to start. Changed plugs & after alot more cranking the truck fired up & ran great. No smoke, or noises from the motor at all. This weekend went over & installed new tires & changed upper pass side control arm & a new outer ball joint & truck will not start at all. We checked for engine codes their is none. Checked the fuel pump & was carrying 60lbs at the rail, swapped the coil, still will not start. They said it started fine 2-3 times in the week it sat there, but will not start now. Have talked to a few mechanics & am getting alot of things. First everyone tells me to change the coolant temp switch, they say it controls the temp for the injectors, so i bought a new one & will try this weekend if weather permitting. Also my brother in law took the ignition switch from his 98 parts blazer & also crank sensor, hope to try all this weekend. Their is no problems with the dash, but my 97 Jimmy had tranny problems because the ignition switch was going bad. The boy who owned it had tranny problems & sent it off & had it rebuilt, so i am kinda leaning towards the ignition switch. Any useful info appreciated. Thanks

battery still good?
Old 03-10-2011, 02:28 PM   #8
Registered User
 
Age: 38
Join Date: Jun 2004
Posts: 19
Location:
User is: OffLine
Re: 98 Sonoma will crank, but not start

If you read the entire post i was saying that it runs fine now. It was either the egr being stuck, just cleaned it the best i could or replacing the coolant temp sensor. It would not start next day because i had hosed the motor down & must have gotten something wet. Runs & starts fine now, just need to figure out the 4WD now & why i have no reverse lights.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 03:00 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.