98 s10 won't start in cold weather - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

98 s10 won't start in cold weather

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 12-01-2010, 02:58 PM   #1
Registered User
 
omgs10's Avatar
 
Age: 23
Join Date: Aug 2010
Posts: 175
Location:
User is: OffLine
98 s10 won't start in cold weather

Ok i have a 98 s10 2.2 5spd. I live in oklahoma, i go to work around 4 pm and get off around 2-3 am. Car starts up fine when i go to work, but when i get off it won't start. (A lot colder at 3am.) The engine cranks over just fine, but won't start. My egr tube is cracked so i figured maybe it was sucking in cold air? I also bought some HEET, but that didn't solve anything. Any ideas.?
Old 12-04-2010, 01:28 PM   #2
S-Series Addict
 
SonomaGT's Avatar
 
Join Date: Nov 2009
Posts: 250
Location: SE Michigan
User is: OffLine
Re: 98 s10 won't start in cold weather

Look around for any vacuum leaks, thats where i would start.
Old 12-04-2010, 03:00 PM   #3
Registered User
 
Zeeke98's Avatar
 
Age: 40
Join Date: Aug 2003
Posts: 10,370
Location: Michigan
User is: OffLine
Re: 98 s10 won't start in cold weather

Weak coils could cause it also. Never had it on my 2.2's but had a 4.3 I had put an Accel coil in it and when it got below a certain temp it wouldn't start. If it was above freezing it was fine.
Old 12-12-2010, 09:31 PM   #4
Registered User
 
omgs10's Avatar
 
Age: 23
Join Date: Aug 2010
Posts: 175
Location:
User is: OffLine
Re: 98 s10 won't start in cold weather

Quote: Originally Posted by Zeeke98
Weak coils could cause it also. Never had it on my 2.2's but had a 4.3 I had put an Accel coil in it and when it got below a certain temp it wouldn't start. If it was above freezing it was fine.
I fixed my vacuum leak but still having problems in the cold. Idk what to do?
Old 12-12-2010, 10:52 PM   #5
Registered User
 
Zeeke98's Avatar
 
Age: 40
Join Date: Aug 2003
Posts: 10,370
Location: Michigan
User is: OffLine
Re: 98 s10 won't start in cold weather

Have you checked your coils?
Old 12-14-2010, 11:42 AM   #6
King Tut
 
JLiRD808's Avatar
 
Join Date: May 2010
Posts: 233
Location: Honolulu/Cincy
User is: OffLine
Re: 98 s10 won't start in cold weather

Quote: Originally Posted by Zeeke98
Have you checked your coils?
Update on this? My 98 2.2 wont start either...just had the crank sensor replaced and it seemed to work fine for a couple days but today was REALLY cold and the problem persists!
Old 12-08-2011, 08:53 AM   #7
King Tut
 
JLiRD808's Avatar
 
Join Date: May 2010
Posts: 233
Location: Honolulu/Cincy
User is: OffLine
Re: 98 s10 won't start in cold weather

Wow...almost 1 year later to the date...and my problem persists.

Just got a brand new battery too.

Any ideas?

THX!
Old 12-08-2011, 06:19 PM   #8
Registered User
 
Zeeke98's Avatar
 
Age: 40
Join Date: Aug 2003
Posts: 10,370
Location: Michigan
User is: OffLine
Re: 98 s10 won't start in cold weather

Did you ever check your coils as I suggested a year ago?
Old 12-12-2011, 11:39 AM   #9
Registered User
 
Join Date: Nov 2011
Posts: 37
Location:
User is: OffLine
Re: 98 s10 won't start in cold weather

someone told me these trucks have a cold start sensor located by the throttle position sensor that could b causing this problem..........mine is a 4.3 auto, 2001
Old 12-14-2011, 12:03 AM   #10
Vig Pimpin
 
viggy58's Avatar
 
Age: 31
Join Date: Apr 2011
Posts: 724
Location: Lawrenceville, GA
User is: OffLine
Re: 98 s10 won't start in cold weather

dist cap allowing moisture in? something is either killing spark, or you have a weak fuel pump that can't pull enough pressure when it's cold.

try starting it with a shot of carb cleaner. if it starts, you have a fuel delivery problem
pull the plugs and see if they're covered with gas when the no-start occurs. if they're wet, you have no spark.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:56 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.