96 s10 won't start when hot (pcm?) - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

96 s10 won't start when hot (pcm?)

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 09-10-2010, 09:31 PM   #1
Registered User
 
Age: 56
Join Date: Sep 2010
Posts: 2
Location:
User is: OffLine
96 s10 won't start when hot (pcm?)

96 4.3 vortec starts ok cold and will run all day
but if engine is turned off it will not start back up till pcm cools down
pcm is hot to touch' no fuel pump prime or ignition.
does replacing pcm sound right or am i missing something
Old 09-10-2010, 09:34 PM   #2
UN-BANNED B!TCHES!!!!!
 
NotaDime's Avatar
 
Join Date: Jan 2007
Posts: 6,950
Location: Verizon's iPhone4
User is: OffLine
Re: 96 s10 won't start when hot (pcm?)

ignition module would sound more like it...

autozone can test it for free, drive the truck to them and get it nice and hot, remove it quickly and bring it in...

its mounted to your coil.





allthough the fuel pump not turning on wouldnt be related. are you 100% sure its not coming on either? or 99%?

Last edited by NotaDime; 09-10-2010 at 09:38 PM.
Old 09-11-2010, 06:08 AM   #3
i saw what you did there!
 
fast68chevy's Avatar
 
Age: 36
Join Date: Sep 2002
Posts: 3,571
Location: Lincoln IL
User is: OffLine
Re: 96 s10 won't start when hot (pcm?)

ICM or CS

one or the other

is crapping out due to heat

it happens pretty often


everyone always automatically think its the computer

but its not

9 times out of 10 its failed sensor or ICM or FP

Last edited by fast68chevy; 09-11-2010 at 06:09 AM.
Old 09-12-2010, 09:44 PM   #4
Registered User
 
Age: 56
Join Date: Sep 2010
Posts: 2
Location:
User is: OffLine
Re: 96 s10 won't start when hot (pcm?)

100% on fuel pump not coming on and when I cool the pcm truck starts right up
Old 09-15-2010, 09:25 PM   #5
Registered User
 
Age: 69
Join Date: Sep 2010
Posts: 28
Location: central Florida
User is: OffLine
Re: 96 s10 won't start when hot (pcm?)

If it won't even turn over, then the starter solenoid is too hot. It is very close to the exhaust. Installing a heat shield over it will help.
Old 09-15-2010, 09:27 PM   #6
UN-BANNED B!TCHES!!!!!
 
NotaDime's Avatar
 
Join Date: Jan 2007
Posts: 6,950
Location: Verizon's iPhone4
User is: OffLine
Re: 96 s10 won't start when hot (pcm?)

wow, sounds like it may well be the pcm then...

try to get ahold of a spare one to try it out
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:49 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.