02 s10 won't start - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

02 s10 won't start

Go Back   S-10 Forum > Specific Model Forums > 2nd Gen Forums > S10 / Sonoma
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 12-28-2011, 03:50 PM   #1
Registered User
 
Age: 33
Join Date: Dec 2011
Posts: 5
Location:
User is: OffLine
02 s10 won't start

Hola. My 02 s10 2.2 4L won't start. It started a few months ago with intermittent problems. All lights and noises come on with the key in, but it wouldn't turn over. Then it would, then it wouldn't.

now it just won't start.

cables have been stripped back to reveal new cable and reattached to the terminal posts, new battery put in. all terminals have been sandpapered and made all shiny again...

I'm at a loss at what to do

could it be that I need new cables altogether? or something more?

thanks.b.
Old 12-28-2011, 03:53 PM   #2
only change is constant
 
mattclifford's Avatar
 
Age: 29
Join Date: Jun 2009
Posts: 575
Location: Santa Monica, CA
User is: OffLine
Re: 02 s10 won't start

starter maybe? is it even trying to turn over?
Old 12-28-2011, 04:00 PM   #3
Registered User
 
Age: 33
Join Date: Dec 2011
Posts: 5
Location:
User is: OffLine
Re: 02 s10 won't start

no, it's not. it would sometimes not start and then id walk away or jostle the battery around, and it would start up again soon. now it just does nothing but turn on all the electronics. the cables are pretty stiff, and i noticed a cable relay under the batter tray that was all corroded so I cleaned it up, not sure what it's purpose is though...
Old 12-28-2011, 08:15 PM   #4
Registered User
 
chevyracing16's Avatar
 
Age: 26
Join Date: Nov 2011
Posts: 425
Location: CT
User is: OffLine
Re: 02 s10 won't start

Quote: Originally Posted by brandon_w_b
no, it's not. it would sometimes not start and then id walk away or jostle the battery around, and it would start up again soon. now it just does nothing but turn on all the electronics. the cables are pretty stiff, and i noticed a cable relay under the batter tray that was all corroded so I cleaned it up, not sure what it's purpose is though...
When I first got my 00 it would do the same thing. I was able to tap the starter solenoid and it would work. At first I didn't think it could be the starter because it would only do it intermittently. I got a used one from the junk yard and it has been 3 years(knock on wood)with no starting related issues.
Old 12-29-2011, 07:21 PM   #5
It's mostly BS
 
rimara's Avatar
 
Age: 56
Join Date: Oct 2004
Posts: 1,315
Location: San Jose CA
User is: OffLine
Re: 02 s10 won't start

The starter needs 2 things to work:

1. Good power and ground from the battery.
2. A 12v start signal to trigger the solenoid.

Sounds like you have checked the big cables from the battery to the starter and the engine. Now you need to see if the signal is getting to the small terminal on the starter. Get a volt meter or test light to see if you get the 12v when someone turns the key to start. If you are getting the 12v there, then it's probably the starter. If you are not getting 12v, then it might be any of these:

1. Bad fuse
2. Bad relay - might be able to swap with another one in the block
3. Bad ignition switch
4. Bad wiring between any of the parts.

Go to the electrical section and look for the sticky from deathphoenix99 with wiring diagrams.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:21 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.