Popping sound from my front end...HELP - S-10 Forum
 
LinkBack Thread Tools
post #1 of 13 Old 01-14-2009, 09:35 PM Thread Starter
BlazerBeater
 
wgraves's Avatar
 
Join Date: Feb 2007
Location: Johnstown,OH
Age: 28
Posts: 40

User is: wgraves is offline
Send a message via AIM to wgraves Send a message via MSN to wgraves Send a message via Yahoo to wgraves
Popping sound from my front end...HELP

Well This has been going on since I've owned the blazer. Sometimes when I back up, hit a divot in the road, turn the wheel,ect. theres a popping sound from the front end. I can hear it and feel it do this. My Blazer is a 1996 4dr 4x4. No lift or anything, just stock height. Replaced Ball joints last year and it didn't do anything. Can't seem to find out where it's coming from! Any help would be great. Thanks

wgraves is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 01-14-2009, 09:42 PM
Blue-X
 
yz85608's Avatar
 
Join Date: Sep 2007
Location: Akron
Age: 25
Posts: 828

User is: yz85608 is offline
Re: Popping sound from my front end...HELP

is it a loud pop, or subtle sp?
does it happen everytime you turn your wheel?

Shawn
Blue Xtreme
Xtremely Stock
yz85608 is offline  
post #3 of 13 Old 01-14-2009, 09:44 PM Thread Starter
BlazerBeater
 
wgraves's Avatar
 
Join Date: Feb 2007
Location: Johnstown,OH
Age: 28
Posts: 40

User is: wgraves is offline
Send a message via AIM to wgraves Send a message via MSN to wgraves Send a message via Yahoo to wgraves
Re: Popping sound from my front end...HELP

Quote:
Originally Posted by yz85608 View Post
is it a loud pop, or subtle sp
does it happen everytime you turn your wheel?
Its not very loud, just enough to hear it and it doesn't happen every time.

1996 S10 4x4 Blazer
4 Dr
Rebuild In Progress
wgraves is offline  
post #4 of 13 Old 01-14-2009, 09:56 PM
Registered User
 
Join Date: Jan 2008
Location: attleboro, ma
Age: 38
Posts: 1,083

User is: MARS2878 is offline
Re: Popping sound from my front end...HELP

check your cv axles & sway bar links
MARS2878 is offline  
post #5 of 13 Old 01-17-2009, 06:36 PM
Registered User
 
juggalotim's Avatar
 
Join Date: Aug 2003
Location: St.Louis
Age: 32
Posts: 205

User is: juggalotim is offline
Send a message via AIM to juggalotim Send a message via Yahoo to juggalotim
Re: Popping sound from my front end...HELP

might be one of your torsion bar mount bushings(if the 96s even came with them?) My 90 4x4 s10 i replaced the drivers side one like twice the 3 years i owned it and never really went off roading. Every time i would turn or hit a bump u would hear and feel a popping from underneath.

03 Blazer Xtreme DDM 8K HIDs, Vleds in the interior Bright inside and out!

91 S-10 4.3L 4x4 shaved doors, 2in body lift SOLD!
juggalotim is offline  
post #6 of 13 Old 01-17-2009, 08:00 PM
Registered User
 
Calvin51's Avatar
 
Join Date: Dec 2007
Location: Ohio
Age: 59
Posts: 284

User is: Calvin51 is offline
Re: Popping sound from my front end...HELP

Check your hood bolt where it goes through the hinge
Calvin51 is offline  
post #7 of 13 Old 01-17-2009, 09:27 PM
BUT I WONT PUT IT HERE
 
bmxbang's Avatar
 
Join Date: Jan 2004
Location: Bluesprings, MO
Age: 29
Posts: 8,150

User is: bmxbang is offline
Send a message via AIM to bmxbang
Re: Popping sound from my front end...HELP

mine does that 2 sometimes but i just figured it was one of my lower balljoints because its shot...

Matt
04 Lincoln LS V8
bmxbang is offline  
post #8 of 13 Old 01-24-2009, 11:32 PM
Registered User
 
Blazer_1997's Avatar
 
Join Date: Nov 2008
Age: 24
Posts: 86

User is: Blazer_1997 is offline
Re: Popping sound from my front end...HELP

I have a bushing out on my upper arm, causing it to do it.
Blazer_1997 is offline  
post #9 of 13 Old 01-25-2009, 02:18 AM
Registered User
 
AWD V8's Avatar
 
Join Date: Jan 2009
Location: Surrey, BC, Canada
Age: 63
Posts: 6,481

User is: AWD V8 is online now
Re: Popping sound from my front end...HELP

Also check that the adjusting nuts for the upper control arms are tight. Put a wrench on them to check, they need to be be real tight. If they are not tight it will clunk when you turn into a corner hard or when backing up and turning the wheel when you hit the brakes.
AWD V8 is online now  
post #10 of 13 Old 01-27-2009, 03:39 PM
Registered User
 
Calvin51's Avatar
 
Join Date: Dec 2007
Location: Ohio
Age: 59
Posts: 284

User is: Calvin51 is offline
Re: Popping sound from my front end...HELP

Also end link bushings or shock rubbers if not bagged.
Calvin51 is offline  
post #11 of 13 Old 03-01-2011, 07:07 PM
Registered User
 
Mic_'s Avatar
 
Join Date: Feb 2011
Posts: 14

User is: Mic_ is offline
Re: Popping sound from my front end...HELP

CV joints


.
Mic_ is offline  
post #12 of 13 Old 03-21-2011, 08:54 PM
Registered User
 
Join Date: Jul 2010
Age: 39
Posts: 4

User is: chilly_moose is offline
Re: Popping sound from my front end...HELP

I got the same thing going on in my '01 jimmy. It's the front carrier gears. you need to rebuild your front carrier.
chilly_moose is offline  
post #13 of 13 Old 03-21-2011, 08:57 PM
Check your ground
 
556mm's Avatar
 
Join Date: Oct 2005
Posts: 30,848

User is: 556mm is offline
Re: Popping sound from my front end...HELP

I would think he got it figured out over 2 years later.
556mm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome