Blend Door Actuator - S-10 Forum
 
LinkBack Thread Tools
post #1 of 11 Old 11-13-2009, 04:41 PM Thread Starter
Registered User
 
Join Date: Nov 2009
Posts: 5

User is: stickemdano is offline
Blend Door Actuator

1996 Blazer 4.3. 215,000 kms.
Replaced the DREADED blend door actuator. This job is not fun but also not impossible. Basically just had to keep pulling stuff off until I could get to it. It will take an afternoon and a bit more to complete. Had to walk away a few times and count to ten!!
I had the same 'no heat issue'. I started with repacing the thermostat. No change. Then replaced all the vacuum hoses. No change. I knew it was not the heater core, so I left that alone. Next I tried replacing the temperature control switch. No change. Then I went after the blend door actuator. A lot of people shy away from this but go ahead and do it if you have some basic knowledge and some basic tools.
I broke my hazard switch during the operation and replaced it no problem (easy fix). Now that everything is said and done, only problem I have is that the turn signals (and hazard) do not work. I checked the fuses and they are OK. Any ideas? Is there an electrical connection under the dash I may have forgot about?

stickemdano is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-13-2009, 05:03 PM
no longer has a 95
 
95 S_Trucker's Avatar
 
Join Date: Jan 2007
Location: Lancaster, PA
Age: 27
Posts: 1,883

User is: 95 S_Trucker is offline
Send a message via AIM to 95 S_Trucker
Re: Blend Door Actuator

double check and make sure the hazard switch is in the whole way. i bet you dont have any brakelights either

99 Blazer 2 Door, 4wd, NV3500, 8.5

99 K2500 LS CCSB 7.4, 4L80E
95 S_Trucker is offline  
post #3 of 11 Old 11-13-2009, 10:10 PM Thread Starter
Registered User
 
Join Date: Nov 2009
Posts: 5

User is: stickemdano is offline
Re: Blend Door Actuator

Thanks 95 S Trucker. I just tried pushing the hazard switch in further, but it is in all the way. Also you are right, I have no brake lights.
stickemdano is offline  
post #4 of 11 Old 11-18-2009, 07:57 PM
Move over here I come
 
89S10WBlazer's Avatar
 
Join Date: Nov 2009
Location: Hebron Indiana
Age: 27
Posts: 89

User is: 89S10WBlazer is offline
Re: Blend Door Actuator

hazard switch is malfunctioning. had the same problem on my buddy's 96. wiggle it around it should work. if not replace it again.

83 S-10 Blazer 2.8 5 Speed-SOLD
83 S-15 2.8 Standard Cab-Gypsy AT-SOLD
91 S-10 4.3 5 Speed Ext. Cab. 3/3 drop-SOLD
89 S-10 Blazer 5.7 3/3 Drop-DEAD for now
1999 Blazer 4x4 4.3 Kenwood Headunit Hifonics System
2009 Toyota Corolla S 5 Speed
89S10WBlazer is offline  
post #5 of 11 Old 12-01-2009, 11:19 PM Thread Starter
Registered User
 
Join Date: Nov 2009
Posts: 5

User is: stickemdano is offline
Re: Blend Door Actuator

Thanks guys. Replaced with another new hazard switch which now works fine. First one must have been defective. Apparently not the first one!!
stickemdano is offline  
post #6 of 11 Old 12-02-2009, 04:17 PM
1998 S10 Blazer
 
2001cvpi's Avatar
 
Join Date: Nov 2009
Location: New Jersey
Posts: 185

User is: 2001cvpi is offline
Re: Blend Door Actuator

You should not continue with the same thread NAME and diagnose with a different problem... Blend door? Hazard switch? Sorry, was looking for more on the blend door...
2001cvpi is offline  
post #7 of 11 Old 12-02-2009, 04:19 PM
1998 S10 Blazer
 
2001cvpi's Avatar
 
Join Date: Nov 2009
Location: New Jersey
Posts: 185

User is: 2001cvpi is offline
Re: Blend Door Actuator

Disregard previous thread from me... I see the reost. Thanks
2001cvpi is offline  
post #8 of 11 Old 12-04-2009, 08:25 PM
Slap my meat on your pita
 
GeorgesBlazah's Avatar
 
Join Date: Sep 2004
Location: south jersey
Age: 31
Posts: 8,082

User is: GeorgesBlazah is offline
Re: Blend Door Actuator

I had to do my blend door on mine...pain in the ass

George
98 Blazah 6in SL - 2in BL - 4.56s - Detroit ITS AN ANIMAL 4x4 BUMPER. IT IS NOT MADE ANYMORE, BUT YOU CAN BUY MINE FOR $6000

BLAZER PICS AND INFO CLICK ME
Founder/Godfather of the Anti-Bag Coalition
"Bags are for groceries"
GeorgesBlazah is offline  
post #9 of 11 Old 12-09-2009, 11:14 PM
Registered Minitrucker
 
LeRoy_921's Avatar
 
Join Date: Oct 2004
Location: Columbia, Mo
Age: 27
Posts: 394

User is: LeRoy_921 is offline
Re: Blend Door Actuator

****... i gotta replace mine too I think.
LeRoy_921 is offline  
post #10 of 11 Old 12-27-2009, 12:12 AM
Registered User
 
Gregs93S-10's Avatar
 
Join Date: Feb 2004
Location: Ocean Springs, MS.
Posts: 16

User is: Gregs93S-10 is offline
Send a message via Yahoo to Gregs93S-10
Re: Blend Door Actuator

I just relaced the TEMP DOOR ACTUATOR on my 02 Xtreme, but still no luck. My problem is that the temperature door is stuck on high heat.

When I took off the old actautor, I turned the "keyed" lever for the door and I turned it with no problems. The door itself did not seemed jammed....so I replaced the actuator motor itself BUT did NOT solve the problem...

What gives?

The control module is fine...I think. When I switched the temp from cold to hot and visa versa...I could feel the motor turning ever so slightly...a VERY small amount of turning, but, it is getting power....

I know I'm missing something....someone please shed some light on this...thx.

One BadAss '01 XTreme 4.3L; 5-speed !!
Gregs93S-10 is offline  
post #11 of 11 Old 12-29-2009, 05:29 PM
1998 S10 Blazer
 
2001cvpi's Avatar
 
Join Date: Nov 2009
Location: New Jersey
Posts: 185

User is: 2001cvpi is offline
Re: Blend Door Actuator

I'm second guessing the control module. Check vac lines?
2001cvpi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome