defrost and vents not working for a/c and heat... - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

defrost and vents not working for a/c and heat...

Go Back   S-10 Forum > Specific Model Forums > 1st Gen Forums > S10 / S15
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 09-16-2008, 09:29 AM   #1
Registered User
 
BIGT94z's Avatar
 
Join Date: May 2008
Posts: 61
Location:
User is: OffLine
defrost and vents not working for a/c and heat...

just blows out the bottom vents. anyone have any idea's?
Old 09-16-2008, 02:14 PM   #2
Registered User
 
slowteg97's Avatar
 
Age: 36
Join Date: Apr 2008
Posts: 183
Location:
User is: OffLine
Re: defrost and vents not working for a/c and heat...

yea check you vaccum supply lines that control the actuator sometimes they crack or even pop off there should be one just above the gas pedal to the right to give you an idea what your lookin for my truck has the same problem only blow through the floor vents barely through the dash and defrost vents. im just to lazy
Old 09-16-2008, 03:56 PM   #3
I Don't Fear DEATH
 
specter692000's Avatar

 
Age: 28
Join Date: Jun 2007
Posts: 17,750
Location: Richmond, IN
User is: OffLine
Re: defrost and vents not working for a/c and heat...

got the same problem now i know how to fix it thanks slow
Old 09-18-2008, 12:58 AM   #4
i saw what you did there!
 
fast68chevy's Avatar
 
Age: 36
Join Date: Sep 2002
Posts: 3,571
Location: Lincoln IL
User is: OffLine
Re: defrost and vents not working for a/c and heat...

make sure that the vacuum hose under the hood that runs to the passenger side to the heater system through the firewall is connected to the intake manifold vacuum still

this is main vacuum source to the heater control panel

and positions will not change without it

if its connected then the door in the heater box may be stuck

or the panel switch may be broken

or the actuator may be bad yes

most of the time its the vacuum hose thats not connected under the hood though


good luck
Old 09-24-2008, 07:25 PM   #5
Registered User
 
Age: 31
Join Date: Apr 2008
Posts: 1
Location:
User is: OffLine
Re: defrost and vents not working for a/c and heat...

might not be very common but on mine it was a suction block right behind the heater controls etc, think the part was $14, that was after i took the dash out checked every vaccuum line etc 3 times and it was the stupid little piece that coulda been fixed in 10 min lol. but isnt that the way it always goes
Old 09-24-2008, 09:42 PM   #6
Registered User
 
Age: 46
Join Date: Jul 2006
Posts: 5,065
Location: Where men act like men and don't cry
User is: OffLine
Re: defrost and vents not working for a/c and heat...

Usualy if you have a vacuum problem it will blow out the defrost only as a default. In the heat and a/c position though it never is supose to blow out the defrost vents. Heat will blow out the floor and a/c will blow out the front vents or floor and front in Bi-level.
So if you do not get ac/ out the defrost vents don't panic. You're not supose to
Old 09-25-2008, 04:01 PM   #7
I Don't Fear DEATH
 
specter692000's Avatar

 
Age: 28
Join Date: Jun 2007
Posts: 17,750
Location: Richmond, IN
User is: OffLine
Re: defrost and vents not working for a/c and heat...

any clue as to why i only get it through on the floor even in the defrost position i dont have a/c in my truck can factory with out it an and i took out the controll panel and ran the switches up and down and on the htr vent and defrst side there is hardly any resitance behind it like there is when i go from cold to heat can anybody help me out with it
Old 09-25-2008, 06:24 PM   #8
Registered User
 
slowteg97's Avatar
 
Age: 36
Join Date: Apr 2008
Posts: 183
Location:
User is: OffLine
Re: defrost and vents not working for a/c and heat...

yo i know exactly what ur sayin i have the same problem, im wondering if we should change that part that injunjoes suggested. i mean for 14 bux it cant hurt ya know????
Old 09-25-2008, 08:59 PM   #9
Registered User
 
Age: 46
Join Date: Jul 2006
Posts: 5,065
Location: Where men act like men and don't cry
User is: OffLine
Re: defrost and vents not working for a/c and heat...

If Injunjoes Is talking about what I think he is that could very well be why its stuck at the floor.
Pull out the unit so you can see the back side. Right where all the vacuum lines are there is a part that slides as you move the selector. It will rotate the vacuum selector. Some times the small pin will break and as you move the lever you will see that the selector does not rotate for the vacuum switch.
Old 09-25-2008, 09:12 PM   #10
Registered User
 
Age: 46
Join Date: Jul 2006
Posts: 5,065
Location: Where men act like men and don't cry
User is: OffLine
Re: defrost and vents not working for a/c and heat...

Maybe this will help some. Can't seem to find the rest. Garage is a mess!
Attached Thumbnails
defrost and vents not working for a/c and heat...-09-25-08_1755.jpg  
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:00 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.