91 S10 Fuel not spraying - S-10 Forum
 
LinkBack Thread Tools
post #1 of 9 Old 12-01-2011, 02:53 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Age: 23
Posts: 4

User is: durr711 is offline
91 S10 Fuel not spraying

Hi I have a 91 S10 2.5 tbi and the injector is not getting a ground pulse. It has new ECU and ignition control module. You can manully ground it and pulse it yourself and it will run! Any ideas I am stumped? Also there is a gray wire all by itself I cant find where it goes that might be the problem. Here is a pic of the wire.

Attached Thumbnails
Click image for larger version

Name:	IMG_20111201_144841.jpg
Views:	53
Size:	39.6 KB
ID:	121347   Click image for larger version

Name:	IMG_20111201_144831.jpg
Views:	56
Size:	51.9 KB
ID:	121348  
durr711 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-02-2011, 12:45 AM
Registered User
 
2003Xtreme's Avatar
 
Join Date: May 2008
Location: Vandalia, IL
Age: 26
Posts: 1,760

User is: 2003Xtreme is offline
Re: 91 S10 Fuel not spraying

I think the wire in your picture is a test point.. Like for a test light.. ground it and touch it there to make sure your light is grounded good. Not 100 positive, but I think I am close.. lol


99 Hugger Orange Z28
93 Suburban Lowered
91 S10 shortbed Lowered


Project Build Thread Links
http://www.s10forum.com/forum/f135/s...y-pics-483887/
http://www.s10forum.com/forum/f135/f...yard-d-483861/
http://www.s10forum.com/forum/f3/198...t-work-489962/

Quote:
Originally Posted by J_SIN View Post
I'd rather pump up my bags with a bicycle pump than use their products.
2003Xtreme is offline  
post #3 of 9 Old 12-02-2011, 11:30 AM Thread Starter
Registered User
 
Join Date: Dec 2011
Age: 23
Posts: 4

User is: durr711 is offline
Re: 91 S10 Fuel not spraying

Ok do you have any idea why it wont start?
durr711 is offline  
post #4 of 9 Old 12-02-2011, 01:39 PM
ASE certified MasterTech
 
jtcfanof3's Avatar
 
Join Date: Aug 2005
Location: A little here and a little there....
Age: 40
Posts: 8,694

User is: jtcfanof3 is offline
Send a message via AIM to jtcfanof3
Re: 91 S10 Fuel not spraying

That's the fuel pump test lead. Have you verified the circuit is good from the pick up coil to the ECM? And ECM to injector circuit?


1989 Chevrolet Blazer 3.4
1989 Chevrolet Blazer 4.3 4x4
1989 Chevrolet Blazer 4.3 Edelbrock equipped
2003 Chevrolet S10 4.3
1999 Chevrolet S10 Xtreme 2.2
jtcfanof3 is offline  
post #5 of 9 Old 12-02-2011, 02:49 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Age: 23
Posts: 4

User is: durr711 is offline
Re: 91 S10 Fuel not spraying

The wire from the ecm to the injector is good. Which wire off the pick up coil is the one for the injector?
durr711 is offline  
post #6 of 9 Old 12-03-2011, 09:01 AM
1st gen v8
 
00LS1TransAm's Avatar
 
Join Date: Dec 2009
Location: Sutton, MA
Age: 26
Posts: 25

User is: 00LS1TransAm is offline
Re: 91 S10 Fuel not spraying

Check the fuse for the ECM

02 ram 2500 -diesel 6 speed lifted on 35's
94 s10 -excabsb 4.3 5 speed c5 Z06's
00LS1TransAm is offline  
post #7 of 9 Old 12-03-2011, 05:40 PM
Solid Axle MOD
 
Sonomanclature's Avatar
 
Join Date: Jan 2007
Location: Elizabeth Colorado
Age: 28
Posts: 11,438

User is: Sonomanclature is offline
Send a message via MSN to Sonomanclature
Re: 91 S10 Fuel not spraying

As stated that wire is the test lead fo the pump, the wire from the pickup coil is purple/white for high, and black/red for low. it is almost impossible to test iwth a multimeter. You can take the ICM which the pickup is located in, and have an auto parts store test it.


94 Sonoma Dana44/60 5.7L 5spd


06 Subaru Impreza
Sonomanclature is offline  
post #8 of 9 Old 12-03-2011, 06:57 PM
ASE certified MasterTech
 
jtcfanof3's Avatar
 
Join Date: Aug 2005
Location: A little here and a little there....
Age: 40
Posts: 8,694

User is: jtcfanof3 is offline
Send a message via AIM to jtcfanof3
Re: 91 S10 Fuel not spraying

You can test the circuit, continuity. Verify the circuit is good. And yes, have the ICM tested at a parts house. Did you verify the fuses were good yet?
If it is working you can also run a voltage drop test on the circuits with a meter...


1989 Chevrolet Blazer 3.4
1989 Chevrolet Blazer 4.3 4x4
1989 Chevrolet Blazer 4.3 Edelbrock equipped
2003 Chevrolet S10 4.3
1999 Chevrolet S10 Xtreme 2.2
jtcfanof3 is offline  
post #9 of 9 Old 12-03-2011, 08:02 PM Thread Starter
Registered User
 
Join Date: Dec 2011
Age: 23
Posts: 4

User is: durr711 is offline
Re: 91 S10 Fuel not spraying

I sold the truck just going to get another one didnt have any more money to put in it!
durr711 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome