91 S10 Fuel not spraying - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

91 S10 Fuel not spraying

Go Back   S-10 Forum > Specific Model Forums > 1st Gen Forums > S10 / S15
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 12-01-2011, 02:53 PM   #1
Registered User
 
Age: 22
Join Date: Dec 2011
Posts: 4
Location:
User is: OffLine
91 S10 Fuel not spraying

Hi I have a 91 S10 2.5 tbi and the injector is not getting a ground pulse. It has new ECU and ignition control module. You can manully ground it and pulse it yourself and it will run! Any ideas I am stumped? Also there is a gray wire all by itself I cant find where it goes that might be the problem. Here is a pic of the wire.
Attached Thumbnails
91 S10 Fuel not spraying-img_20111201_144841.jpg   91 S10 Fuel not spraying-img_20111201_144831.jpg  
Old 12-02-2011, 12:45 AM   #2
Registered User
 
2003Xtreme's Avatar
 
Age: 24
Join Date: May 2008
Posts: 1,760
Location: Vandalia, IL
User is: OffLine
Re: 91 S10 Fuel not spraying

I think the wire in your picture is a test point.. Like for a test light.. ground it and touch it there to make sure your light is grounded good. Not 100 positive, but I think I am close.. lol
Old 12-02-2011, 11:30 AM   #3
Registered User
 
Age: 22
Join Date: Dec 2011
Posts: 4
Location:
User is: OffLine
Re: 91 S10 Fuel not spraying

Ok do you have any idea why it wont start?
Old 12-02-2011, 01:39 PM   #4
ASE certified MasterTech
 
jtcfanof3's Avatar
 
Age: 38
Join Date: Aug 2005
Posts: 8,691
Location: A little here and a little there....
User is: OffLine
Re: 91 S10 Fuel not spraying

That's the fuel pump test lead. Have you verified the circuit is good from the pick up coil to the ECM? And ECM to injector circuit?
Old 12-02-2011, 02:49 PM   #5
Registered User
 
Age: 22
Join Date: Dec 2011
Posts: 4
Location:
User is: OffLine
Re: 91 S10 Fuel not spraying

The wire from the ecm to the injector is good. Which wire off the pick up coil is the one for the injector?
Old 12-03-2011, 09:01 AM   #6
1st gen v8
 
00LS1TransAm's Avatar
 
Age: 24
Join Date: Dec 2009
Posts: 25
Location: Sutton, MA
User is: OffLine
Re: 91 S10 Fuel not spraying

Check the fuse for the ECM
Old 12-03-2011, 05:40 PM   #7
Solid Axle MOD
 
Sonomanclature's Avatar

 
Age: 26
Join Date: Jan 2007
Posts: 10,210
Location: Elizabeth Colorado
User is: Online
Re: 91 S10 Fuel not spraying

As stated that wire is the test lead fo the pump, the wire from the pickup coil is purple/white for high, and black/red for low. it is almost impossible to test iwth a multimeter. You can take the ICM which the pickup is located in, and have an auto parts store test it.
Old 12-03-2011, 06:57 PM   #8
ASE certified MasterTech
 
jtcfanof3's Avatar
 
Age: 38
Join Date: Aug 2005
Posts: 8,691
Location: A little here and a little there....
User is: OffLine
Re: 91 S10 Fuel not spraying

You can test the circuit, continuity. Verify the circuit is good. And yes, have the ICM tested at a parts house. Did you verify the fuses were good yet?
If it is working you can also run a voltage drop test on the circuits with a meter...
Old 12-03-2011, 08:02 PM   #9
Registered User
 
Age: 22
Join Date: Dec 2011
Posts: 4
Location:
User is: OffLine
Re: 91 S10 Fuel not spraying

I sold the truck just going to get another one didnt have any more money to put in it!
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:04 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.