2.8 v6 throttle body problems - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

2.8 v6 throttle body problems

Go Back   S-10 Forum > Specific Model Forums > 1st Gen Forums > S10 / S15
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 05-01-2010, 09:32 PM   #1
HOOK'D 4 LYFE
 
Age: 24
Join Date: May 2010
Posts: 4
Location: effigham, co
User is: OffLine
2.8 v6 throttle body problems

i need a fuel pressure regulator or a whole new throttle body pretty cheap if possible
Old 05-02-2010, 10:27 PM   #2
ASE certified MasterTech
 
jtcfanof3's Avatar
 
Age: 38
Join Date: Aug 2005
Posts: 8,691
Location: A little here and a little there....
User is: OffLine
Re: 2.8 v6 throttle body problems

and then............


You need a rephrase guy!
Old 05-03-2010, 10:54 PM   #3
HOOK'D 4 LYFE
 
Age: 24
Join Date: May 2010
Posts: 4
Location: effigham, co
User is: OffLine
Re: 2.8 v6 throttle body problems

well never mind about the problems ive got a 4.3 throttle body ima put on it where do i start like accelerator cable wise and other stuff
Old 05-04-2010, 01:45 AM   #4
i saw what you did there!
 
fast68chevy's Avatar
 
Age: 36
Join Date: Sep 2002
Posts: 3,571
Location: Lincoln IL
User is: OffLine
Re: 2.8 v6 throttle body problems

use 4.3L parts


cable you can buy new at auto zone etc or junkyard from a 4.3L truck with same injection as yours, either vin Z TBI,

or vin W CFI/SFI

you will need vin Z cable anyways

dirt common in the '88-92 years
'

the regulator you can modify

you remove the hat of it off the tb unit and drill out the brass in the end of it just until the screw in the middle of the regulator will screw thead, and you turn it so the roof of the regulator raises higher some

this increases volume of fuel

mine idles a little faster and stronger than other vin Z 4.3L engines out there after doing this mod

also after disconnecting tthe EGR valve in which was malfunctioning and sticking open and killing the engine in gear at stops when warm, after having been on the freeway cruising
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:10 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.