Air bubbles in trans fluid?? - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Air bubbles in trans fluid??

Go Back   S-10 Forum > Engine and Drivetrain Tech > Transmission & Rearend
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 05-21-2002, 05:56 PM   #1
Registered User
 
Join Date: Jul 2001
Posts: 508
Location: Las Vegas
User is: OffLine
Air bubbles in trans fluid??

When I check the fluid the end of the dip stick had bubbles on it, almost like foam. Trans works fine except the converter constantly cycles in third. Fluid isnt burned and Ive always used synthetic and no leaks. Im wondering if its a cracled valve body. Been hearing about alot of those in the 4L60E's. I dont trust any shops here especially the idiots at the dealership.
Old 05-22-2002, 02:05 AM   #2
ZQ8 2001
 
DoubleDown's Avatar
 
Age: 32
Join Date: Aug 2001
Posts: 924
Location: Vegas
User is: OffLine
i recommend Dudley's transmission on Highland. guy named Todd runs the place, does great work IMO.
Old 05-24-2002, 09:03 PM   #3
SS Member
 
Age: 38
Join Date: Jul 2001
Posts: 21
Location: Las Vegas
User is: OffLine
I 2nd that they built my trans for my race car!!!!
Old 05-24-2002, 11:58 PM   #4
Registered User
 
Join Date: Jul 2001
Posts: 508
Location: Las Vegas
User is: OffLine
I made the mistake of letting Pep Boys change my filter the last time. They ended up stripping my manifold and donut bolts. I bet the idiot didnt get the filter in right and thats where its pulling in air. Thanks
Old 05-26-2002, 04:46 AM   #5
Registered User
 
Join Date: Sep 2001
Posts: 756
Location: germany
User is: OffLine
Filter

Make sure that the old rubber gasket comes out with the filter!If you mount the new filter with the old gasket still stuck in the hole,the new filter will suck air!Look into it soon,this can cause you serious problems.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:59 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.