S-10 Forum

S-10 Forum (http://www.s10forum.com/forum/index.php)
-   262ci Forum (4.3) (http://www.s10forum.com/forum/262ci-forum-4-3/)
-   -   Something is running and draining my battery. (http://www.s10forum.com/forum/f107/something-is-running-and-draining-my-battery-505288/)

greree 10-14-2012 09:02 PM

Something is running and draining my battery.
 
What is this? (Arrow) And why does it keep running when the truck is off? It's draining my battery. 1995 Chevy S10 4.3 2WD TBI

http://s9.postimage.org/61en6tjwf/55970384.jpg

Buddies'Garage 10-14-2012 09:32 PM

Re: Something is running and draining my battery.
 
That is your ABS system. I'm not sure why it would be draining the battery. If you know it to be the cause then just replace it. They're fairly cheap from boneyards. *They're difficult to bleed & you may need professional help. Also, I'm sure you can search & quickly find a thread detailing how to delete it all together.

greree 10-14-2012 09:45 PM

Re: Something is running and draining my battery.
 
It's draining the battery because it keeps running when the truck is shut off. It sounds like a little electric motor is running. Thursday morning when I went to my truck I heard it, but didn't have time to look at it. When I got to work and shut the truck off it kept running. When I got off work the battery was dead. I got a jump, and drove it home, and when I shut the truck off there it still kept running. I disconnected the battery, then reconnected it, and it stopped. But today it started again. When I got home and shut the truck off it didn't do anything, but when I came outside a few hours later it was making the noise again, and disconnecting and reconnecting the battery didn't stop it.

riveradel 10-14-2012 09:58 PM

Re: Something is running and draining my battery.
 
The red wire is hot all the time.remove the plug or cut the red wire until you get it fix.

S15vortecpwr 10-14-2012 11:15 PM

Re: Something is running and draining my battery.
 
look for a ABS relay. if it is sticking than that can keep the pump running all the time.

IMO dont cut any wires. just disconnect the unit or pull the fuse. cutting wires is asking for more trouble/work down the road.

riveradel 10-14-2012 11:20 PM

Re: Something is running and draining my battery.
 
The relay is built into the unit,and if he pulls the fuse,no break lights.

riveradel 10-14-2012 11:25 PM

Re: Something is running and draining my battery.
 
The red wire is for the abs module only,so is the motor is running all the time,they are not working properly.

greree 10-14-2012 11:33 PM

Re: Something is running and draining my battery.
 
I pulled the power plug for the unit. The motor stopped, and I still have brake lights. How will that affect my braking?

riveradel 10-14-2012 11:34 PM

Re: Something is running and draining my battery.
 
None.

badbowtie1987 10-15-2012 07:06 AM

Re: Something is running and draining my battery.
 
if you disabled the abs unit then you wont have abs if your tires lock up while braking. other than that it will brake just fine.

SixPack 10-15-2012 10:01 AM

Re: Something is running and draining my battery.
 
The EBC4 (4WAL) 3 sensor and 4 sensor ABS relay is shorted and the ABS pump motor is running uncontrollably and will eventually fail if the car battery holds out long enough. The ABS relay is inside the ABS modulator (ECHU) and it is not serviceable (thanks GM). The ABS modulator must be replaced if you still want ABS assisted braking. Rebuilt ABS modulators are no longer available because there are no good cores to rebuild. That is because when a ABS modulator fails, they are removed and thrown in the trash. The last time I checked, a rebuilt 3 sensor ABS unit is available form GM for about $1200 msrp. The 1990-1992 S10 ABS is a 4 sensor (channel) system and the 1993-1994 is a 4-sensor (channel) unit. The 3 and 4 sensor ABS modulators are identical in appearance. The 3-sensor ABS has a rear brake sensor on the drive shaft and the 4 sensor ABS has a brake sensor on each wheel.

Cardone will rebuild your old ABS modulator for $800. I purchased a 4-sensor ABS modulator from NAPA for $800 exchange. I found one 4-sensor ABS modulator in the NAPA Cape Giradeau Missouri parts warehouse and it was the last one available in their entire parts distribution network. I did not install it because I finally bled my old ABS modulator and got my ABS working again. I returned the rebuilt ABS modulator to a NAPA store for a $800 refund.

The ABS assist on my 1991 S10 Blazer 4x4 has not been used in about 10 years because has not been driven on gravel roads or on wet or icy pavement. You are supposed to hear the ABS self-test after the vehicle is started and moves forward about 20 feet. I don't hear mine self-test so I doubt if it still works.

Disconnecting the 12V power supply is the poor man's fix to the problem.


All times are GMT -4. The time now is 03:45 AM.

vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO
Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0