Idles fine give it gas starts to cut out hesitates - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Idles fine give it gas starts to cut out hesitates

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 08-04-2006, 05:20 PM   #1
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Idles fine give it gas starts to cut out hesitates

1992 s10 blazer s10 4.3 188,700 mi. Truck died going down highway. It started to run rough for about 10 miles pulled over ran very rough no power. Had it towed to work next morning would not start.

I put a new fuel pump, gas tank and fuel filter in last month due to rust. So today I installed a new CPI/nut kit from Napa also new cap and rotor plug wires while I was in there. Truck would not start. 3 or the six spark plugs were soaked in gas. Replaced all 6 plugs and truck fired right up. It drove fine for 2 miles and then started to sputter/hesitate and I can't get it going above say 20-27mph. Fuel pressure reads 52 running and when I snap the throttle it goes to 60-62psi. after sitting for 15 mins it reads 20psi. It idles fine, when I give it gas and hold it, it starts to cut out hesitates.

I checked the fuel pump ground it was good. A while back I bought a set of used sensors off ebay so I swapped them on. They included TPS, ignition module, MAP sensor, Air diverter valve, and idle air control. It runs the absolute same. No change, No codes.

My thoughts: Plugged cat converter, bad crank position sensor, bad pickup coil in distributor.

Any thoughts/help/past experiences would be greatly appreciated.

-Thanks
Old 08-04-2006, 05:46 PM   #2
Driver of the Short Bus!
 
scott011422's Avatar
 
Join Date: Sep 2003
Posts: 507
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

You don't have a CPS....So its not that...........I'm thinking its your fuel pressure. I know my 92' 4.3l sonoma never ran anywhere near that hi. In fact, I just looked up the fuel pressure test for your vehicle in a Vantage, and at Idle you should have 9 to 13 psi. So I'm thinking that could be your problem!

Last edited by scott011422; 08-04-2006 at 05:59 PM.
Old 08-04-2006, 06:35 PM   #3
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Not sure what a CPS is but this truck has CPI injection. I talked to a local shop and they said the pressure should be 55 psi at idle and when you snap the throttle it should go to 62psi.

Last edited by biggyzzz; 08-04-2006 at 06:36 PM.
Old 08-04-2006, 07:06 PM   #4
Driver of the Short Bus!
 
scott011422's Avatar
 
Join Date: Sep 2003
Posts: 507
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Alrighty, Here is what My roommate said to try...........He's betting most of his money on the cat. Expecailly if the intake has an odd noise when you try to floor it. kinda described it like a roaring. Easy to test though, jsut unbolt the cat , if it runs drasticly better, there's your problem.

Also, 20 psi after 15 min either running or not is BAD. Chances are that your "Spider assembly" is going out, prolly have a leaky popet valve. Its located under your intake. Basicly you have one larger injector module called the spider that does all your injectors...
Old 08-04-2006, 08:42 PM   #5
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

I drilled a 1/2 inch hole in the exhaust before the cat made no difference in the way it runs. I replaced the whole CPI injector today. I wonder if it was a bad part out of the box. I got it from napa it was $250. Is there a way to test the new CPI to see if it is bad? Should the pressure be staying at 50 psi after the truck has been sitting not running and for how long? Thanks for the help.
Old 08-04-2006, 08:44 PM   #6
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

One more question with the new spider injector CPI does it matter which poppet goes in which hole in the intake? I remember reading that it did not matter.
Old 08-04-2006, 11:40 PM   #7
Driver of the Short Bus!
 
scott011422's Avatar
 
Join Date: Sep 2003
Posts: 507
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

I understand that removing a rusted cat is a pain in the azz, but a .5 hole isn't going to do much if the cat is blocked.

With the fuel pressure, spec is with the pump off, that the fuel system should hold that pressure for 48 hours. So in reality I would think maby 4 hours with no noticable decrease?

On the popits: I dunno. I'm thinking not being that the Spider fires all the popits at once. But I'll talk to my roommate in the morning and see what he says. I'll probably hop on after lunch, Central time.

untill then, If you have any more questions, fire them off and I'll ask him. FYI, hes not some bum, but an ASE certified master tech, so he knows his sh*t
Old 08-05-2006, 08:26 AM   #8
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

I think I'm going to cut the exhaust with a sawzall when I get back to work. What does he think the fuel problem could be leaking pressure like that? The new CPI is defective or a bad fuel pump? They are both new napa parts. Checked again 52 psi idling 60-62 when throttle snapped and 20psi after sitting for 20 mins not running. Thanks again.

-Joe
Old 08-05-2006, 11:47 AM   #9
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Update: Installed another new CPI from napa still the same thing. Took a sawzall and cut the y-pipe to cat so the cat is out of the picture. Same thing. Just spitts and sputters when I give it gas idles ok.
Old 08-05-2006, 02:39 PM   #10
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Just to clarify the last post it spits and sputters and cuts out when I give it even a little gas, top speed about 20 mph. The truck will idle ok.
Old 08-05-2006, 02:59 PM   #11
Registered User
 
Age: 27
Join Date: Aug 2006
Posts: 6
Location: Clarksville OH
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

I had a 1994 4.3 and it was doing the same thing and finally one day it wouldnt start at all and it was the coil.
Old 08-05-2006, 09:38 PM   #12
Registered User
 
Join Date: Mar 2006
Posts: 12
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

did you check the timing? I went thru this recently, but not as bad. Anyway, the dist. drive gear was badly worn, and as near as I could tell, the base timing was off as well. Found this after replacing the same parts you did, plus others.

I'm so happy to finally figure it out that every problem looks like the distributor now, but hey, it's worth checking out.

Last edited by rawdog; 08-05-2006 at 09:40 PM.
Old 08-05-2006, 09:51 PM   #13
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Didn't think of that. I have a 2000 blazer that I did the lower intake gasket on and the distributor was not adjustable, I thought this set up was the same. I have a timing light so I'll check that out too.
Old 08-06-2006, 04:52 PM   #14
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Update: I couldn't find my timing light so I'll have to get another. I took the new battery out of my wifes truck and bought a new coil for $15 . That didn't help. I dropped the gas tank and got the fuel pump warrantied. Pressure is now holding at 55psi after shutting off key for several hours. But, it is doing the same thing. Idles fine give it gas and it just starts to sputter. Is this the correct order for the plug wires 92 4.3 CPI:

_4
5 3
6 2 distributor
_1

Engine

6 5
4 3
2 1

Fan
Front of vehicle

Anyone got any ideas?

Last edited by biggyzzz; 08-06-2006 at 04:56 PM.
Old 08-06-2006, 06:30 PM   #15
Registered User
 
Age: 29
Join Date: Jan 2003
Posts: 296
Location: oklahoma
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

what about the egr valve?? when mine went bad i know it ran like crapp when i gave it gas??? just a thought
Old 08-06-2006, 06:44 PM   #16
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

I took the EGR out the other day and cleaned it everything looked ok no chunks of carbon or anything. When yours ran bad from the EGR problem did it severly cut out and barely go 20mph, basically not drivable. Or did it just run bad and it was still drivable?
Old 08-07-2006, 04:10 PM   #17
Registered User
 
Age: 44
Join Date: Apr 2004
Posts: 42
Location:
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Update: FIXED!!! It was the pickup coil in the distributor.
Old 08-08-2006, 04:30 AM   #18
An ol Scott
 
SilverWings's Avatar
 
Age: 70
Join Date: Jun 2004
Posts: 833
Location: Missoula Montana
User is: OffLine
Re: Idles fine give it gas starts to cut out hesitates

Quote: Originally Posted by biggyzzz
Update: FIXED!!! It was the pickup coil in the distributor.
My, my, my. Funny how many times it turns out to be a problem in the distributor. I've just fixed a problem of poor running due mainly to a fault in the distributor my self.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:44 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.