HOLY CRAP!!!!!! My ignition coil is glowing blue!!! - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 02-18-2004, 10:16 PM   #1
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

95 S-10 Blazer CPI Vin W. You can look at my last post. I have a random misfire code. I just turned out all the lights in the garage with the engine running and look at the engine to see if I could see a spark plug wire arc'g. Much to my amazement, the sides of the ignition coil(between the coil and it's frame are glowing blue. A friend said I'm loosing discharge and replacing the coil will fix my problem. Will it? This isn't just some normal thing right?
Old 02-18-2004, 10:38 PM   #2
Registered User
 
Join Date: Oct 2003
Posts: 619
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

not normal, but alot cooler than neons......



not that neons are cool
Old 02-18-2004, 10:57 PM   #3
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by meeh350
not normal, but alot cooler than neons......



not that neons are cool
Yeah now I'm Fast and Furious. Woooooo Hoooooooooo!!!!!!!!!!!!!
Old 02-18-2004, 11:18 PM   #4
Stepsider
 
Slacker's Avatar
 
Age: 29
Join Date: Nov 2003
Posts: 2,002
Location: Windsor, Ontario
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by cw's95Nightmare
Yeah now I'm Fast and Furious. Woooooo Hoooooooooo!!!!!!!!!!!!!
Hey, cut me a break. Not like I have a big aluminum wing.
Old 02-18-2004, 11:53 PM   #5
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by Slacker
Hey, cut me a break. Not like I have a big aluminum wing.
Just joking.
Old 02-19-2004, 12:08 AM   #6
Registered User
 
Join Date: Oct 2003
Posts: 619
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Whats wrong with a wing, I have one on my push mower.. adds down force in the corners... trust me, it can get away from you in the corners


i suppose neons have thier purpose.. i just love seeing them hang down with the wires dragging on the road like they ran over them and they got stuck under the truck/car or a totally stock cavy with a painted dash dragging its exhaust tip down the road and so many neons in it, it looks like someone is welding in it.

Hey CW.... maybe you can market this new creation of yours.... people can mount coils all over thier cars and shoot arcs every where.... im sure someone will buy it..... especially if its sold on ebay Start gathering junk coils up

Last edited by meeh350; 02-19-2004 at 12:14 AM.
Old 02-19-2004, 12:19 AM   #7
Stepsider
 
Slacker's Avatar
 
Age: 29
Join Date: Nov 2003
Posts: 2,002
Location: Windsor, Ontario
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by meeh350
i suppose neons have thier purpose.. i just love seeing them hang down with the wires dragging on the road like they ran over them and they got stuck under the truck/car
My girl's step-bro strapped his rear neon to the back axle on his non-turbo talon. I damn near died laughing when I saw it. It's a wonder it's still working.
Old 02-19-2004, 12:21 AM   #8
Registered User
 
Join Date: Oct 2003
Posts: 619
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

see, im not about to go out and buy a new cell phone.....but when i see stuff like that going down the road... i wish i had a camera phone
Old 02-19-2004, 12:58 AM   #9
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

I'm going to consult my research and development people on this right away. Don't worry, I'll have them in stores in time for Christmas. Also, I think I need to get on the phone with the good people down at The Fast and Furious set. They'll need to get these glow in the dark coils on before they shoot another scene.

This is all just too cutting-edge for me.
Old 02-19-2004, 06:37 AM   #10
Insane Network Engineer
 
rlith's Avatar
 
Join Date: Dec 2002
Posts: 5,965
Location: Pittsburgh, PA.
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by cw's95Nightmare
95 S-10 Blazer CPI Vin W. You can look at my last post. I have a random misfire code. I just turned out all the lights in the garage with the engine running and look at the engine to see if I could see a spark plug wire arc'g. Much to my amazement, the sides of the ignition coil(between the coil and it's frame are glowing blue. A friend said I'm loosing discharge and replacing the coil will fix my problem. Will it? This isn't just some normal thing right?
Back on topic.. You need a new coil... You shouldn't see any spark accross the coil...this is probably causing most of your problems
Old 02-19-2004, 06:46 AM   #11
Registered User
 
Join Date: Oct 2003
Posts: 619
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

CW, dont do it man......... keep the cool glow in the dark coil..... most fast and furious guys vehicles dont run good..... they just look "cool"
Old 02-19-2004, 07:51 AM   #12
Clean N' Dark
 
BlazerLT's Avatar
 
Age: 38
Join Date: Sep 2003
Posts: 1,921
Location: Sudbury, Ontario, Canada
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

you are lucky you haven't started a fire.
Old 02-19-2004, 10:02 AM   #13
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by BlazerLT
you are lucky you haven't started a fire.
That's what I've been thinking about this morning. Not to mention all the times I felt around in the engine bay when it was running. I could have been electricuted...I think. Anyway, any suggestions on what coil I should buy? I don't care what it's going to cost but I do want to be able to pick it up somewhere today and would like something better than stock. After a week of driving this thing to work everyday(many many miles) instead of a lowered Mustang, I really miss my blazer.
Old 02-19-2004, 10:22 PM   #14
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

OK. Got the new coil installed. Same things is going on. It is glowing from underneath and you can see 2 short sparks going from the coil module to the coil. Guess what!!! I also have blue flames EVERYWHERE! On top of the distributor and between some of the plug wires. Random ignition misfire huh, they were'nt kidding. Does anyone have a clue what's going on here? Please help.
Old 02-19-2004, 10:39 PM   #15
Insane Network Engineer
 
rlith's Avatar
 
Join Date: Dec 2002
Posts: 5,965
Location: Pittsburgh, PA.
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

bad wires... Replace em...
Old 02-19-2004, 10:45 PM   #16
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

They're new. I will replace them anyway I guess. How does that explain the coil and the top of the distributor glowing though?
Old 02-19-2004, 11:05 PM   #17
Registered User
 
jerseybud's Avatar
 
Age: 39
Join Date: May 2003
Posts: 163
Location: New England
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

The blue glow is called a corona. Its caused by the loss of electrons thru the insulation. If I recall, it can be caused by carbon tracking in the cap. If you take the cap off and rotor and examine them closely you may see black tracks in them. You might have a cracked cap too.
I would suggest installing a new cap and rotor, and testing the wires for resistance, and installing everything with silicone dielectric grease around the nipples for the cap, and the spark plugs, and the one wire leading into the coil. I personally would change spark plugs too. AC Delco, cheap and OEM.
Old 02-19-2004, 11:09 PM   #18
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by jerseybud
The blue glow is called a corona. Its caused by the loss of electrons thru the insulation. If I recall, it can be caused by carbon tracking in the cap. If you take the cap off and rotor and examine them closely you may see black tracks in them. You might have a cracked cap too.
I would suggest installing a new cap and rotor, and testing the wires for resistance, and installing everything with silicone dielectric grease around the nipples for the cap, and the spark plugs, and the one wire leading into the coil. I personally would change spark plugs too. AC Delco, cheap and OEM.
The cap and rotor are new also but it sounds like you know what you're talking about. I'll replace them. I looked for dielectric grease at the parts store earlier and couldn't fine it. It goes inside the boots of the wires right?
Old 02-19-2004, 11:20 PM   #19
Registered User
 
jerseybud's Avatar
 
Age: 39
Join Date: May 2003
Posts: 163
Location: New England
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Dielectric grease and wire separators are a must on any vehicle. I usually put a little grease on a small screwdriver and swirl it around the boots of the wires, both ends, plugs and distributor side.
You can make cheap wire spearators out of big zip ties.
1. wrap one around the wires you want to spearate
2. Put one between each wire, and around the one you just put on in step 1.
Tighten all and cut the ends off.

Are all your ground cables installed still? You could put a set of jumper cables connected to the exhaust manifold or any non-moving metal, non aluminum metal part and the other side to the dirt or a steel post driven in the ground and see if the glow goes away.
Old 02-19-2004, 11:27 PM   #20
Registered User
 
TwyztydMynd's Avatar
 
Join Date: Jul 2003
Posts: 102
Location: Crystal Beach Texas
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

coill wire ,,,imo ......
seen that one wire cause many different problems and sometimes goes bad before any others do
Old 02-19-2004, 11:28 PM   #21
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

I WILL try all of that tomorrow. Thank you so much. I just took the truck around the block. The new coil was not a total loss, it starts right up now and throttle response is incredible. I will do everything you've mentioned here though because I want this truck to run right for a long time. I have no dielectric grease on anything. I'm also using Bosch platinum plugs which I read earlier is not a good idea. I'll fix that tomorrow too. Thanks again, I'll PM you with the results.
Old 02-19-2004, 11:29 PM   #22
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by TwyztydMynd
coill wire ,,,imo ......
seen that one wire cause many different problems and sometimes goes bad before any others do
Well, it won't hurt to replace that while I'm at it. Thanks.
Old 02-20-2004, 12:03 AM   #23
Registered User
 
Join Date: Oct 2003
Posts: 619
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Quote: Originally Posted by cw's95Nightmare
I'm also using Bosch platinum plugs which I read earlier is not a good idea.

Yeah loose em..... i had them and they didn't last more than 4 months and i started getting a shudder on heavy loads.... put ac delco stockers in and have no problems
Old 02-24-2004, 03:33 PM   #24
95 Blazer 4X4 2 door
 
cw's95Nightmare's Avatar
 
Age: 38
Join Date: Jan 2004
Posts: 210
Location: Houston
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Ok. I reduced the amount of blue light under the hood by re-routing the plug wires and using dielectric grease. Also, I replaced the ignition coil but it still glows blue from underneath. I still have a problem though. It still loses fuel pressure about 15 minutes after I turn off the engine. To start it I have to turn the key to on 3 times to build fuel pressure. Someone suggested that I need a new fuel pump because the check valve may be bad. Could I just put a check valve on the fuel intake line? I think this is where the problem is because I took the EGR valve out and looked in the hole and there isn't any fuel sitting around the CPI unit. Could a bad check valve in the fuel pump cause it to run rough too. Any suggestions are always appreciated. BTW: I have replaced the fuel pressure regulator and had the CPI flow tested. I can only guess the nut kit is good since I don't see any fuel sitting around in the intake.
Old 02-25-2004, 08:02 AM   #25
Registered User
 
pacesetter's Avatar
 
Age: 34
Join Date: Oct 2003
Posts: 24
Location:
User is: OffLine
Re: HOLY CRAP!!!!!! My ignition coil is glowing blue!!!

Im having the same problem, only I have a bran new fuel pump. I am guessing its that crappy CPI, I think the fuel pressure regulator is messed up on mine and if I recall its built into the cpi.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:42 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.