hazard lights flashing and wont start - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

hazard lights flashing and wont start

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 07-17-2011, 12:05 PM   #1
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
hazard lights flashing and wont start

i bought a 96 blazer 4.3 4x4 from a friend that wont start. what had happen was hazard switch was broke so he stuck a small screw driver down the hazard switch an worked for a long time to turn them off. well one day he was going down a bumpy road dirt road an all the lights started flashing and the blazer died. he cud never get it to start again. it cracks over just fine just dont start. any ideas what could be going on?
Old 07-17-2011, 12:22 PM   #2
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

removed the hazard switch with needle nose plyers an lights quit flashing. for sum reason when i go to disconect the battery the terminals are really hot also
Old 07-18-2011, 12:42 AM   #3
Registered User
 
Join Date: Jun 2002
Posts: 10,741
Location: Who cares
User is: OffLine
Re: hazard lights flashing and wont start

i have a 91 and was changing the bulbs to leds. i couldn't get the corner leds to
fire right and the 4 ways just stayed on. i turned the corner leds around so they
would fire with the bumper leds like they used to. when i did this, i noticed that
the fuel pump whirled on once the corner leds where in the correct position and
the 4 ways were working like they were supposed to....so it looks like the
fuel pump circuit and the hazard/turn signal circuit are married to each in some
form. i don't have wiring diagrams avail now, but i found this pretty strange.

i don't know if this helps or not, but maybe try pulling bulbs up front at the
corners and bumper. maybe the it will light off. i know it sounds goofy, but
ya never know. i guess you've already checked fuses, etc..you might pull the
hazard fuse and see if it lights off. the hazards are hot all the time so they
can work with the key on or off.
Old 07-19-2011, 07:58 PM   #4
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

ill look in to that when i get sum time and post back
Old 08-01-2011, 01:45 AM   #5
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

had time to do a little more digging. heres what i got pulled the hazard switch lights quit flashing. i have no fuel pressure at all an no spark. i can crank as long as i want then when u let off u get one lil spark an thats it
Old 08-02-2011, 01:43 AM   #6
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

i got a 96 BLAZER wire diagram hopefully it close to the 96 JIMMY wire diagram
Old 08-02-2011, 07:52 PM   #7
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

have 12 volts to the pink wire going in to the coil and i can here the fuel pump kick in if i put a 12 volt jumper wire to the prime wire but dont get no fuel psi on my guage
Old 08-04-2011, 12:30 AM   #8
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

im gettin no signal from in between the pcm an ignition control module an have tryed 3 different crankshaft sensors the old one, brand new one, an one out of a running truck. im lost at whats wrong an why im getting no spark
Old 08-06-2011, 03:55 PM   #9
Now own a 99 Blazer 4x4
 
SSsonoma43's Avatar
 
Age: 31
Join Date: Feb 2003
Posts: 370
Location: Milwaukee, WI
User is: OffLine
Re: hazard lights flashing and wont start

Ok, I am going to say check all your fuses with a test light when the key is on. You want to make sure your ignition switch is not bad. Test for voltage on both sides of the fuses. The ignition switch is what powers all the fuses that are supposed to be hot in run. There are a couple VCM fuses that are supposed to be hot at all times and in run only.
Old 08-06-2011, 04:45 PM   #10
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

will do when it cools down a little bit. found an update 2 wires were burnt were they plug in to the computer. i wud shake the harness with the burnt wires an it about wants to start. but sumtimes will make a humming sound close to the distribator when shaking the wires. i will replace them to 2 wires and re check fuses an give an update
Old 08-06-2011, 10:07 PM   #11
Registered User
 
DUI_DIME's Avatar
 
Age: 28
Join Date: Feb 2009
Posts: 95
Location:
User is: OffLine
Re: hazard lights flashing and wont start

got the wires soldered up an replaced. fuses are good. finally got the truck to start ut guages were going crazy speedometer an rms were bouncing around. shook the harness under the colum an it made loud sounds like the starter was tryin to engage while running then finally died. it seems to only do it when i have the turn signal/cruise control/ hazard light harness hooked up
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:58 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.