hazard lights flashing and wont start - S-10 Forum
 
LinkBack Thread Tools
post #1 of 11 Old 07-17-2011, 12:05 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
hazard lights flashing and wont start

i bought a 96 blazer 4.3 4x4 from a friend that wont start. what had happen was hazard switch was broke so he stuck a small screw driver down the hazard switch an worked for a long time to turn them off. well one day he was going down a bumpy road dirt road an all the lights started flashing and the blazer died. he cud never get it to start again. it cracks over just fine just dont start. any ideas what could be going on?

DUI_DIME is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 07-17-2011, 12:22 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

removed the hazard switch with needle nose plyers an lights quit flashing. for sum reason when i go to disconect the battery the terminals are really hot also
DUI_DIME is offline  
post #3 of 11 Old 07-18-2011, 12:42 AM
Registered User
 
Join Date: Jun 2002
Location: Who cares
Posts: 10,898

User is: bg's is offline
Re: hazard lights flashing and wont start

i have a 91 and was changing the bulbs to leds. i couldn't get the corner leds to
fire right and the 4 ways just stayed on. i turned the corner leds around so they
would fire with the bumper leds like they used to. when i did this, i noticed that
the fuel pump whirled on once the corner leds where in the correct position and
the 4 ways were working like they were supposed to....so it looks like the
fuel pump circuit and the hazard/turn signal circuit are married to each in some
form. i don't have wiring diagrams avail now, but i found this pretty strange.

i don't know if this helps or not, but maybe try pulling bulbs up front at the
corners and bumper. maybe the it will light off. i know it sounds goofy, but
ya never know. i guess you've already checked fuses, etc..you might pull the
hazard fuse and see if it lights off. the hazards are hot all the time so they
can work with the key on or off.
bg's is offline  
post #4 of 11 Old 07-19-2011, 07:58 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

ill look in to that when i get sum time and post back
DUI_DIME is offline  
post #5 of 11 Old 08-01-2011, 01:45 AM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

had time to do a little more digging. heres what i got pulled the hazard switch lights quit flashing. i have no fuel pressure at all an no spark. i can crank as long as i want then when u let off u get one lil spark an thats it
DUI_DIME is offline  
post #6 of 11 Old 08-02-2011, 01:43 AM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

i got a 96 BLAZER wire diagram hopefully it close to the 96 JIMMY wire diagram
DUI_DIME is offline  
post #7 of 11 Old 08-02-2011, 07:52 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

have 12 volts to the pink wire going in to the coil and i can here the fuel pump kick in if i put a 12 volt jumper wire to the prime wire but dont get no fuel psi on my guage
DUI_DIME is offline  
post #8 of 11 Old 08-04-2011, 12:30 AM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

im gettin no signal from in between the pcm an ignition control module an have tryed 3 different crankshaft sensors the old one, brand new one, an one out of a running truck. im lost at whats wrong an why im getting no spark
DUI_DIME is offline  
post #9 of 11 Old 08-06-2011, 03:55 PM
Now own a 99 Blazer 4x4
 
SSsonoma43's Avatar
 
Join Date: Feb 2003
Location: Milwaukee, WI
Age: 33
Posts: 370

User is: SSsonoma43 is offline
Send a message via AIM to SSsonoma43 Send a message via Yahoo to SSsonoma43
Re: hazard lights flashing and wont start

Ok, I am going to say check all your fuses with a test light when the key is on. You want to make sure your ignition switch is not bad. Test for voltage on both sides of the fuses. The ignition switch is what powers all the fuses that are supposed to be hot in run. There are a couple VCM fuses that are supposed to be hot at all times and in run only.

Used to own a 1999 GMC SONOMA 4X4 (X) IAT mod, MAF mod, TB mod, TB spacer, 160 degree thermostat, Gibson exaust, Backyard intake, Headlight removed, Hypertech PP3, Casper TPS controller, Corvette servo, MSD coil, E-fan, ASP power pulleys, and EGR mod, 16.451@81.27
SSsonoma43 is offline  
post #10 of 11 Old 08-06-2011, 04:45 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

will do when it cools down a little bit. found an update 2 wires were burnt were they plug in to the computer. i wud shake the harness with the burnt wires an it about wants to start. but sumtimes will make a humming sound close to the distribator when shaking the wires. i will replace them to 2 wires and re check fuses an give an update
DUI_DIME is offline  
post #11 of 11 Old 08-06-2011, 10:07 PM Thread Starter
Registered User
 
DUI_DIME's Avatar
 
Join Date: Feb 2009
Age: 30
Posts: 95

User is: DUI_DIME is offline
Re: hazard lights flashing and wont start

got the wires soldered up an replaced. fuses are good. finally got the truck to start ut guages were going crazy speedometer an rms were bouncing around. shook the harness under the colum an it made loud sounds like the starter was tryin to engage while running then finally died. it seems to only do it when i have the turn signal/cruise control/ hazard light harness hooked up
DUI_DIME is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome