Got fuel pressure, and spark but wont start - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Got fuel pressure, and spark but wont start

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 04-20-2011, 02:46 PM   #1
Registered User
 
Age: 24
Join Date: Apr 2011
Posts: 2
Location:
User is: OffLine
Got fuel pressure, and spark but wont start

My buddy has an 02 blazer with the 4.3 vortec auto 2wd. We have checked the fuel pressure and also we have checked the spark. Fuel pump reads about 45 psi and holds. car ran fine after new plugs, wires and coil and then stopped running again. plugged in scan tool and no codes were thrown other then just an o2 sensor. Also car cranks fine every time and it used to sporadically start. now just wont start period. Not sure what to do, was maybe thinking PCM? Any help?

Thanks
Old 04-20-2011, 04:29 PM   #2
Molon Labe
 
BudRacing's Avatar
 
Age: 28
Join Date: Aug 2004
Posts: 5,295
Location: Decatur, Ga
User is: OffLine
Re: Got fuel pressure, and spark but wont start

45 sounds a little low for these trucks
Old 04-21-2011, 01:40 AM   #3
terrible. take a lap.
 
joyride's Avatar
 
Join Date: Dec 2009
Posts: 4,025
Location: Tacoma, Wa
User is: OffLine
Re: Got fuel pressure, and spark but wont start

yeah 45 sounds too low. Is the fuel filter partially clogged maybe?
Old 04-21-2011, 03:22 AM   #4
Vig Pimpin
 
viggy58's Avatar
 
Age: 31
Join Date: Apr 2011
Posts: 724
Location: Lawrenceville, GA
User is: OffLine
Re: Got fuel pressure, and spark but wont start

yep. fuel pressure needs to be at least 60 psi. change the fuel filter. if you're still that low, your pump is bad. if you replace it, DO NOT GET AN AIRTEX PUMP!!!!!! spend the money and get an ac delco/delphi. you'll thank yourself later.

i'm gonna guess it tossed a "bank too lean" code from low fuel pressure...
Old 04-21-2011, 09:49 AM   #5
Registered User
 
Age: 24
Join Date: Apr 2011
Posts: 2
Location:
User is: OffLine
Re: Got fuel pressure, and spark but wont start

Alright, thanks guys for the info. Ill post my results.
Old 04-21-2011, 10:26 PM   #6
Wire Splicin Fool :-)
 
lesterl's Avatar
 
Age: 35
Join Date: May 2008
Posts: 8,691
Location: Harrisonville, MO
User is: OffLine
Re: Got fuel pressure, and spark but wont start

http://cgi.ebay.com/ebaymotors/New-A...cb76#vi-ilComp
Old 04-22-2011, 09:47 PM   #7
Registered User
 
Join Date: Jun 2002
Posts: 10,888
Location: Who cares
User is: OffLine
Re: Got fuel pressure, and spark but wont start

Boy that's a great price on a Delco pump and trimmings..
Old 04-23-2011, 01:08 AM   #8
Wire Splicin Fool :-)
 
lesterl's Avatar
 
Age: 35
Join Date: May 2008
Posts: 8,691
Location: Harrisonville, MO
User is: OffLine
Re: Got fuel pressure, and spark but wont start

Shure is, researched that one for someone else's post..... Glad I found it, hope it stays around because rebuilding one of those modules for around 1/2 a C note aint bad. If the fuel guage sender is bad also, RockAuto carries the sender for under that cost also.....
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:11 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.