Error Code P0420 - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Error Code P0420

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 02-28-2008, 10:27 PM   #1
Registered User
 
Age: 36
Join Date: Jan 2006
Posts: 14
Location:
User is: OffLine
Unhappy Error Code P0420

I know there are several threads on this, but this is a little weird...

I had a new Magnaflow Catalytic converter installed about 2 months ago (the old one was rattling like a tin can). Everything was running fine until about a couple of weeks ago when my car started throwing the P0420 code *Catalyst efficiency low bank 1*. I figured that since I had a new Cat. Converter, that it was more than likely my O2 sensor going bad (after the Cat). I installed the new one this past weekend, but the CEL is still on. Right now I'm wondering what the heck to do. My Blazer runs fine... I just have this annoying light on. Any ideas???
Sponsored Links
Advertisement
 
Old 02-29-2008, 05:30 PM   #2
Registered User
 
onecrazynoma's Avatar
 
Age: 29
Join Date: Mar 2006
Posts: 1,465
Location: SoCal
User is: OffLine
Re: Error Code P0420

i had the same code come up a while ago. i was just gonna throw a new cat on, figure at 120k it must be toast with how much soot flies out of the exhaust when i stomp on it. well luckily i have autotap, so i hooked up to my pc and what do you know, a bad o2 sensor on bank1.(not after cat) on driverside. so chances are you just need to find what o2 sensor(s) is bad.
not sure how else you will test the sensors. i guess just start replacing them. or spend that money on autotap or similar software there are a few others. and diag. it yourself.
im sure someone will chime in with a way to test your o2's

ps you could always take the ses bulb out lol
Old 03-05-2008, 05:40 PM   #3
Registered User
 
Age: 36
Join Date: Jan 2006
Posts: 14
Location:
User is: OffLine
Re: Error Code P0420

So bank 1 is referring to one of the o2 sensors between the Cat and the exhaust manifold? It sucks that the readout doesn't tell you which one is bad.
Old 03-05-2008, 06:13 PM   #4
No More SS
 
SmokeeJay's Avatar
 
Age: 42
Join Date: Feb 2007
Posts: 1,100
Location: Atlanta, GA
User is: OffLine
Re: Error Code P0420

Bank 1 Sensor 2 is just in front of the cat on the drivers side. I replaced that one last weekend. Took all of 15 minutes.
Old 03-18-2011, 10:41 PM   #5
Registered User
 
Age: 61
Join Date: Mar 2011
Posts: 4
Location:
User is: OffLine
Re: Error Code P0420

This is an 0BD II driving cycle to reset your monitors.They do not tell you this when getting inspection if you fail, "just drive it a few more miles" found out the hard way but it really works
http://www.obdii.com/DRIVECYCLE.HTML
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:06 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.