Cranks but no start. Getting fuel and Spark - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Cranks but no start. Getting fuel and Spark

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 12-03-2011, 09:10 PM   #1
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Cranks but no start. Getting fuel and Spark

Im helping a friend with a 2002 s10 4.3L. It started acting up with a hard start only after its hot. It would start first thing in the morning, but wouldnt again. Hes replaced the battery and starter. After he did the batter the gauges would all peg out. Then after the starter it went back but still have the hard starts.

He changed out the fuel pump and now it doesnt start at all. Hes getting 60psi of pressure with key on and it takes about an hour before it bleeds down to 25. He put a spark tester on a plug and its getting spark. When cranking it doesnt sound like its firing but once you release the key it spits and spudders for a couple seconds.

While cranking he sprayed eather into the throttle body and the thing wont even fire like that.

What could it be? Crank position sensor? Cam Sensor? Any help would be greatly appriciated.
Old 12-03-2011, 09:43 PM   #2
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

In the past couple month hes also replaced for just regular maintance the plugs, cap, rotor, distributor, radiator, water pump, thermostat.

Just sitting there the truck has 12.5 volts then while cranking it drops to 10.6. This is with new battery and starter. that seems alittle low.
Old 12-04-2011, 09:24 AM   #3
Registered User
 
Join Date: Nov 2011
Posts: 267
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

Quote:
Just sitting there the truck has 12.5 volts then while cranking it drops to 10.6.
Sounds like a bad battery to me. One of the cells might be dry. Hopefully you can get it replaced under warranty.
Old 12-04-2011, 11:05 AM   #4
Registered User
 
Join Date: Aug 2006
Posts: 115
Location: Biarritz, France
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

I'm having exactly the same issue with my 98'. I'm tearing my hair…when I release the key I've some explosion then nothing. I post various times about that and no way to get it solved. I changed almost everything ECM, injectors, ignition module and more.
ECM is not growing any code.
I'll need to buy another car as nobody finds this out
Old 12-04-2011, 11:05 AM   #5
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

Quote: Originally Posted by KarlW
Sounds like a bad battery to me. One of the cells might be dry. Hopefully you can get it replaced under warranty.
Even trying to start it while jumping off a running car it still wont start. Load tested the battery and the battery is good.

This has me going nuts, and its not even my truck.
Old 12-04-2011, 11:32 AM   #6
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

Quote: Originally Posted by tahi
I'm having exactly the same issue with my 98'. I'm tearing my hair…when I release the key I've some explosion then nothing. I post various times about that and no way to get it solved. I changed almost everything ECM, injectors, ignition module and more.
ECM is not growing any code.
I'll need to buy another car as nobody finds this out
Did you change crank position sensor and the coil. Thats what I was going to recomend to him next. just for shits and giggles i was also going to do a compression check.
Old 12-04-2011, 11:48 AM   #7
Registered User
 
Join Date: Aug 2006
Posts: 115
Location: Biarritz, France
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

Quote: Originally Posted by hurst1979olds
Did you change crank position sensor and the coil. Thats what I was going to recomend to him next. just for shits and giggles i was also going to do a compression check.
I changed the coil and electronic ignition module yesterday and no way…
My CKP sensor is one year old so I didn't change it. I tested it like unplug it to see if the spark was going away. On mine if I unplug it I've no more spark with means CKP should be OK as spark is coming back when I plug it again.

But I reckon that my problem could be related to a sync defect between spark and stroke. Sometimes I crank and I've a dozen of strokes with explosion then nothing. Maybe I should change the CKP again but I've been wasting so many $$$ now that I want to get rid of this truck
Old 12-04-2011, 12:33 PM   #8
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

He said last week before it finally quite on him and stopped starting, he said that it had been ideling at around 500...could it be an IAC thats stuck open?
Old 12-04-2011, 01:01 PM   #9
Registered User
 
Join Date: Aug 2006
Posts: 115
Location: Biarritz, France
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

I guess that a stuck IAC would throw a code
Old 12-05-2011, 01:27 PM   #10
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

Well i back probed the crank sensor and monitored the voltage. With the key on it would read 0 then turning the engine over with a breakerbar you can hear the fuel pump kick on, and the volt meter reads anywere between 4.5-4.9v just depends on what spot it at.

After cranking the engine over it just spits and spudders then cuts off. And the eather doesnt affect anything. But with a spark tester your getting a spark.
Old 12-05-2011, 01:33 PM   #11
jax4x4.com
 
pjg1173's Avatar
 
Age: 40
Join Date: Apr 2009
Posts: 2,644
Location: jacksonville, NC
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

did he replace the dist cap before it quit or after? I've seen some of the cheeper discout auto stuff die after a few months. I had this same issue with a 2000 s10, the owner kept saying I just changed the cap and roter a few months ago. took the cap off anyway and it had white electrical streaks everywhere.
Old 12-05-2011, 04:50 PM   #12
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

He had replaced the whole distributor cap/rotor with an AcDelco unit back in the summer. But ill have him check it out....worth a shot at least.
Old 12-06-2011, 09:58 AM   #13
Registered User
 
Age: 27
Join Date: Aug 2005
Posts: 84
Location:
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

He pulled the cap and rotor and the bottom of the distributor was full of water. The rotor button was broken off and all the terminals in the cap were fuzzy green. Bought a new distributor and started up great. Brand new AcDelco distributor defective in less that 2000 miles.

Thanks for your help guys....Tahi, I would try this on your truck if you have not yet already did. Good luck with it. Keep us posted.
Old 12-06-2011, 04:01 PM   #14
jax4x4.com
 
pjg1173's Avatar
 
Age: 40
Join Date: Apr 2009
Posts: 2,644
Location: jacksonville, NC
User is: OffLine
Re: Cranks but no start. Getting fuel and Spark

there should be some vents in the bottom of the distibutor base. if these are clogged he will have this happen again since condensation won't be able to vent/drain from the cap.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:55 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.