Blazer quit running while driving... - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

Blazer quit running while driving...

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 09-06-2007, 01:50 AM   #1
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Blazer quit running while driving...

I know this may be a long shot... like doing a fullback dive on 4th and 40.

Well, I was headed down the highway. All of a sudden, my engine cut off. I coasted to the side of the road, my brakes and steering got hard. The engine wont start... it acts like it is going to turn over, but wont... so its not the starter because it doesnt have the "machine gun sound."

Any idea on what could have happened? I recently crossed 100,000 miles and they recommended a dist. cap and rotor change when i had the coolant flushed. Could one of these have caused this to happen?

Jordan
Old 09-06-2007, 03:52 AM   #2
Mr. Sparkle
 
Onimun's Avatar
 
Join Date: Sep 2006
Posts: 9,953
Location: Southern California
User is: OffLine
Re: Blazer quit running while driving...

Good chance that might have been what happened. Go check the cap and rotor yourself very easy. I believe the cap comes off with 2 screws and the rotor just pops off. If those are the origional parts then they definatly need to be changed.
Old 09-06-2007, 08:36 AM   #3
Registered User
 
Age: 29
Join Date: Apr 2007
Posts: 72
Location:
User is: OffLine
Re: Blazer quit running while driving...

What do you mean by seems like it wanted to turn over but wouldn't??? it's one or the other...
Old 09-06-2007, 08:44 AM   #4
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

i meant that it wasnt making the "machine gun sound"... it sounded like what it normally sounds like right before it starts, but it didnt get to the point of actually starting

Best way i can describe the sound:
che che che vooom <---- normal
che che che che che che.... <---- now

Last edited by Curly; 09-06-2007 at 08:45 AM.
Old 09-06-2007, 08:59 AM   #5
Usted huele como un asno
 
mattryanmusic's Avatar
 
Age: 34
Join Date: Nov 2005
Posts: 1,196
Location: Roy Bitches!
User is: OffLine
Re: Blazer quit running while driving...

So it cranks but doesn't start?
Old 09-06-2007, 09:07 AM   #6
PUNISHING GROUNDS
 
got_u_sick's Avatar
 
Age: 29
Join Date: Feb 2006
Posts: 3,350
Location: Kentucky
User is: OffLine
Re: Blazer quit running while driving...

If your cap and rotor check out good, I can almost bet its the Ignition Module. Take your distributor cap off and its mounted on the bottom. Its a big flat simiconductor with a few wires connected to it. If you have a book for your truck it will tell you how to check it with a meter to see if its good or not. Chances are thats your problem if it was running fine then just took a shit all of the sudden.

You can check: Unplug your plug wire from the coil and put a screwdriver in it. Set it close enough to the post so it will arc when your turn the truck over. If it arcs=good. If not, coil or something in the initial firing system is bad.

Do the same with a plug wire. If there was spark on the coil, but you see no arc off the plug wire, 9 times out of 10, your ignition module is dead.

Last edited by got_u_sick; 09-06-2007 at 09:09 AM.
Old 09-06-2007, 10:12 AM   #7
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by mattryanmusic
So it cranks but doesn't start?
I guess so... i've always thought of cranking as starting, but i guess they are two different things.
Old 09-06-2007, 10:39 AM   #8
loco hombre
 
nater006's Avatar
 
Join Date: Dec 2003
Posts: 3,461
Location: Michigan
User is: OffLine
Re: Blazer quit running while driving...

Check cap & rotor, ignition coil, and fuel pressure.

If the pump zapped, it wouldn't even try to fire since the fuel pressure wouldn't be enough to spray and even get a sputter.

I had a dist cap failure on the freeway. Truck sputtered out, stalled, steering and brakes got tough (no power steering or brake booster when the engine stalls!). Cap wasn't even that old but had a microscopic crack or similar in it which carbon traced and shorted stuff out. So, check that too.
Old 09-06-2007, 10:46 AM   #9
__/\_____\O/___ ahh shark
 
rtsurfer's Avatar
 
Join Date: Aug 2007
Posts: 189
Location:
User is: OffLine
Re: Blazer quit running while driving...

It can only be a few things, Electrical, Mechanical, Fuel

First make sure you have enough fuel in the tank. Father in law pulled this one on me. Called up car won't start. I went over there and found out he was on empty.

2nd Pull on spark plug wire, put a screwdriver in the end of the wire, and lay it on top of the motor. Now crank over the motor.(try to start it) If you see it spark Good chances are it is a Fuel Problem. No Spark it could be computer, cap, rotor or timing chain.

Did you get any Check eninge lights brfore it shut off????
Old 09-06-2007, 11:34 AM   #10
Banned
 
Age: 56
Join Date: Apr 2007
Posts: 163
Location:
User is: OffLine
Re: Blazer quit running while driving...

Spray some starting fluid in the intake if it trys to start look to the fuel side of it. If not look for an Ingition problem.
Old 09-06-2007, 11:43 AM   #11
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Nope, no check engine lights.

I know someone is going to say "search button," but is there a thread telling how to change out the cap and rotor? I would like to see some pics or something... maybe something on another site. But I need to change that anyways because i've been working on getting it tuned up.
Old 09-06-2007, 12:15 PM   #12
loco hombre
 
nater006's Avatar
 
Join Date: Dec 2003
Posts: 3,461
Location: Michigan
User is: OffLine
Re: Blazer quit running while driving...

There are 2 torx screws (sorry, I don't remember which T-size) that hold the cap on. Label and remove the spark plug wires and coil wire from the cap. Remove the torx screws. (one in front, one in back). The cap lifts straight off. The rotor also has 2 torx screws holding it on that should be the same size as the cap ones. It's pretty easy on, easy off.

I'd recommend putting some dielectric grease in the wire boots before hooking them back up to the cap. Putting dielectric grease in the boots for the plugs is also a good move.
Old 09-06-2007, 08:35 PM   #13
Will work for turbo parts
 
Join Date: Jan 2007
Posts: 2,789
Location: SE, WI
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by got_u_sick
If your cap and rotor check out good, I can almost bet its the Ignition Module. Take your distributor cap off and its mounted on the bottom. Its a big flat simiconductor with a few wires connected to it. If you have a book for your truck it will tell you how to check it with a meter to see if its good or not. Chances are thats your problem if it was running fine then just took a shit all of the sudden.

You can check: Unplug your plug wire from the coil and put a screwdriver in it. Set it close enough to the post so it will arc when your turn the truck over. If it arcs=good. If not, coil or something in the initial firing system is bad.

Do the same with a plug wire. If there was spark on the coil, but you see no arc off the plug wire, 9 times out of 10, your ignition module is dead.
+1 for the PCM Same thing happened to me.
Old 09-06-2007, 08:41 PM   #14
chesticles are fun
 
spaseghost's Avatar
 
Age: 30
Join Date: Jan 2007
Posts: 1,131
Location: western colorado
User is: OffLine
Re: Blazer quit running while driving...

an engine only needs 3 things, and it looks like nater has you on your way with one of the 3. easiest thing to do is check your fuses first. then double check fuel, air, and spark. then go from there and fix what you dont have.
Old 09-07-2007, 04:38 PM   #15
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Ok guys. I changed the distributor cap and rotor. Didnt fix it.

I checked for a spark from the wire and I got one.

So next thing I am going to look at is if it is a fuel problem. Gonna get some starter fluid late tonight since I have to wait for friends to get off work to ride anywhere...

any other ideas?
Old 09-07-2007, 04:40 PM   #16
whore turned lurker
 
dimerunner88's Avatar
 
Age: 28
Join Date: Jan 2007
Posts: 20,921
Location: Clay City,IN
User is: OffLine
Re: Blazer quit running while driving...

is there gas in the tank?
Old 09-07-2007, 04:45 PM   #17
whore turned lurker
 
dimerunner88's Avatar
 
Age: 28
Join Date: Jan 2007
Posts: 20,921
Location: Clay City,IN
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by rtsurfer
It can only be a few things, Electrical, Mechanical, Fuel

First make sure you have enough fuel in the tank. Father in law pulled this one on me. Called up car won't start. I went over there and found out he was on empty.

2nd Pull on spark plug wire, put a screwdriver in the end of the wire, and lay it on top of the motor. Now crank over the motor.(try to start it) If you see it spark Good chances are it is a Fuel Problem. No Spark it could be computer, cap, rotor or timing chain.

Did you get any Check eninge lights brfore it shut off????
don't do that screwdriver shit, just get a spark plug and put in the wire, or better yet buy a spark tester like i have and you can check spark while it running.*hooks inline and you see the voltage running through it*
Old 09-07-2007, 05:01 PM   #18
loco hombre
 
nater006's Avatar
 
Join Date: Dec 2003
Posts: 3,461
Location: Michigan
User is: OffLine
Re: Blazer quit running while driving...

Get your hands on a fuel pressure gauge and stick it on the schraeder valve on the incoming fuel line, under the hood. If it isn't measuring 60ish with the key on, you might be looking at a pump

Last edited by nater006; 09-07-2007 at 05:03 PM.
Old 09-07-2007, 05:19 PM   #19
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Yeah Tom, it has gas. Everyone has asked me that.
But I'm gonna get a hold of someone's fuel pressure gauge.
Old 09-08-2007, 12:09 AM   #20
former owner
 
98SS's Avatar
 
Age: 31
Join Date: Feb 2003
Posts: 7,388
Location: north of Motor City ... formerly near Memphis
User is: OffLine
Re: Blazer quit running while driving...

Sorry to hear, man. You at school? Good luck fixing it.
Old 09-08-2007, 12:42 AM   #21
forum idiot
 
orangesonoma's Avatar
 
Age: 36
Join Date: Oct 2002
Posts: 49,674
Location: Indian Trail, NC
User is: OffLine
Re: Blazer quit running while driving...

sounds like it is broke pretty bad... sell it to me cheap..
Old 09-08-2007, 12:12 PM   #22
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by 98SS
Sorry to hear, man. You at school? Good luck fixing it.
Thanks man. Yeah I'm at school. Thankfully my roomate has pretty much the same schedule as me, i just have to get up earlier than usual some days to catch a ride.

Quote: Originally Posted by orangesonoma
sounds like it is broke pretty bad... sell it to me cheap..
How about.... I'll trade you.
Old 09-08-2007, 03:25 PM   #23
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

well, ive narrowed it down to fuel related... sprayed starter fluid into the throttle body and it starts up for a little while...

does anyone know where i can get a cheap fuel pressure gauge

and if its fuel related, is there anything other than fuel pump or fuel filter that could be the problem?
Old 09-08-2007, 04:22 PM   #24
chesticles are fun
 
spaseghost's Avatar
 
Age: 30
Join Date: Jan 2007
Posts: 1,131
Location: western colorado
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by Curly
well, ive narrowed it down to fuel related... sprayed starter fluid into the throttle body and it starts up for a little while...

does anyone know where i can get a cheap fuel pressure gauge

and if its fuel related, is there anything other than fuel pump or fuel filter that could be the problem?
check napa or the like for a fuel pressure gauge.
you could have a blockage in the line, but its not really all that possible. try your filter first. you can pull it off and blow some compressed air in it and put it back on and check your pressure after that. otherwise, check your pump. you could also have bad injectors too.
Old 09-09-2007, 05:11 PM   #25
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

alright guys... i changed the fuel filter.... still no luck

if fuel pressure checks out fine, what should i look at?


note for those who havent read this whole thread:
so far i have changed the distributor cap and rotor, checked for spark (had one), and changed fuel filter. Spraying stater fluid in the throttle body gets it running for a few seconds.
Old 09-09-2007, 05:52 PM   #26
Will work for turbo parts
 
Join Date: Jan 2007
Posts: 2,789
Location: SE, WI
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by Curly
alright guys... i changed the fuel filter.... still no luck

if fuel pressure checks out fine, what should i look at?


note for those who havent read this whole thread:
so far i have changed the distributor cap and rotor, checked for spark (had one), and changed fuel filter. Spraying stater fluid in the throttle body gets it running for a few seconds.
Measure the resistance of the injectors.

Last edited by King_Ice_Flash2; 09-09-2007 at 05:53 PM.
Old 09-09-2007, 05:54 PM   #27
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Quote: Originally Posted by King_Ice_Flash2
Measure the resistance of the injectors.
How would I go about doing that?
Old 09-09-2007, 07:22 PM   #28
chesticles are fun
 
spaseghost's Avatar
 
Age: 30
Join Date: Jan 2007
Posts: 1,131
Location: western colorado
User is: OffLine
Re: Blazer quit running while driving...

pull the electrical plug on the injectors and ohm them out.
Old 09-12-2007, 02:53 PM   #29
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

alright guys... i check the fuel pressure.. it was about 10 psi. Do you just turn it to the accesory position and let the fuel pump to kick on to check it?

Also, another thing.... i called to check on the fuel pump. Told them it is a 2dr blazer 2wd. They said they have 2 different ones depending on a code that is on my factory pump. Is there a way I can find out the code without taking the the tank and fuel pump out?
Old 09-12-2007, 03:19 PM   #30
Son of a drag racer
 
BlueDime's Avatar
 
Age: 25
Join Date: Apr 2007
Posts: 467
Location: Cincinnati, OH
User is: OffLine
Re: Blazer quit running while driving...

Don't quote me on this but isn't the fuel pressure for the newer enignes in the range of 50 psi. I have a 91 2.8 so I'm not sure on that number. I did have a similar problem that was the fuel pump put they usually go out gradually over time. The accesory position only turns on your radio and stuff I belive but if you turn the key to the on position then the pump should turn on for a second to build pressure in the line but if your getting low pressure and the pump turns on then something else is going on.
Old 09-12-2007, 03:27 PM   #31
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Yeah I hear the pump come on for about 2 seconds and it builds a little pressure. Could the pump just not be pumping enough?
Old 09-12-2007, 03:38 PM   #32
Son of a drag racer
 
BlueDime's Avatar
 
Age: 25
Join Date: Apr 2007
Posts: 467
Location: Cincinnati, OH
User is: OffLine
Re: Blazer quit running while driving...

It's possible. Electric motors act weird when they die. My fuel pump would get progressively worse over time and thats how they normally go out. If it was a thing where it isn't pumping enough I would check and make sure there isn't a ground problem or put a voltmeter on the wires to it and make sure its getting 12 volts. If that is the case I would have the battery checked out.
edit: If the battery is any older than 4 years I would have it replaced anyway

Last edited by BlueDime; 09-12-2007 at 03:40 PM.
Old 09-12-2007, 03:46 PM   #33
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Yeah I had the battery replaced last year. But I'll check the wires before I get into removing the gas tank.
Old 09-12-2007, 05:21 PM   #34
whore turned lurker
 
dimerunner88's Avatar
 
Age: 28
Join Date: Jan 2007
Posts: 20,921
Location: Clay City,IN
User is: OffLine
Re: Blazer quit running while driving...

replace the pump
Old 09-12-2007, 05:27 PM   #35
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

thanks man.
Old 09-12-2007, 06:03 PM   #36
Build them right....Mod
 
philntx's Avatar

 
Age: 58
Join Date: Jul 2006
Posts: 3,771
Location: Plano TX
User is: OffLine
Re: Blazer quit running while driving...

If your FP was 10 lb, either the pump is bad or the rubber hose from the pump has a hole in it.

Either way, you'll need to drop the tank.

That motor requires 50+lbs to run. The older TBI motors ran on 9-14 lbs of pressure.
Old 09-14-2007, 05:42 PM   #37
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

well i got the tank dropped and drain (it was completely full, so I am not dealing with putting it back on full )

picking up the pump tomorrow and replacing it then
Old 09-18-2007, 03:54 PM   #38
whore turned lurker
 
dimerunner88's Avatar
 
Age: 28
Join Date: Jan 2007
Posts: 20,921
Location: Clay City,IN
User is: OffLine
Re: Blazer quit running while driving...

and then? updates?
Old 09-18-2007, 04:32 PM   #39
Mr. Sparkle
 
Onimun's Avatar
 
Join Date: Sep 2006
Posts: 9,953
Location: Southern California
User is: OffLine
Re: Blazer quit running while driving...

Yea i agree Prob the fuel pump. Keep us updated
Old 09-18-2007, 08:23 PM   #40
Registered User
 
94noma4.3's Avatar
 
Age: 25
Join Date: Jun 2007
Posts: 282
Location: Palm Coast
User is: OffLine
Re: Blazer quit running while driving...

havin the same problem. i thought it was gonna be the fuel pump. let us no what happens
Old 09-18-2007, 11:27 PM   #41
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

got the fuel pump in... got it running, so the fuel pump was bad
Old 09-19-2007, 01:00 AM   #42
Mr. Sparkle
 
Onimun's Avatar
 
Join Date: Sep 2006
Posts: 9,953
Location: Southern California
User is: OffLine
Re: Blazer quit running while driving...

glad to hear u got it working man
Old 09-19-2007, 01:02 AM   #43
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

oh yeah, im glad too
Old 09-19-2007, 01:51 PM   #44
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

Son of a.... I just filled the gas tank to full and i have a leak... I guess I did not get a good seal on the pump.

Is it ok for me to drive it until it gets to about a quarter of a tank so that I can drop it again myself, or do I need to get it looked at now? I've driven it for about 5 days so far, just filled it up for the first time (was a little less than full when i got the new fuel pump on), and it leaked for a short period and has stopped now.

I'm sick of this, and I really dont have the time or desire to drop it myself right now in the middle of the week... I would probably be willing to drop it myself this weekend if I could burn some of the fuel off. So I'm debating either taking it to a shop or doing it myself this weekend.
Old 09-19-2007, 02:12 PM   #45
Son of a drag racer
 
BlueDime's Avatar
 
Age: 25
Join Date: Apr 2007
Posts: 467
Location: Cincinnati, OH
User is: OffLine
Re: Blazer quit running while driving...

Well if its just the seal on the top of the tank then you can drive it around the problem is that you will get the worst gas mileage ever but it won't hurt anything.
Old 09-19-2007, 02:35 PM   #46
future Dr. Curly
 
Curly's Avatar
 
Join Date: Oct 2004
Posts: 4,897
Location: Memphis
User is: OffLine
Re: Blazer quit running while driving...

ok yeah, thats what im gonna do.... im gonna get the tank down to about 1/4 a tank and then take it down and redo the seal, making sure to lubricate it.
Old 09-20-2007, 12:34 AM   #47
Registered User
 
99_noma's Avatar
 
Age: 28
Join Date: Nov 2005
Posts: 55
Location:
User is: OffLine
Re: Blazer quit running while driving...

what would you check if your fuel pump didnt even turn on when you turned your key?
Old 09-20-2007, 01:26 AM   #48
Registered User
 
Age: 27
Join Date: Apr 2007
Posts: 1,059
Location:
User is: OffLine
Re: Blazer quit running while driving...

the fuse.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:00 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.