95 S10 Blazer starting and running problems - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

95 S10 Blazer starting and running problems

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 02-10-2006, 11:14 AM   #1
Registered User
 
Age: 55
Join Date: Feb 2006
Posts: 1
Location:
User is: OffLine
95 S10 Blazer starting and running problems

I have a 95 S 10 blazer with a 4.3 motor. The problem I have is both a start and run issue. One time you try it it may start fine and idle fine for a few seconds, the next time it may not. The thing is even if it does start, the minute you put it in gear or turn heater or ac on it dies.I have put plugs, wires,rotor,cap, new fuelpump, fuel injector, fuel filter, egr, and map sensors on it. nothing helped. I was messing with it one day, I disconnected the map sensor and it started and ran at a idle, but still would die if a load was put on it. I tried another sensor, no change. I am lost, any ideas?
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:09 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.