1999 4.3 starts when key in on position - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

1999 4.3 starts when key in on position

Go Back   S-10 Forum > Engine and Drivetrain Tech > 262ci Forum (4.3)
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 01-05-2013, 11:02 PM   #1
Registered User
 
Age: 36
Join Date: Jan 2012
Posts: 6
Location:
User is: OffLine
1999 4.3 starts when key in on position

99 astro van. starts with key in on position. even before i get to the start point. replaced the ign switch. still did it. replaced the starter relay under the hood with an ac relay right next to it. still did it. replaced the starter. still did it. ive searched this site, google, the book. i also shifted the column real quick as the starter was engaging and it continued to crank. the van starts but you can hear the bendix starter still engaged in the flywheel. i dunno whats next. do you?



dave in chadds ford
Old 01-05-2013, 11:25 PM   #2
Girl with wrenches
 
roademon's Avatar
 
Age: 25
Join Date: Sep 2010
Posts: 1,802
Location: Calgary AB
User is: OffLine
Re: 1999 4.3 starts when key in on position

So in the on position it continues to crank even once started? I would say wiring at the ignition key cylinder is messed
Old 01-05-2013, 11:37 PM   #3
Registered User
 
burned's Avatar
 
Age: 47
Join Date: Aug 2009
Posts: 1,728
Location: Vancouver, BC
User is: OffLine
Re: 1999 4.3 starts when key in on position

Check the neutral safety switch and also check the wiring at the starter, may be grounding out.
Old 01-06-2013, 10:06 PM   #4
Registered User
 
Age: 36
Join Date: Jan 2012
Posts: 6
Location:
User is: OffLine
Re: 1999 4.3 starts when key in on position

i insert the key, turn it fwd, and before it gets to start position,it starts to crank. when the van does start and the key is left on the run position the starter gear stays in the flywheel and makes a horrible screech so i turn it off.

why or how would a neutral safety switch effect the ignition? and it is automatic trans
Old 01-07-2013, 12:15 AM   #5
Registered User
 
burned's Avatar
 
Age: 47
Join Date: Aug 2009
Posts: 1,728
Location: Vancouver, BC
User is: OffLine
Re: 1999 4.3 starts when key in on position

You sure you go that ignition switch in correctly?
Can you turn it backwards to "accy" ?

Well in your case its technically called a transmission range switch, same as a neutral switch.

To test the Park Neutral Switch, remove the starter enable relay located in the underhood fuse relay center and probe B6 cavity with a test lamp. Turn ignition to start and light should only be lit in P or N. Try moving the shift lever full range and between ranges and see if you can find a failure. Also the black wire 50 (NOT a ground) from Battery to Starter Solenoid must be connected and in good condition.

IGN-A 40A Fuse 6 is hot at all times and provides power to the ignition switch and the starter enable relay via the red wire 242 at cavity A6. When the ignition switch is in the START position, Yellow wire 5 powers CRANK Fuse 8 10A in the I/P Fuse Block and Purple wire 806 provides power to the Park/Neutral Position and Backup Lamp Switch. If the switch is in Park or Neutral, Yellow wire 1737 powers the Starter Enable Relay coil at cavity B6. Black wire 850 cavity A4 provides ground to the coil and terminates at Ground G104 which is located at the Right Side Front of Dash above Blower Motor. If everything works as it is designed, the coil closes the contact inside the starter enable relay and bridges power from Red wire 242 A6 to Purple wire 6 terminal B4 which is the starter request wire
Old 01-07-2013, 12:20 PM   #6
General L33
 
Hotwire's Avatar
 
Join Date: Jul 2001
Posts: 1,517
Location: Summerfield, NC
User is: OffLine
Re: 1999 4.3 starts when key in on position

Does this astro have any aftermarket equipment installed? Remote start, alarm system, etc?

Did you replace the ignition lock or the actual switch?
Old 01-07-2013, 05:18 PM   #7
Registered User
 
Age: 36
Join Date: Jan 2012
Posts: 6
Location:
User is: OffLine
Re: 1999 4.3 starts when key in on position

no remote start no alarm. i replaced the wire part, the ign switch. goes does the column little 7 mm bolt.

the ign switch can only go in one way cause the bolts wont line up
Old 01-09-2013, 07:28 PM   #8
Registered User
 
Age: 36
Join Date: Jan 2012
Posts: 6
Location:
User is: OffLine
Re: 1999 4.3 starts when key in on position

it was the neutral safety switch.
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:45 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.