1992 s10 blazer no power to fuel pump - S-10 Forum

 
LinkBack Thread Tools
post #1 of 7 Old 04-25-2010, 07:36 PM Thread Starter
Registered User
 
Join Date: Jul 2008
Age: 28
Posts: 5

User is: S10HelleruD is offline
1992 s10 blazer no power to fuel pump

changed pump think relay is ok what else could be wrong? grounds are all good! how do you check to see if a relay is good again?

S10HelleruD is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-25-2010, 07:59 PM
Mr. SQ
 
bobditts's Avatar
 
Join Date: Aug 2008
Age: 32
Posts: 2,302

User is: bobditts is offline
Re: 1992 s10 blazer no power to fuel pump

check the fuses. To check the relay, run power to the pigtail that is coming off of the relay.
bobditts is offline  
post #3 of 7 Old 04-26-2010, 03:02 AM Thread Starter
Registered User
 
Join Date: Jul 2008
Age: 28
Posts: 5

User is: S10HelleruD is offline
Re: 1992 s10 blazer no power to fuel pump

Thank you i figured it out twas my buddys dumb self that when he replaced the fuel pump for me he didt plug it in!!!!! but anyone know if they had black interior in any s10 blazer?? and would a 94 dash fit into a 92
S10HelleruD is offline  
post #4 of 7 Old 04-26-2010, 08:24 AM
Mr. SQ
 
bobditts's Avatar
 
Join Date: Aug 2008
Age: 32
Posts: 2,302

User is: bobditts is offline
Re: 1992 s10 blazer no power to fuel pump

yes there was a black interior for s10 blazers. Have no idea about the dash.
bobditts is offline  
post #5 of 7 Old 05-02-2010, 10:47 PM
Older Than Dirt
 
compmikey's Avatar
 
Join Date: May 2007
Location: Ohio
Posts: 402

User is: compmikey is offline
Re: 1992 s10 blazer no power to fuel pump

check those fuses! "ECM-B" comes to mind, but check as many as you can.
compmikey is offline  
post #6 of 7 Old 05-04-2010, 05:23 AM
Registered User
 
Join Date: Jan 2009
Age: 27
Posts: 70

User is: secondgencamaro is offline
Re: 1992 s10 blazer no power to fuel pump

Quote:
Originally Posted by compmikey View Post
check those fuses! "ECM-B" comes to mind, but check as many as you can.
Definitely check this one in particular.

'76 Camaro 400ci - TH-350 - 3.08:1 - 3,760lbs w/o driver

'93 S-10 3.4L - std cab - short bed
secondgencamaro is offline  
post #7 of 7 Old 05-04-2010, 05:32 AM
Equinsu Ocha!
 
350X's Avatar
 
Join Date: Mar 2008
Location: NW Ohio
Age: 44
Posts: 862

User is: 350X is offline
Re: 1992 s10 blazer no power to fuel pump

Go hook up with this guys n help each other.

Same year GM and he can't get his FP to turn off

http://www.s10forum.com/forum/f135/t...unning-439793/

Like a bad reese's pieces commercial

Last edited by 350X; 05-04-2010 at 05:34 AM.
350X is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome