1984 S10 Blazer w/ 3.4l engine Won't Start! - S-10 Forum
 
LinkBack Thread Tools
post #1 of 9 Old 12-10-2008, 04:41 PM Thread Starter
Registered User
 
Join Date: Dec 2008
Age: 35
Posts: 476

User is: onecrazyfoo4u is offline
1984 S10 Blazer w/ 3.4l engine Won't Start!

New to the forum hi all! Just bought this 84 about 2 months ago. It's all original, no engine modifications, stock 2BL carb, electronic fuel pump, etc. It's been running great all along until this morning it wouldn't start up. It caught for a second, and chugged for about 5 seconds (sounded like it was running only a couple cylinders) then died and won't start at all now.

The last owner told me he had a shop do a 1998 3.4l engine swap. This sounds like a really common swap, and you can't even tell the difference by looking at the engine from what I've seen. I'm trying to find some specifications on this engine. I have reciepts for it, but it doesn't tell me what car the engine was out of. Anybody have a link to general specifications for the 3.4l motor, like spark plugs, ignition, timing, etc.?

I'm just trying to troubleshoot and it's hard without specs for the 3.4l. Main thing I need, is what spark plugs are used for this engine (heat range + gap)? What's the timing supposed to be set at? And what are the fluid capacities? I can't think of any other reason why it wouldn't start, anybody? Thanks for the help!


Last edited by onecrazyfoo4u; 12-10-2008 at 04:42 PM.
onecrazyfoo4u is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-10-2008, 08:02 PM Thread Starter
Registered User
 
Join Date: Dec 2008
Age: 35
Posts: 476

User is: onecrazyfoo4u is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

Well, I pulled the plugs, and they all smell like gas really bad. So, I'm guessing this means that the carb is flooding? How do I fix it? I'm not too knowledgable on carbuerators....always had fuel injected vehicles. Should I just let it sit for awhile and then try starting again? It just turns and turns, doesn't catch or even try to chug at all.

What spark plugs does this 3.4l engine take? Thanks.
onecrazyfoo4u is offline  
post #3 of 9 Old 12-10-2008, 10:29 PM
YAY for Primer!
 
ShortyzKustomz's Avatar
 
Join Date: Oct 2003
Location: Central Va.
Age: 30
Posts: 223

User is: ShortyzKustomz is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

Must be a crate motor if its a 98, Cause 98 Camaros had the the 3.8

-1994 Toyota Bagged, Suicides, 3.8 T5 Swap in the Works
-2006 Silverado 5/8 Drop on KMC 20s
-1992 S10 Longbed 4.3 3/4 drop (Beater)
ShortyzKustomz is offline  
post #4 of 9 Old 12-11-2008, 04:12 PM Thread Starter
Registered User
 
Join Date: Dec 2008
Age: 35
Posts: 476

User is: onecrazyfoo4u is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

I don't think it's a crate, looks too old. Is there a way to check the year or model of the eninge, is it stamped anywhere?

I bought new plugs and wires, just because it needed it....but I don''t know if I got the right spark plugs? Which ones should be used for a 3.4l carb''d engine? I doubt it will fix the start up problem though. Help please!
onecrazyfoo4u is offline  
post #5 of 9 Old 12-11-2008, 09:40 PM
4x4 v6 blazer
 
neo71665's Avatar
 
Join Date: Oct 2004
Location: rison arkansas
Age: 36
Posts: 7,521

User is: neo71665 is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

Only years f bodies that had 3.4 were 93, 94, and 95.

87 blazer tahoe 2 door, 5.7, auto, sfa 4x4
91 noma reg cab, 3.4, 5speed, lowered
President of the Arkansas chapter Anti-bag Coalition
"Bags are for groceries"
Quote:
Originally Posted by alarm_the_alarm View Post
Lift That Sh*t, Fat Girls Can't Jump
Quote:
Originally Posted by mostizzle View Post
i just made love to your bowels......and then reported them.

neo71665 is offline  
post #6 of 9 Old 12-12-2008, 02:02 AM Thread Starter
Registered User
 
Join Date: Dec 2008
Age: 35
Posts: 476

User is: onecrazyfoo4u is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

Cool, I think that's what it's out of. Where can I find the engine model number or vin number? I'm just having trouble finding the specs on this engine. Mainly, what spark plugs and gap should I be running? Any help is appreciated!
onecrazyfoo4u is offline  
post #7 of 9 Old 12-13-2008, 12:22 AM
Wait, what?
 
Z28Camaro's Avatar
 
Join Date: Dec 2007
Location: Worthington, IN
Age: 28
Posts: 443

User is: Z28Camaro is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

Have you checked for spark yet? Could be a coil possibly...
Z28Camaro is offline  
post #8 of 9 Old 12-17-2008, 12:22 PM Thread Starter
Registered User
 
Join Date: Dec 2008
Age: 35
Posts: 476

User is: onecrazyfoo4u is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

I got her started up the other day after messing around with the carb. I think it was just a stuck choke plate on the stock 2BBL carb. Is the rear plate the choke plate then (the bigger one)? And the plate should open up only for start right, should go back closed after a few minutes of idle? Both plates were pretty loose, but they work good now. Thanks!
onecrazyfoo4u is offline  
post #9 of 9 Old 12-17-2008, 12:58 PM
bat
Registered User
 
Join Date: Feb 2008
Posts: 20

User is: bat is offline
Re: 1984 S10 Blazer w/ 3.4l engine Won't Start!

You will start to have choke problems. I tied mine open. It should be close to fully closed and open up while running and stay open until it's turned off and cools down. A faulty choke will not close when cool or close when hot. I don't know the correct fix. A complete rebuild may or may not fix it.
bat is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome