turns over won't start - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

turns over won't start

Go Back   S-10 Forum > Engine and Drivetrain Tech > 2.2L - 2nd gen 4-banging
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 02-07-2013, 04:31 PM   #1
Registered User
 
Join Date: Feb 2013
Posts: 8
Location:
User is: OffLine
turns over won't start

I have a 98 2.2L manual. it will turn over but wont run. the check engine light stays on. I have replaced the starter less than two months ago i bought the truck in october and since have replaced the fuel tank, filler neck, and straps, pump and sending unit, sending and return lines as well as fuel filter. i have a brand new air filter and have cleaned all the box units from the intake to the filter. it also has a brand new battery. So heres the thing it runs on starting fluid but then shortly dies. I have fuel pressure to the shredder valve and the pump whur's when the key is turned. I have checked every fuse in the cab and under the hood and swapped relays to rule them out. I tested all of the terminals with my test light and found that my ECMb fuse terminal as well as my TBSI fuse terminal and my LDLEV fuse terminal are all dead. I got my hands on a $400 plus dollar computer reader and sure enough would not pull a code i just get a flashing EV symbol and a big fat goose egg on the screen. I figured my way to the intake manifold sensor and the two throttle body sensors and the wiring in between to fuse box. I did have to sauder and broken wire in the harness when I replaced the gas tank. checking the plugs for corrosion found nothing so i plugged them back in and and sure enough the truck fired right up and runs like a charm with no check engine light. drove it 5 or so miles and shut it off starts right back up? I plugged the computer reader back in and still got the same EV flashing signal? just to be sure i plugged it into my buick lesabre which doesnt have it's check engine light on and it actually works and shows results. Im very confused as to what the issue is. i would also like to disclaim that the ignition switch has been pulled apart as the little black piece is missing and the key is clearly aftermarket from some axxess company. any insight would help i suck with electrical problems
Old 02-07-2013, 04:34 PM   #2
Registered User
 
Join Date: Feb 2013
Posts: 8
Location:
User is: OffLine
Re: turns over won't start

also the security light comes on and off randomly. i did however notice that when the truck finally did start the security light on the dash was infact off
Old 02-08-2013, 12:59 AM   #3
Ratchety thing
 
tCstump's Avatar
 
Age: 26
Join Date: Jul 2010
Posts: 112
Location: Beckley
User is: OffLine
Re: turns over won't start

If you pulled your ignition switch you probably need to reset your BCM. If security is on, don't start the truck but crank the truck once then leave the key in the run position for about 10 mins. The security light will go off. Turn they key off for 5 seconds. Then repeat this 2 more times. This will relearn your BCM to your ignition and it should start. That is if security is you problem.
Old 02-08-2013, 02:56 PM   #4
Registered User
 
Join Date: Feb 2013
Posts: 8
Location:
User is: OffLine
Re: turns over won't start

alright. sure enough this morning the truck would not start. I did the procedure you described and on the third and final time instead of the security light dissappearing after it flashes it simply stayed on. by the third crank it turned over and in running. thank you for all your help. atleast if its not a permanant fix it will get me out of the woods if it happens to continue. but all in all it worked so thank you
Old 02-08-2013, 02:58 PM   #5
Registered User
 
Join Date: Feb 2013
Posts: 8
Location:
User is: OffLine
Re: turns over won't start

i never actually pulled the ignition but when i bought the truck it had clear evidence that someone had messed with it. hopefully a new ignition switch will stop it if it continues
Old 02-08-2013, 11:04 PM   #6
Ratchety thing
 
tCstump's Avatar
 
Age: 26
Join Date: Jul 2010
Posts: 112
Location: Beckley
User is: OffLine
Re: turns over won't start

No prob man, glad it worked for ya. If you do change the igntion cylinder just repeat the BCM again and all should be good. I swapped to a tilt wheel the other day and didn't change the ignitioin cylinder. My truck wouldn't start and it had me freaking out. haha
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:15 PM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.