fuel injector problems - S-10 Forum
 
LinkBack Thread Tools
post #1 of 5 Old 11-04-2010, 05:36 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Age: 24
Posts: 25

User is: palella09 is offline
fuel injector problems

i got a '96 2.2 and i'm having problems with one of my fuel injectors. it stays open and makes the inside of my truck smell like gas when it just sits there. I know i need to change it but is there any other chevys that have the same fuel injector? i'm on a tight budget and i'm willing to try to get one from a junkyard instead of buying a brand new injector from pep boys for 117 +20 for core !
thanks

palella09 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-04-2010, 07:57 PM
LORDING
 
mostizzle's Avatar
 
Join Date: Aug 2009
Location: Poopin' with the door open
Posts: 33,506

User is: mostizzle is offline
Re: fuel injector problems

cavaliers, grand ams and a few other FWD GM's have the 2.2 in them, i got mine from a grand am.. just make sure it's around the same year but nothing after 97, the engines will look the same as yours(the black finned valve cover is a dead give away) so just poke around until you come across one.

TelAmeriCorp
mostizzle is offline  
post #3 of 5 Old 11-05-2010, 02:35 AM Thread Starter
Registered User
 
Join Date: Mar 2009
Age: 24
Posts: 25

User is: palella09 is offline
Re: fuel injector problems

i'll be heading to the local junkyard tomorrow morning, thanks for the help!
palella09 is offline  
post #4 of 5 Old 11-05-2010, 05:35 PM
LORDING
 
mostizzle's Avatar
 
Join Date: Aug 2009
Location: Poopin' with the door open
Posts: 33,506

User is: mostizzle is offline
Re: fuel injector problems

no problem and good luck!

TelAmeriCorp
mostizzle is offline  
post #5 of 5 Old 11-05-2010, 06:07 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Age: 24
Posts: 25

User is: palella09 is offline
Re: fuel injector problems

i ended up finding the injector on a cavalier and i put it in. after priming it about 4 times to make sure each injector was fine and wasn't leaking i tried to start it and it sounded like it was clogged with fuel, took out a spark plug and tried it again. it shot out all the fuel that was stuck in there. i cranked it again and it started, but shot fire out and lit up everything that got wet from gas from the previous crank. i was scared as s*** and threw water to put it out. luckily nothing got burnt too bad and I ended up putting everything back together and got it running. I never knew i could be so scared to try starting my truck. I'll post pics of the damage soon!
palella09 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome