fuel injector problems - S-10 Forum
S-10 Forum is the resource on GM S-series trucks, Suspension, engine information, Body Modifications, painting tutorials.  Modifications to suit every need, budget and whim

fuel injector problems

Go Back   S-10 Forum > Engine and Drivetrain Tech > 2.2L - 2nd gen 4-banging
New User? Register Forgot Password


 
LinkBack Thread Tools
Old 11-04-2010, 05:36 PM   #1
Registered User
 
Age: 22
Join Date: Mar 2009
Posts: 25
Location:
User is: OffLine
fuel injector problems

i got a '96 2.2 and i'm having problems with one of my fuel injectors. it stays open and makes the inside of my truck smell like gas when it just sits there. I know i need to change it but is there any other chevys that have the same fuel injector? i'm on a tight budget and i'm willing to try to get one from a junkyard instead of buying a brand new injector from pep boys for 117 +20 for core !
thanks
Old 11-04-2010, 07:57 PM   #2
.
 
mostizzle's Avatar
 
Join Date: Aug 2009
Posts: 27,707
Location: 1800 Crenshaw
User is: OffLine
Re: fuel injector problems

cavaliers, grand ams and a few other FWD GM's have the 2.2 in them, i got mine from a grand am.. just make sure it's around the same year but nothing after 97, the engines will look the same as yours(the black finned valve cover is a dead give away) so just poke around until you come across one.
Old 11-05-2010, 02:35 AM   #3
Registered User
 
Age: 22
Join Date: Mar 2009
Posts: 25
Location:
User is: OffLine
Re: fuel injector problems

i'll be heading to the local junkyard tomorrow morning, thanks for the help!
Old 11-05-2010, 05:35 PM   #4
.
 
mostizzle's Avatar
 
Join Date: Aug 2009
Posts: 27,707
Location: 1800 Crenshaw
User is: OffLine
Re: fuel injector problems

no problem and good luck!
Old 11-05-2010, 06:07 PM   #5
Registered User
 
Age: 22
Join Date: Mar 2009
Posts: 25
Location:
User is: OffLine
Re: fuel injector problems

i ended up finding the injector on a cavalier and i put it in. after priming it about 4 times to make sure each injector was fine and wasn't leaking i tried to start it and it sounded like it was clogged with fuel, took out a spark plug and tried it again. it shot out all the fuel that was stuck in there. i cranked it again and it started, but shot fire out and lit up everything that got wet from gas from the previous crank. i was scared as s*** and threw water to put it out. luckily nothing got burnt too bad and I ended up putting everything back together and got it running. I never knew i could be so scared to try starting my truck. I'll post pics of the damage soon!
Sponsored Links
Advertisement
 

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:10 AM.

Powered by vBulletin® Copyright ©2000 - 2011, Jelsoft Enterprises Ltd. SEO by vBSEO 3.2.0
SEO by vBSEO
vBulletin Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.