98 s10 Starting problems - S-10 Forum
 
LinkBack Thread Tools
post #1 of 12 Old 07-05-2010, 07:53 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Question 98 s10 Starting problems

I have a 98 s10, runs fine. I try to start it today and nothing happens. The lights will come on, the check engine light comes on, fuel pump does not turn on, Starter does not engage or even attempt to crank. I jumpered the starter fuse relay and also the fuel pump fuse relay and I could start it by doing that without having to turn the key or push in the clutch. I also tried jumpering the clutch neutral safety switch and that didnt do anything. I think it might be the ignition switch but I am not 100% and I really dont want to rip apart my steering column to find out. Any other Possible things that I could check? Also, my security light isnt on so I dont think that is the problem either. Thanks.

98TenTruck is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 07-05-2010, 09:15 PM
It's "Neanderthal"
 
SH-60B's Avatar
 
Join Date: Nov 2007
Location: Meriden/CT/USA
Posts: 5,409

User is: SH-60B is offline
Re: 98 s10 Starting problems

Before going any further clean the battery cables at both ends, pay particular attention to the ground cable.

1996 2.2, 5 speed, std cab, Sonoma
Teamsters Local 1150
SH-60B is offline  
post #3 of 12 Old 07-05-2010, 09:47 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Re: 98 s10 Starting problems

I cleaned both connections. Checked ground connections and they are all good. I used a code reader on it and it didnt bring up any codes either..
98TenTruck is offline  
post #4 of 12 Old 07-06-2010, 01:43 AM
Registered User
 
Join Date: Jun 2010
Location: Lake Orion
Age: 34
Posts: 157

User is: Ryan66 is offline
Re: 98 s10 Starting problems

Quote:
Originally Posted by 98TenTruck View Post
I cleaned both connections. Checked ground connections and they are all good. I used a code reader on it and it didnt bring up any codes either..
Does it click at all? MIne did this last week. Everything would come on but wouldnt start just clicked like a dead battery. It turned out to be a loose connection on one of the wires going to the starter solenoid and it was throwin a small spark when you tried to start it
Ryan66 is offline  
post #5 of 12 Old 07-06-2010, 09:15 AM
It's "Neanderthal"
 
SH-60B's Avatar
 
Join Date: Nov 2007
Location: Meriden/CT/USA
Posts: 5,409

User is: SH-60B is offline
Re: 98 s10 Starting problems

What's the battery voltage?

1996 2.2, 5 speed, std cab, Sonoma
Teamsters Local 1150
SH-60B is offline  
post #6 of 12 Old 07-06-2010, 02:52 PM
Registered User
 
Join Date: Jun 2010
Age: 29
Posts: 19

User is: S10 Guru is offline
Re: 98 s10 Starting problems

Check all your fuses too
S10 Guru is offline  
post #7 of 12 Old 07-07-2010, 03:20 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Re: 98 s10 Starting problems

I can hear the solenoid click once, I didnt check the battery voltage yet. I hooked up jumper cables to it and still nothing. I mean it starts when you jumper the starter relay and the fuel pump relay so i dont think its a battery issue. I checked all of the fuses and they all checked out to be good..
98TenTruck is offline  
post #8 of 12 Old 07-07-2010, 04:58 PM
Registered User
 
Join Date: Jun 2010
Location: Lake Orion
Age: 34
Posts: 157

User is: Ryan66 is offline
Re: 98 s10 Starting problems

Sounds like what mine did. Crawl under the drivers side and get under the starter and have someone try to start it. See if you see a spark coming off solenoid
Ryan66 is offline  
post #9 of 12 Old 07-08-2010, 02:39 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Re: 98 s10 Starting problems

okay Ill take a look at it tomorrow morning.
98TenTruck is offline  
post #10 of 12 Old 07-10-2010, 02:05 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Re: 98 s10 Starting problems

Found the problem. There was a short in this little chip in the ignition switch harness.
98TenTruck is offline  
post #11 of 12 Old 07-10-2010, 08:14 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Age: 28
Posts: 6

User is: 98TenTruck is offline
Re: 98 s10 Starting problems

Nevermind, That was still not the problem. Anyone think it might be the PCM?
98TenTruck is offline  
post #12 of 12 Old 09-09-2010, 12:19 PM
Registered User
 
Join Date: Sep 2010
Age: 56
Posts: 2

User is: CLEWIS is offline
Re: 98 s10 Starting problems

I Have A 2001 S10 Turn The Key I Hear The Fuel Pump But Nothing Else Sometimes It Cranks Right Up But Most Times I Have To Fool With Key Hold It Down For 15-50 Seconds Maybe More Replaced Ignition Switch Neutral Switch Still Wont Turn Over Right Away
CLEWIS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome