2000 s10 wont start - S-10 Forum
LinkBack Thread Tools
post #1 of 1 Old 08-15-2008, 01:44 PM Thread Starter
Registered User
Join Date: Aug 2008
Posts: 2

User is: draginby is offline
2000 s10 wont start

hey im new here i looked around but couldnt find anything..my problem is i put a fuel cell in my truck with a carter inline pump and when i turn the key so the pump comes on then start the truck it starts up fine then starts to cut out like its not getting enough gas i think maybe theres not enough presure dose anyone know the stock fuel presure for a 2000 2.2l any help would be great thanks

draginby is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome