2.2 camshaft position sensor replacement problem? - S-10 Forum
 
LinkBack Thread Tools
post #1 of 9 Old 12-20-2009, 05:14 PM Thread Starter
Registered User
 
Join Date: Dec 2009
Posts: 7

User is: s10guy71 is offline
2.2 camshaft position sensor replacement problem?

Now I need to replace the camshaft position sensor on my 98 s10 2.2, i removed the wiring harness, then the 8mm bolt, i remeved it slowly and the sensor split in 2 pieces? Now what to do? I appreciate any help. Thanks!!!

s10guy71 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-20-2009, 06:15 PM
Registered User
 
Join Date: Aug 2009
Age: 28
Posts: 713

User is: Bobthebiker is offline
Re: 2.2 camshaft position sensor replacement problem?

figure out how to get the rest of it out! how is up to you?
Bobthebiker is offline  
post #3 of 9 Old 12-21-2009, 12:19 AM Thread Starter
Registered User
 
Join Date: Dec 2009
Posts: 7

User is: s10guy71 is offline
Re: 2.2 camshaft position sensor replacement problem?

Quote:
Originally Posted by Bobthebiker View Post
figure out how to get the rest of it out! how is up to you?
Well yes I understand that, I had posted nicely asking for some advice on what to do. I am sure someone had run into this before on their truck. Do i remove the wheel well, remove the sensor, drill a small hole in the second part and pull it out with a auto body dent hammer? Does the engine have to be hot, warm or cold? What kind of metal is the second half made of? copper, steel pot metal etc? I just moved away from my home 1650 miles to be exact, now i have a issue with this and am no where close to home or my shop, where my tools and everything is at. If it was at my shop I wouldnt be posting. Thanks!
s10guy71 is offline  
post #4 of 9 Old 12-21-2009, 02:02 AM
LORDING
 
mostizzle's Avatar
 
Join Date: Aug 2009
Location: Poopin' with the door open
Posts: 33,437

User is: mostizzle is offline
Re: 2.2 camshaft position sensor replacement problem?

the other half is plastic with a magnet in the middle,my buddy here says he got his out with the engine cold,lots of penetrating oil and a pair of curved needle nose pliers. i imagine you could try screwin a long self tapping screw into it and try pullin it out that way. whatever you do you kinda gotta be careful not to push the other half all the way into the block, good luck

TelAmeriCorp
mostizzle is offline  
post #5 of 9 Old 12-21-2009, 12:37 PM
Registered User
 
Join Date: Aug 2009
Age: 28
Posts: 713

User is: Bobthebiker is offline
Re: 2.2 camshaft position sensor replacement problem?

I'd pull the wheelwell, giving you as much room to work as possible without pulling the engine. the other thing I'd do is just use pliers carefully. that plastic got brittle with age, and as a result, broke. screws are just going to make that much worse I'd think. pulling carefully will get it out.
Bobthebiker is offline  
post #6 of 9 Old 12-21-2009, 06:45 PM
4 wheels aren't as fun
 
serpentracer's Avatar
 
Join Date: Jun 2005
Location: Cincinnati, Ohio
Age: 40
Posts: 1,948

User is: serpentracer is offline
Re: 2.2 camshaft position sensor replacement problem?

I wonder if a shop vac has enough vacuum to suck it out?

02 sonoma 4.3L auto
97 sonoma 2.2L manual
serpentracer is offline  
post #7 of 9 Old 12-21-2009, 09:32 PM
LORDING
 
mostizzle's Avatar
 
Join Date: Aug 2009
Location: Poopin' with the door open
Posts: 33,437

User is: mostizzle is offline
Re: 2.2 camshaft position sensor replacement problem?

if it sucks like ur mom it'll pull the sensor and all the oil out of the crankcase with it i'm jokin bro don't get pissed , maybe if it was a badass vacuum but i doubt it. it's worth a try tho i suppose

TelAmeriCorp
mostizzle is offline  
post #8 of 9 Old 12-22-2009, 06:40 AM
4 wheels aren't as fun
 
serpentracer's Avatar
 
Join Date: Jun 2005
Location: Cincinnati, Ohio
Age: 40
Posts: 1,948

User is: serpentracer is offline
Re: 2.2 camshaft position sensor replacement problem?

she could suck the cam out of that hole.

02 sonoma 4.3L auto
97 sonoma 2.2L manual
serpentracer is offline  
post #9 of 9 Old 12-22-2009, 07:39 PM
LORDING
 
mostizzle's Avatar
 
Join Date: Aug 2009
Location: Poopin' with the door open
Posts: 33,437

User is: mostizzle is offline
Re: 2.2 camshaft position sensor replacement problem?

pics? aww who am i foolin,i don't care what she looks like

TelAmeriCorp
mostizzle is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the S-10 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.


Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome